-   Linux - Software (
-   -   artsd soundserver crash signal 11 sigsegv (alsa) (

NosLycn 05-28-2006 12:01 AM

artsd soundserver crash signal 11 sigsegv (alsa)

I'm running Debian Sid and recently did an upgrade, which shot me up to kde 3.5.2. When this happened, arts stopped working and I get one of those handly little kde crash handler windows popping up with a notification of a crash. knotify also seems to crash when using a new user (as I don't have system sounds enabled with my default user).

When I attempt to run artsd from a terminal, I get:

unix_connect: can't connect to server (unix:/tmp/ksocket-dave/suna-585d-44792ea8)

Segmentation fault

Sounds don't work if attempting to use arts. If using OSS, sound works. ESD doesn't work. Alsa appears to work in the terminal. Of course, I can only play one sound at a time with OSS, which is not good for some applications. I'm guessing it might have to do with alsa, because I get constant crash handler windows popping up (disrupting system use until I ALT-CTRL-BACKSPACE) when attempting to set the sound server to use ALSA instead of Autodetect. If attempting to set it up for OSS, I get no such errors.

I appreciate any assistance, as I have been working on fixing this for the past 8 hours. Thank you.

shame 05-28-2006 06:39 AM

There are similar reports regarding kanotix (Debian sid variant) and ubuntu dapper.
It is aparently a problem with libasound2, which was upgraded in the last few days.
If you haven't cleared the apt cache you can do this ti fix it -

cd /var/cache/apt/archives/
 dpkg -i libasound2_1.0.11-4_i386.deb

Otherwise wait til version 1.0.11-6 to see if it's fixed.

NosLycn 05-28-2006 12:13 PM

Actually, I did clear the apt cache, hoping that it would help if I were to downgrade to etch. Let's just say that when I did that I wasted a lot of time. I'm going to check the debian website to see if they have that particular package there. Be Right back.

I found 1.0.11-3, so I am going to see if that works. Just a sec.

Okay. It's set up. Now to reconfigure alsa again and get arts up and running.

Incase of that horrible pop-up blocking my ability to do anything, I will be posting this now and post a reply to my reply after restarting X.

NosLycn 05-28-2006 12:14 PM

It worked! You rock! Shame, you get 20 points and 5 gold stars!

shame 05-28-2006 04:27 PM

Glad it worked for you but I can't take the credit. It's worth while checking the kanotix forum for any problems relating to sid after upgrades. They almost always have a fix pretty quick.

All times are GMT -5. The time now is 07:55 PM.