LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-17-2004, 07:00 PM   #1
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Rep: Reputation: 15
arts problem


hi,
I am facing the following problem. I cant play two files simultaneously. While playing the second file i get the error audio output resource not available. I am using Mandrake 9.2 with kernel 2.4.22.
When I view arts status from arts Control I get the following:

Artsd should run with realtime scheduling but it does not (Is artswrapper suid root?)

Any help would be greatly appreciated.
 
Old 04-17-2004, 11:47 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
have you tried the obvious? (i.e. running arts as root?)

Simon
 
Old 04-18-2004, 12:32 AM   #3
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Original Poster
Rep: Reputation: 15
Hi,
I closed the arts server and then started artswrapper as root. Now I can only listen to sound when I start players as root. I hear nothing when I start players as normal user.. What should I do?
Also, arts is supposed to support real time processing so that we can hear to more than one player. But when I start two players simultaneously I get the error as device/dsp is buzy. Where am I going wrong?

Thank you for your help
 
Old 04-18-2004, 01:10 AM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
If I read that correctly, the system works for anyone who is root. This usually means that the part you need has root access enabled only. Look at the permissions for artsd or atswrapper or whatever the offending bit is.

If this is right, then you will probably need to either change the permission to let any user use it, or make a link to the offending part which has the same name and useful permissions.

Is this making sence?

Simon
 
Old 04-18-2004, 01:18 AM   #5
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Original Poster
Rep: Reputation: 15
Hi,
I am able to start the arts server from any user. The problem is though it is running and the arts control centre shows output being sent but I donot hear any sound! (
 
Old 04-18-2004, 01:51 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally posted by jods
Hi,
I am able to start the arts server from any user. The problem is though it is running and the arts control centre shows output being sent but I donot hear any sound! (
Right OK - you're original message said:

Quote:
From jods first message
hi,
I am facing the following problem. I cant play two files simultaneously. While playing the second file i get the error audio output resource not available. I am using Mandrake 9.2 with kernel 2.4.22.
When I view arts status from arts Control I get the following:

Artsd should run with realtime scheduling but it does not (Is artswrapper suid root?)

Any help would be greatly appreciated.
So initially it looked like you wanted to be able to play two files at the same time as any user, now it seems you want to play just one file as any user and also hear what is being played.

So... can you get sound if you are root??

A previous reply suggests that you can.

In general, if you can do something as root wot you cannot do as a user then you need to check the permissions. Common sence, right?

OTOH: if even root users have the same problem...

Simon
 
Old 04-18-2004, 02:07 AM   #7
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Original Poster
Rep: Reputation: 15
Hi,
Could you please elaborate on the permissions you mentioned in your reply. If you are talking about file permissions then they are 755 and the arts server is up and running. There is no problem in starting it. The problem is that there is no sound coming...
Also sound was coming earlier before i killed arts server and then started it as root. On starting it as root only those processes played sound which were started as root. Then i killed the root process and started it as normal user. It then started giving me problems...
 
Old 04-18-2004, 09:14 PM   #8
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Original Poster
Rep: Reputation: 15
also i can hear sound from my totem player but not mplayer or xmms
 
Old 04-19-2004, 12:40 AM   #9
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally posted by jods
Hi,
Could you please elaborate on the permissions you mentioned in your reply. If you are talking about file permissions then they are 755 and the arts server is up and running. There is no problem in starting it. The problem is that there is no sound coming...
Also sound was coming earlier before i killed arts server and then started it as root. On starting it as root only those processes played sound which were started as root. Then i killed the root process and started it as normal user. It then started giving me problems...
You havn't said which file has permission 755... you'll find your app will probably be calling other utilities - check the file permisissions of *all* the files used by your app. If you can get sound as root but not as a user then this suggests that the sound utility (or whatever) being called has root-only file-permission somewhere important.

This is almost always the case for when you can do something as root but not as a user. It is especially common when you install from source tarball as root, then switch to a user. The docs in the tarball should help some by saying what extra files you need to create... but they don't always: it's just polite.

Usually, if you need access to something only root can use (like module calls) then there is a vertual link which fits the role. If you look in your module directory you'll see many of these. The installation process would normally do this for you if the designers thought of it but there are ideological/style reasons for not doing so and expecting the user to figure it out.

Of course, there are other things that can go wrong.

You'll find clues to what is wrong by looking at what totem player does different to xmms. (Do you mean you have the same problem with xmms but not with totem?)
 
Old 04-19-2004, 02:14 AM   #10
jods
Member
 
Registered: Mar 2004
Location: Patiala, India
Distribution: Mandrake
Posts: 34

Original Poster
Rep: Reputation: 15
just one query...if there was some problem with permission, then some error message should have come.. shouldnt it?
 
Old 04-23-2004, 07:58 PM   #11
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Not nessisarily.
If you called the file from terminal or something like that then sure, but if a program was calling the file then you'd just get a message from the program that the file wasn't available or not there or something because that is what it looks like to the program.


Simon
 
Old 09-26-2004, 10:13 PM   #12
nef
Member
 
Registered: Dec 2002
Location: Mexico
Distribution: ArchLinux 0.7, Slackware 10.1
Posts: 61

Rep: Reputation: 15
Hi, I'm having the exact same problem.
I found this link, which was very helpful (no i haven't been able to solve this, but almost...)

What this guy tells you to do is:
/opt/kde/bin/artsdsp -m [program]

[program] being the command you use to usually open the program you need (xmms, mplayer, in my case skype).
I got it to work that way.

Anyway, i don't know how to get rid of the problem with artswrapper permissions, and i don't want to open every program i need to use with that command.
Still searching
 
Old 01-07-2005, 10:45 AM   #13
javeree
Member
 
Registered: Jun 2004
Location: Belgium
Posts: 49

Rep: Reputation: 15
CD to the directory where artswrapper is located (/opt/kde/bin here)
As root type
chmod u+s artswrapper

The thing is: arts wants real-time priority, but you can only set that when running as root. As most people disapprove of 'regular' programs running as root, artswrapper comes into play. artwrapper runs as root (because of the chmod above), sets the real time priority, and then starts arts in this priority (as noon-root) before it exits.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with aRts paul_mat Linux - Newbie 5 01-11-2005 01:17 AM
arts freezes! Sound only with mplayer + arts disabled metgorna Mandriva 0 09-18-2004 09:21 AM
problem with aRts Riichard Linux - Hardware 3 06-25-2004 01:18 PM
Arts problem zodmaner Slackware 1 05-30-2003 10:45 AM
(RH 8) problem with arts and KDE Tafta Linux - Distributions 0 01-31-2003 11:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration