LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-26-2015, 09:01 AM   #1
Marcello90
LQ Newbie
 
Registered: Apr 2015
Posts: 3

Rep: Reputation: Disabled
Unhappy ARToolKit


Hello to everybody,
I'm a new ubuntu 12.04 (64-bit) LTS user. In these days i'm having a lot of problems trying to install ARToolKit for markers detection(the topic of my master thesis work). I followed a lots of guide to install it:

http://www.hitl.washington.edu/artoo...serstartup.htm

http://www.linuxforums.org/forum/ubu...-x86_64-a.html

Unfortunately nothing worked.

I attach you the error of the second guide i followed(http://www.linuxforums.org/forum/ubu...-x86_64-a.html)

marcello@marcelloPC:~/ARToolKit/ARToolKit/bin$ ./simpleTest
No video config string supplied, using defaults.
libARvideo: GStreamer 0.10.36

(simpleTest:8971): GStreamer-CRITICAL **: gst_parse_launch_full: assertion `pipeline_description != NULL' failed
Segmentation fault (core dumped)

I waste last three days but i cannot solve this problem.

Can anybody help me??
 
Old 04-27-2015, 11:08 AM   #2
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Welcome to LQ.
Have you checked and met the requirements?
 
Old 04-27-2015, 02:13 PM   #3
Marcello90
LQ Newbie
 
Registered: Apr 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks for your reply,finally i solved that problem,but there is a new one now
This morning i started with this tutorial:
http://www.hitl.washington.edu/artoo...n/devmulti.htm

The problem is that after build my marker i cannot train the pc on that marker.
In that guide i should do:
./mk_patt
Enter camera parameter filename: (i put the path of file camera_para.dat)

I receive this answer:
Usin supplied video config string [videotestsrc].
libARvideo:GStreamer 0.10.36
(mk_patt:5146):Glib-GObject-WARNING**:invalid cast from 'GstVideoTestSrc' to 'GstBin'
(mk_patt:5146):GStreamer-CRITICAL **:gst_bin_get_by_name:assertion 'GST_IS-BIN (bin)' failed
pipeline has no element named 'artoolkit'!
setupCamera():Unable to open connection to camera.
main():unable to set up AR camera

I hope you have a solution for this problem!!!
Thanks for your help
 
Old 04-27-2015, 02:18 PM   #4
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
I suggest you mark this thread as SOLVED and open a new one for this new topic.
and Please use a more descriptive topic.

Last edited by Habitual; 04-27-2015 at 02:20 PM.
 
  


Reply

Tags
artoolkit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Errors while installing ARToolKit - GL/GLUT xTheLostx Linux - Software 2 08-10-2006 12:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration