-   Linux - Software (
-   -   Ardour compile on Ubuntu 8.10 (

linuxisgreat 05-15-2010 08:24 AM

Ardour compile on Ubuntu 8.10

I'm trying to compile ardour 2.8.7 from source and the compile got past the dependencies and everything else fine but it stopped at one point with these errors


libs/vamp-plugins/Onset.h:21:25: error: aubio/aubio.h: No such file or directory
In file included from libs/vamp-plugins/plugins.cpp:44:
libs/vamp-plugins/Onset.h:56: error: ISO C++ forbids declaration of ‘fvec_t’ with no type
libs/vamp-plugins/Onset.h:56: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:57: error: ISO C++ forbids declaration of ‘cvec_t’ with no type
libs/vamp-plugins/Onset.h:57: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:58: error: ISO C++ forbids declaration of ‘fvec_t’ with no type
libs/vamp-plugins/Onset.h:58: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:59: error: ISO C++ forbids declaration of ‘aubio_pvoc_t’ with no type
libs/vamp-plugins/Onset.h:59: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:60: error: ISO C++ forbids declaration of ‘aubio_pickpeak_t’ with no type
libs/vamp-plugins/Onset.h:60: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:61: error: ISO C++ forbids declaration of ‘aubio_onsetdetection_t’ with no type
libs/vamp-plugins/Onset.h:61: error: expected ‘;’ before ‘*’ token
libs/vamp-plugins/Onset.h:62: error: ‘aubio_onsetdetection_type’ does not name a type
scons: *** [libs/vamp-plugins/plugins.os] Error 1
scons: building terminated because of errors.
andrew@andrew-desktop:~/ardour-2.8.7$ scons
scons: Reading SConscript files ...
IOError: [Errno 13] Permission denied: 'config.log':
  File "/home/andrew/ardour-2.8.7/SConstruct", line 463:
    'CheckPKGVersion' : CheckPKGVersion })
  File "/usr/lib/scons/SCons/Script/", line 552:
    return apply(SCons.SConf.SConf, args, kw)
  File "/usr/lib/scons/SCons/", line 867:
    return apply(SConfBase, args, kw)
  File "/usr/lib/scons/SCons/", line 420:
  File "/usr/lib/scons/SCons/", line 681:
    fp = open(str(self.logfile), log_mode)

I have no experience compiling python.

I would not like to install from a package as the one with ubuntu is wrongly compiled and so are many others which are hosted I have heard the only way to make the problems with packaged versions stop is by compiling ardour yourself so I would still like to go ahead with it.

Could somebody help me with this error? I just want ardour to work.



thecarpy 05-15-2010 03:44 PM

1. what problems are you talking about, I have ardour here and no issues ... i installed ardourvst (with vsti support via wine). I would give that a try.

2. If you really, really wanna build:
It claims it is missing audio/audio.h ... do you have kernel headers? I would get them ... and build-essential is just a bunch of stuff required for building from source ... can't harm ;-)


sudo apt-get install linux-headers-`uname -r` build-essential

linuxisgreat 05-15-2010 04:33 PM

The problems I am refering to are badly messed up distributions of ardour from what it seems.

I ram into this problem and I can't import music either. According to that forum as I said in my last post it is a number of linux distros which come with ardour precompiled as a download option in the package manager.

Again according to the ardour forum building yourself will fix the problem.

I don't know about other distributions but I have heard canonical are a great company for service.


Whoever made that bad compile please fire the guy. :mad::banghead:

EDIT: Just tried the compile again after checking the headers, according to the build essential thing I have everything I should need


texlive-common libsdl-ttf2.0-0 libsm-dev libkonq5-templates guile-1.8
  sharutils libice-dev python-twisted-mail automake1.7 libxrandr-dev
  libexpat1-dev python-twisted-bin python-numpy rosegarden-data diffstat
  libpangomm-1.4-dev libxdamage-dev libglibmm-2.4-dev texlive wine-gecko
  libpthread-stubs0 python-pygame libart-2.0-dev libxslt1-dev ttf-mgopen
  ttf-liberation python-openssl comerr-dev libboost-python1.34.1
  libboost-signals1.34.1 python-twisted-lore patchutils libxfixes-dev lmodern
  python-twisted-news libsdl-mixer1.2 libasound2-dev
  libboost-program-options1.34.1 libxcb-render-util0-dev quilt
  libboost-date-time-dev libraptor1-dev libboost-date-time1.34.1
  texlive-pstricks x11proto-xinerama-dev texlive-base-bin libgtkmm-2.4-dev
  x11proto-render-dev libboost-signals-dev libboost-test1.34.1 libxi-dev m4
  libglademm-2.4-dev texlive-latex-base python-twisted-conch
  libboost-iostreams1.34.1 libsoundtouch1-dev texlive-fonts-recommended
  autoconf python2.5-dev libpixman-1-dev python-twisted-words
  libboost-wave1.34.1 python-dev python-twisted-web libboost-graph1.34.1
  libboost-thread-dev libkrb5-dev libfontconfig1-dev liblapack3gf libogg-dev
  python-twisted x11proto-kb-dev libgnomecanvasmm-2.6-dev x11proto-randr-dev
  python-serial texlive-generic-recommended cdbs libboost-program-options-dev
  dolphin libxinerama-dev libcurl4-openssl-dev texlive-latex-recommended
  libboost-test-dev libboost-wave-dev texlive-latex-recommended-doc
  lilypond-data xtrans-dev intltool libatk1.0-dev dvipdfmx tetex-bin
  latex-beamer python-ogg python-pam libcairomm-1.0-dev
  libboost-serialization-dev libflac-dev prosper x11proto-input-dev
  libxcb-xlib0-dev tipa xmms2-plugin-id3v2 texlive-latex-base-doc latex-xcolor
  python-eyed3 x11proto-fixes-dev fdupes libkonq5 libsigc++-2.0-dev liblo0-dev
  python-cddb libboost-regex-dev kfind kdebase-bin libglade2-dev
  x11proto-xext-dev libssl-dev libboost-thread1.34.1 libxext-dev libidn11-dev
  ladspa-sdk x11proto-damage-dev libsamplerate0-dev libglib2.0-dev
  texlive-fonts-recommended-doc pgf zlib1g-dev libxml2-dev libcairo2-dev flac
  xmms2-plugin-alsa python-twisted-core libpango1.0-dev libfreetype6-dev
  libxau-dev lilypond libxmmsclient4 liblrdf0-dev libblas3gf lilypond-doc
  python-pyvorbis libfftw3-dev xmms2-core texlive-base python-twisted-names
  libboost-serialization1.34.1 vorbis-tools libkadm55 libxcomposite-dev
  libxcb-render0-dev python-twisted-runner libxrender-dev
  libboost-filesystem-dev xmms2-plugin-vorbis libxmmsclient-glib1
  texlive-doc-base libgfortran3 xmms2-plugin-mad libxft-dev libx11-dev scons
  texlive-base-bin-doc libicu-dev libobjc2 libboost-regex1.34.1
  x11proto-composite-dev kdebase-data libboost-dev python-pyopenssl winbind
  libboost-doc autotools-dev libxcb1-dev libgtk2.0-dev libboost-iostreams-dev
  libgnomecanvas2-dev python-pyogg texlive-pstricks-doc tex-common libjack-dev
  x11proto-core-dev xmms2-client-cli python-crypto libxdmcp-dev
  libpthread-stubs0-dev libboost-graph-dev libxcursor-dev dh-buildinfo
  libboost-filesystem1.34.1 texinfo python-opengl libboost-python-dev
  libldap2-dev libpng12-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

and I still get the same aubio.h errors. What is this missing audio thing and how can I fix it? Could it be a typo?

thecarpy 05-15-2010 06:23 PM

What CPU arch are you on? post the output of `uname -r` ... in the worst case, I will build it for you ... and send you it. Funny, I have no issues importing wavs ... have not tested other things ... I have already copmpiled it fine on linux-86 (not 64 Bit), but I have debian squeeze 64 Bit, and there it works find with wav and flac ... I installed ardour on my work system (I had ardour on my home system - I multi-boot as I work from home). It works out of the box with wav and flac, no issues at all ... maybe it is just the ubuntu package that is broken ...

linuxisgreat 05-17-2010 06:45 AM


andrew@andrew-desktop:~$ uname -r

That's the output from uname -r


Anyway I don't think it's a build problem it looks to me like a file is missing but I don't know where it is or how to get to it. Is it a problem in the Sconstruct file or something with my system? I don't know that much about python but I think there is something about the expected token that is doing it.

thecarpy 05-17-2010 07:57 AM

This is compiling c++, it has nothing to do with python. It cannot find audio/audio.h ... look at

linuxisgreat 05-19-2010 01:46 PM


It works fine now all I had to do was install libaubio.

Also took me a while to figure out where the install put the executable binary file but it was in /usr/local/bin I made a link to it in the sound and video menu.

Also I did a search for the ardour icons so I could change it to the logo in the men.

All times are GMT -5. The time now is 09:47 AM.