LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2013, 12:53 PM   #1
vaj-bor
LQ Newbie
 
Registered: May 2013
Posts: 7

Rep: Reputation: Disabled
Lightbulb Aquasim:How insert mac protocol to aquasim


Aquasim:How insert mac protocol to aquasim
I added new protocol to Aquasim but not configure appended file example packet.h and etc
Please help me
thanks
 
Old 05-27-2013, 01:38 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Welcome to LQ.
Quote:
How insert mac protocol to aquasim
Please see ns-2.30/mac/ mac-802_3** mac-802_11** : I.e. mac** is already present.


Quote:
..added new protocol to Aquasim but not configure appended file example packet.h and etc
Please rephrase : The text is not understandable.
Suggest : Break up your explanation into three separate sentences. In three lines.

-
 
Old 05-27-2013, 11:33 PM   #3
vaj-bor
LQ Newbie
 
Registered: May 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi
I can not find this path(ns-2.30/mac/ mac-802_3** mac-802_11** )
please insert link for this path
 
Old 05-28-2013, 12:12 AM   #4
vaj-bor
LQ Newbie
 
Registered: May 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi
I add new protocol to aquasim
but when I run the tclscript with new protocol
NS doesnt new protocol
beacuse I do not know the configuration files
example:
packet.h
ns-defult.tcl
ns-lib.tcl
ns-commnand.cc
and etc
Please help me
 
Old 05-28-2013, 01:28 AM   #5
vaj-bor
LQ Newbie
 
Registered: May 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi
I change these files:
1-packet.h:

PT_SFAMA,

name_[PT_SFAMA] = "mac";

2-ns-default.tcl:

Mac/UnderwaterMac/SFAMA set max_burst 1
Mac/UnderwaterMac/SFAMA set max_backoff_slots_ 4
Mac/UnderwaterMac/SFAMA set guard_time_ 0.00001

3-ns-packet.tcl:

SFAMA

4-MakeFile:
underwatersensor/uw_mac/slotted-fama/sfama.o \

But I dont run tclscript with SFAMA
Please help me
 
Old 05-28-2013, 02:07 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
# 3.
Aquasim : http://www.engr.uconn.edu/~yiz09005/Aqua-Sim-1.0.tgz
mkdir Aquasim ; cd Aquasim/ ; tar xvf Aqua-Sim-1.0.tgz :
Then you have Aquasim/ns-2.30/mac/ mac-802_11.cc mac-802_11.h mac-802_3.cc mac-802_3.h

# 4 : "beacuse I do not know the configuration files"
What is it that you think is a configuration file ?

#4 : "I add new protocol to aquasim"
Please provide a link to the protocol : Where did you find it ?

#4 : packet.h, ns-defult.tcl, ns-lib.tcl are not really configuration files.
ns-command.cc : Unknown file.

#5 : SFAMA : A link to the documention, please.

-
 
Old 05-28-2013, 05:00 AM   #7
vaj-bor
LQ Newbie
 
Registered: May 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Question hi

this link is sfama and header :
http://up.toca.ir/images/3u96l4e9h82y7zknf1e.rar
this link is tcl script:
http://up.toca.ir/images/j9sfeeplsntfv1ib5xq.rar
 
Old 10-09-2015, 05:53 PM   #8
Mralfouzan
LQ Newbie
 
Registered: Oct 2015
Posts: 15

Rep: Reputation: Disabled
want the tcl file for lotted FAMA, uwan-mac and tman

Dear there,

I would like to get the Slotted FAMA, uwan-mac and tman tcl for underwater sensor network please ....
 
Old 10-10-2015, 04:24 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Post #8, @Mralfouzan : Welcome to LQ.

http://obinet.engr.uconn.edu/wiki/index.php/Aqua-Sim >>>
"" Implemented Protocols, MAC :
* ALOHA
* Broadcast MAC
* GOAL: a geo-routing aware MAC integrating VBF and handshake scheme in cross-layer approach
* Slotted-FAMA: a MACA like handshake-based MAC
* UWAN-MAC
* COPE-MAC
* R-MAC ""

``uwan-mac`` : See ns-2.30/underwatersensor/uw_tcl/uwan-mac-random.tcl

"tman" : Unknown term. Please elaborate.

"Slotted FAMA" : The only example we have is the post #7 "test.tcl" (**5xq.rar).
A copy of test.tcl is available as aqua__sfama.tcl.txt , here
https://drive.google.com/file/d/0B7S...ew?usp=sharing
*** The file doesn't work as is. May be you can edit it.

The "patch" {sfama and header} 3u96l4e9h82y7zknf1e.rar mentioned in post #7 :
.. Will conflict with other AquaSim file(s).
3u96l4e9h82y7zknf1e.rar : Available as aquasim-sfama_ns230__2015-files.tar
https://drive.google.com/file/d/0B7S...ew?usp=sharing


-
 
Old 10-10-2015, 04:54 AM   #10
Mralfouzan
LQ Newbie
 
Registered: Oct 2015
Posts: 15

Rep: Reputation: Disabled
UWAN-MAC & tmac

Dear knudfl,

Thanks you for sending the S-FAMA ....

if you try to run UWAN-MAC by ns-2.30/underwatersensor/uw_tcl/uwan-mac-random.tcl ...... it doesnt work ?

Regarding to the tmac .... if ns-2.30/underwatersensor/uw_tcl/tmac-example.tcl .... it also doesnt work ?

So, What should I do in order to run both MAC protocols properly ?

Thanks for your helping
 
Old 10-18-2015, 05:09 AM   #11
Mralfouzan
LQ Newbie
 
Registered: Oct 2015
Posts: 15

Rep: Reputation: Disabled
UWAN-MAC Protocol

Dear there,

I am really struggling to run the example of UWAN-MAC Protocol .... and I have faced this problem ... (Segmentation fault (core dumped))...

Could anyone helps me to fix that.

thank you
 
Old 10-21-2015, 09:55 AM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Re #10, #11.

All contemporary / supported Ubuntu versions can no more be used for Aqua-Sim.
Versions 12.04, 14.04 etc. some time ago got a libc6 update that made it impossible.

The unsupported Ubuntu 10.10 - i386 can be used.

And all simulations ..
Code:
{ broadcastMAC_example.tcl  kinematic.tcl        uw_rwp.tcl
GOAL-random.tcl             rmac-example.tcl     vbf_example_5.tcl
GOAL-string.tcl             tmac-example.tcl     vbf_example_6.tcl
hop_by_hop_VBF_example.tcl  uwan-mac-random.tcl  vbva_example.tcl }
... are working OK.


-

Last edited by knudfl; 10-21-2015 at 02:37 PM.
 
Old 10-21-2015, 01:32 PM   #13
Mralfouzan
LQ Newbie
 
Registered: Oct 2015
Posts: 15

Rep: Reputation: Disabled
do you mean I should use Ubuntu 10.10 in order to run uwan-mac-random.tcl example ...
 
Old 10-21-2015, 02:33 PM   #14
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Re #13.

Yes. The easy way is to install `VirtualBox' in your <unknown> Ubuntu.
... And then install Ubuntu 10.10 - i386 into VirtualBox.

Ubuntu 10.10 - i386 http://old-releases.ubuntu.com/relea...sktop-i386.iso
>>> ubuntu-10.10-desktop-i386.iso


-
 
Old 10-22-2015, 09:07 AM   #15
Mralfouzan
LQ Newbie
 
Registered: Oct 2015
Posts: 15

Rep: Reputation: Disabled
Hello knudfl,

I installed Ubuntu 10.10, but I have some problems with installation.

when I used "sudo ./install" .... the problem shown down:


ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.12 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems


how it can be fixed ?
 
  


Reply

Tags
aquasim, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NS2 and Aquasim Preeti1910 Linux - Software 48 10-15-2016 01:09 PM
wireless ns/aquasim varshitha Linux - Wireless Networking 163 02-14-2015 06:04 PM
aquasim question MonaJalili Linux - Wireless Networking 6 05-12-2013 06:59 AM
Details for setting up PC for using Aquasim exploreuwsn Linux - Newbie 15 02-14-2013 12:10 PM
aquasim varshitha Linux - Wireless Networking 0 01-29-2011 09:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration