LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   apt + readline + postfix + etc... (https://www.linuxquestions.org/questions/linux-software-2/apt-readline-postfix-etc-399381/)

Sapient 01-04-2006 05:29 AM

apt + readline + postfix + etc...
 
When attempting to install readline I get an error of a previous version. readline-4x has many dependancies. How do I update this package without first removing the 4 x version?




rpm -ivh /usr/local/tarfiles/readline-5.0-1.2.i586.rpm
Preparing... ########################################### [100%]
file /usr/share/info/history.info.gz from install of readline-5.0-1.2
conflicts with file from package readline-4.3-306.8
file /usr/share/info/readline.info.gz from install of readline-5.0-1.2
conflicts with file from package readline-4.3-306.8


Thanks

Sapient 01-04-2006 06:13 AM

How do I resolve the dependancies?

rpm -Uivh /usr/local/tarfiles/readline-5.0-1.2.i586.rpm
error: Failed dependencies:
libhistory.so.4 is needed by (installed) ctapi-cyberjack-1.0.0-173.1
libhistory.so.4 is needed by (installed) libxml2-2.6.7-28.7
libhistory.so.4 is needed by (installed) libgda-1.0.3-54.4
libhistory.so.4 is needed by (installed) php4-readline-4.3.4-43.8
libhistory.so.4 is needed by (installed) bash-2.05b-305.9
libreadline.so.4 is needed by (installed) bc-1.06-744.1
libreadline.so.4 is needed by (installed) guile-1.6.4-124.1
libreadline.so.4 is needed by (installed) fvwm2-2.5.9-42.1
libreadline.so.4 is needed by (installed) ctapi-cyberjack-1.0.0-173.1
libreadline.so.4 is needed by (installed) dump-0.4b35-41.1
libreadline.so.4 is needed by (installed) cadaver-0.22.2-1.2
libreadline.so.4 is needed by (installed) units-1.74-328.1
libreadline.so.4 is needed by (installed) amanda-2.4.4p2-55.1
libreadline.so.4 is needed by (installed) gnuplot-3.7.3-256.1
libreadline.so.4 is needed by (installed) libxml2-2.6.7-28.7
libreadline.so.4 is needed by (installed) heimdal-tools-0.6.1rc3-55.9
libreadline.so.4 is needed by (installed) python-2.3.3-88.9
libreadline.so.4 is needed by (installed) heimdal-lib-0.6.1rc3-55.15
libreadline.so.4 is needed by (installed) gdb-6.3-16.4
libreadline.so.4 is needed by (installed) parted-1.6.21-4.2
libreadline.so.4 is needed by (installed) postgresql-7.4.8-0.6
libreadline.so.4 is needed by (installed) postgresql-contrib-7.4.8-0.6
libreadline.so.4 is needed by (installed) postgresql-devel-7.4.8-0.6
libreadline.so.4 is needed by (installed) postgresql-server-7.4.8-0.6
libreadline.so.4 is needed by (installed) heimdal-0.6.1rc3-55.18
libreadline.so.4 is needed by (installed) libgda-1.0.3-54.4
libreadline.so.4 is needed by (installed) quagga-0.96.4-31.7
libreadline.so.4 is needed by (installed) sax2-4.8-103.28
libreadline.so.4 is needed by (installed) samba-client-3.0.20b-3.4
libreadline.so.4 is needed by (installed) ipsec-tools-0.3.3-1.9
libreadline.so.4 is needed by (installed) ocfs2-tools-1.1.4-0.5
libreadline.so.4 is needed by (installed) php4-readline-4.3.4-43.8
libreadline.so.4 is needed by (installed) bash-2.05b-305.9
readline = 4.3-306.8 is needed by (installed) readline-devel-4.3-306.8

Sapient 01-04-2006 09:03 AM

This can also be done through Yast where options for ignore, down-grade, delete can be selected based on the dependency/package. What will be the impact? Will I need to recompile each dependency?


Thanks


All times are GMT -5. The time now is 12:51 AM.