-   Linux - Software (
-   -   apt-get upgrade > Xorg 7 Installed > X won't start (

DaBlade 06-03-2006 07:41 AM

apt-get upgrade > Xorg 7 Installed > X won't start
Hi. I'm running Debian Etch. Last night, I did an apt-get upgrade, which installed a new version of Xorg (7). After I rebooted (I did that later, not because of the upgrade), X refused to start. I tried reinstalling the nVIDIA driver (using the official installer as I always do), but that didn't help. I joined #debian on freenode and there was another guy there at the same time with the same problem, so I'm guessing I'm far from the only one who's had this happen to him/her.

Can anyone give me a hand please?
Thanks in advance for any help you may get.

acid_kewpie 06-03-2006 08:28 AM

you need to check your logs for useful errors, /var/log/Xorg.0.log

DaBlade 06-03-2006 08:47 AM

The log file is huge. I ran startx instead, and here's the bottom of its output:
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

DaBlade 06-03-2006 08:58 AM

I solved the problem - Had to run the nVIDIA installer with --x-module-path=/usr/lib/xorg/modules
(I found the solution in the Debian wiki)

All times are GMT -5. The time now is 03:33 PM.