LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-22-2008, 02:51 AM   #1
tklima
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
apt-get upgrade rollback


Hi,

I wanted to upgrade python2.4-minimal and python2.4 packages, but I got this error

Code:
Setting up python2.4-minimal (2.4.4-3+etch1) ...
Linking and byte-compiling packages for runtime python2.4...
file does not exist: /usr/lib/apache2/modules/mod_python.so
pycentral: pycentral rtinstall: package libapache2-mod-python: error byte-compiling files (1)
pycentral rtinstall: package libapache2-mod-python: error byte-compiling files (1)
dpkg: error processing python2.4-minimal (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python2.4:
 python2.4 depends on python2.4-minimal (= 2.4.4-3+etch1); however:
  Package python2.4-minimal is not configured yet.
dpkg: error processing python2.4 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python2.4-minimal
 python2.4
I also tried apt-get -f and dpkg-reconfigure --force, but nothing helped.
So I decided not to upgrade these packages and set them to hold.
But everytime I install or upgrade another package I get the message above.
Is there a way how to roll back to the previous state?

Thanks for your answers.
Tom
 
Old 04-22-2008, 10:01 PM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
The apt how-to might come in handy about now, eh?
 
Old 04-23-2008, 05:32 AM   #3
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
Go see this thread on message #3, think it's the same kind of problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howabout apt-get update ; apt-get upgrade -f -y --force-yes in the crontab every week frenchn00b Debian 1 04-05-2008 07:47 AM
apt-get upgrade stopped, how can I remove packages before continuing upgrade? [KIA]aze Linux - Newbie 4 05-31-2007 07:49 AM
Question about 'apt-get upgrade' versus 'apt-get install' eur0dad Red Hat 8 07-16-2006 05:41 PM
I cannot upgrade Debian sarge by apt-get upgrade nos1833 Debian 9 07-05-2006 08:41 AM
What's the difference between apt-get upgrade and apt-get dist-upgrade? davidas Linux - Newbie 4 04-04-2004 08:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration