LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-21-2004, 04:19 PM   #1
limiter
Member
 
Registered: Oct 2003
Posts: 47

Rep: Reputation: 16
apt-get broken?


yeah, i'm not too sure of what i did, i tried to install a newer version of Korganizer and suddenly there are loads of unmet dependencies or something.
What follows is the output of "apt-get install kdepim"
Code:
root@0[root]# apt-get install kdepim
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  kdelibs-bin: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  kdelibs4: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  kdepim: Depends: kaddressbook (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kalarm (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kandy (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: karm (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kdepim-kfile-plugins (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kdepim-kio-plugins (>= 4:3.2.1-1) but it is not going to be installed
          Depends: kgpgcertmanager (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kmail (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kmailcvt (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: knode (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: knotes (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: konsolekalendar (>= 4:3.2.1-1) but it is not going to be installed
          Depends: kontact (>= 4:3.2.1-1) but it is not going to be installed
          Depends: korganizer (>= 4:3.2.1-1) but it is not going to be installed
          Depends: korn (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: kpilot (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: ksync (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: ktnef (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libkcal2 (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libkdenetwork2 (>= 4:3.2.1-1) but 4:3.1.4-1 is to be installed
          Depends: libkdepim1 (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libkdgantt0 (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libkgantt0 (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libkpimexchange1 (>= 4:3.2.1-1) but it is not going to be installed
          Depends: libksieve0 (>= 4:3.2.1-1) but it is not going to be installed
  koffice-libs: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  kopete: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  libscrollkeeper0: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  libxml-libxslt-perl: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  scrollkeeper: Depends: libxslt1.1 (>= 1.1.2) but it is not going to be installed
  xlibs-dev: Depends: libice-dev but it is not going to be installed
             Depends: libsm-dev but it is not going to be installed
             Depends: libx11-dev but it is not going to be installed
             Depends: libxext-dev but it is not going to be installed
             Depends: libxi-dev but it is not going to be installed
             Depends: libxmu-dev but it is not going to be installed
             Depends: libxmuu-dev but it is not going to be installed
             Depends: libxp-dev but it is not going to be installed
             Depends: libxpm-dev but it is not going to be installed
             Depends: libxrandr-dev but it is not going to be installed
             Depends: libxt-dev but it is not going to be installed
             Depends: libxtrap-dev but it is not going to be installed
             Depends: libxtst-dev but it is not going to be installed
             Depends: libxv-dev but it is not going to be installed
             Depends: pm-dev but it is not going to be installed
             Depends: x-dev but it is not going to be installed
  xlibs-static-dev: Depends: x-dev but it is not going to be installed
                    Depends: libxext-dev but it is not going to be installed
                    Depends: libxv-dev but it is not going to be installed
                    Depends: libx11-dev but it is not going to be installed
  xlibs-static-pic: Depends: libxext-dev but it is not going to be installed
                    Depends: libxv-dev but it is not going to be installed
                    Depends: libx11-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


What follows if the output of "apt-get -f install"
Code:
root@0[root]# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libice-dev libice6 libsm-dev libsm6 libx11-6 libx11-dev libxext-dev libxext6
  libxi-dev libxi6 libxmu-dev libxmu6 libxmuu-dev libxmuu1 libxp-dev libxp6
  libxpm-dev libxpm4 libxrandr-dev libxrandr2 libxslt1.1 libxt-dev libxt6
  libxtrap-dev libxtrap6 libxtst-dev libxtst6 libxv-dev libxv1 pm-dev x-dev
The following packages will be REMOVED:
  libxslt1
The following NEW packages will be installed:
  libice-dev libice6 libsm-dev libsm6 libx11-6 libx11-dev libxext-dev libxext6
  libxi-dev libxi6 libxmu-dev libxmu6 libxmuu-dev libxmuu1 libxp-dev libxp6
  libxpm-dev libxpm4 libxrandr-dev libxrandr2 libxslt1.1 libxt-dev libxt6
  libxtrap-dev libxtrap6 libxtst-dev libxtst6 libxv-dev libxv1 pm-dev x-dev
0 upgraded, 31 newly installed, 1 to remove and 461 not upgraded.
19 not fully installed or removed.
Need to get 6884kB of archives.
After unpacking 17.8MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 ftp://ftp.us.debian.org unstable/main libice6 4.3.0-7 [162kB]
Get:2 ftp://ftp.us.debian.org unstable/main libsm6 4.3.0-7 [140kB]
Get:3 ftp://ftp.us.debian.org unstable/main libx11-6 4.3.0-7 [672kB]
Get:4 ftp://ftp.us.debian.org unstable/main libxext6 4.3.0-7 [147kB]
Get:5 ftp://ftp.us.debian.org unstable/main libxt6 4.3.0-7 [276kB]
Get:6 ftp://ftp.us.debian.org testing/main libxslt1.1 1.1.2-3 [173kB]
Get:7 ftp://ftp.us.debian.org unstable/main x-dev 4.3.0-7 [177kB]
Get:8 ftp://ftp.us.debian.org unstable/main libxext-dev 4.3.0-7 [207kB]
Get:9 ftp://ftp.us.debian.org unstable/main libxv1 4.3.0-7 [131kB]
Get:10 ftp://ftp.us.debian.org unstable/main libx11-dev 4.3.0-7 [1323kB]
Get:11 ftp://ftp.us.debian.org unstable/main libxv-dev 4.3.0-7 [151kB]
Get:12 ftp://ftp.us.debian.org unstable/main libxi6 4.3.0-7 [138kB]
Get:13 ftp://ftp.us.debian.org unstable/main libice-dev 4.3.0-7 [166kB]
Get:14 ftp://ftp.us.debian.org unstable/main libsm-dev 4.3.0-7 [137kB]
Get:15 ftp://ftp.us.debian.org unstable/main libxi-dev 4.3.0-7 [192kB]
Get:16 ftp://ftp.us.debian.org unstable/main libxmu6 4.3.0-7 [169kB]
Get:17 ftp://ftp.us.debian.org unstable/main libxt-dev 4.3.0-7 [577kB]
Get:18 ftp://ftp.us.debian.org unstable/main libxmu-dev 4.3.0-7 [179kB]
Get:19 ftp://ftp.us.debian.org unstable/main libxmuu1 4.3.0-7 [130kB]
Get:20 ftp://ftp.us.debian.org unstable/main libxmuu-dev 4.3.0-7 [123kB]
Get:21 ftp://ftp.us.debian.org unstable/main libxp6 4.3.0-7 [138kB]
Get:22 ftp://ftp.us.debian.org unstable/main libxp-dev 4.3.0-7 [139kB]
Get:23 ftp://ftp.us.debian.org unstable/main libxpm4 4.3.0-7 [153kB]
Get:24 ftp://ftp.us.debian.org unstable/main libxpm-dev 4.3.0-7 [152kB]
Get:25 ftp://ftp.us.debian.org unstable/main libxrandr2 4.3.0-7 [130kB]
Get:26 ftp://ftp.us.debian.org unstable/main libxrandr-dev 4.3.0-7 [131kB]
Get:27 ftp://ftp.us.debian.org unstable/main libxtrap6 4.3.0-7 [139kB]
Get:28 ftp://ftp.us.debian.org unstable/main libxtrap-dev 4.3.0-7 [145kB]
Get:29 ftp://ftp.us.debian.org unstable/main libxtst6 4.3.0-7 [133kB]
Get:30 ftp://ftp.us.debian.org unstable/main libxtst-dev 4.3.0-7 [131kB]
Get:31 ftp://ftp.us.debian.org unstable/main pm-dev 4.3.0-7 [120kB]
Fetched 6884kB in 1m46s (64.8kB/s)
(Reading database ... 106557 files and directories currently installed.)
Unpacking libice6 (from .../libice6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libice6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libICE.so.6.3', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libsm6 (from .../libsm6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libsm6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libx11-6 (from .../libx11-6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libx11-6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxext6 (from .../libxext6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxext6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxt6 (from .../libxt6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxt6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libice6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libsm6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libx11-6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxext6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxt6_4.3.0-7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@0[root]#



Can anyone help me get my apt program working again?
 
Old 03-21-2004, 04:44 PM   #2
noeffort
LQ Newbie
 
Registered: Feb 2004
Posts: 27

Rep: Reputation: 15
It actually is working but is telling you that the version of korganizer you installed manually had created those broken dependencies.

It would be best to back out the install you made previosly, then apt-get -f update and then see if you can get what you want from apt-get upgrade kde-pim
 
Old 03-21-2004, 05:00 PM   #3
limiter
Member
 
Registered: Oct 2003
Posts: 47

Original Poster
Rep: Reputation: 16
i backed out of both installs by uninstalling kdepim, and then uninstalled Korganizer. but it still does the same thing. How can i fix these dependencies?
the problem seems to be when unpacking these libraries:
Code:
dpkg: error processing /var/cache/apt/archives/libice6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libICE.so.6.3', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
why doesn't this package install?
 
Old 03-21-2004, 05:02 PM   #4
limiter
Member
 
Registered: Oct 2003
Posts: 47

Original Poster
Rep: Reputation: 16
btw, apt won't let me install anything else until i take care of this problem its having now.
 
Old 03-21-2004, 05:26 PM   #5
limiter
Member
 
Registered: Oct 2003
Posts: 47

Original Poster
Rep: Reputation: 16
i found a solution online... thanks anyways people

Yeah quite a lovely mess ain't it I was real impressed. You need to change to the /var/cache/apt/archives and then use dpkg -i --force-overwrite all_of_the_packages_in_errors_output use the entire name of the packages when doing this (dpkg -i --force-overwrite libice6_4.3.0-2_i386.deb libx11-6_4.3.0-2_i386.deb ....). Then once you are done dpkg --configure -a for the extra errors you will get due to some packages not being already configured. You may also want to remove and purge some small program then reinstall it just to make certain there a no stragglers that did not get configured.
http://www.knoppix.net/forum/viewtopic.php?p=39150
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken apt-get ebenh Debian 12 04-11-2012 12:36 PM
apt-get is broken irvken Linux - Software 3 12-12-2004 04:18 AM
apt-get seems broken jon_k Linux - Software 1 12-09-2004 06:20 PM
apt-get is broken, please help! agentforsythe Linux - General 3 01-12-2004 03:24 AM
broken apt-get mindcry Linux - Software 0 05-24-2003 09:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration