-   Linux - Software (
-   -   application shortcut (

trumpetdork 04-17-2005 02:02 PM

application shortcut
I am currently only able to start an application via the command line, but I'd like to put a graphical icon on my desktop and on the menus. I tried to create an applicaiton launcher and tchecked "run in terminal" since that's how the application starts before loading the GUI, but the application ends right away if launched with the icon, How to I create a shortcut that won't stop running?

reddazz 04-17-2005 02:19 PM

What application are you trying to create a shortcut for and on what desktop environment. Have you tried creating the shortcut with the option to run the program in a terminal disabled.

trumpetdork 04-18-2005 08:54 PM

It's a short cut for media players, the office tools like the different parts of OpenOffice, etc...I like having them on the desktopas well as on the menus. The enviroment is Novell Linux Desktop (SuSE). I haven't tried the non-terminal option yet.

reddazz 04-19-2005 12:37 AM

I meant are you using KDE or GNOME. You can drag an application fom the menu to the desktop and select "copy to desktop" and a shortcut should be created.

kencaz 04-19-2005 12:50 AM

Don't know exactly what your trying to launch but sounds like you want terminal -noclose not terminal disabled.

I had that problem with Mplayer I created a shortcut and it would launch but no way to control accept kill it. I found that If I created a small script to open mplayer in a new console it worked fine.

konsole --noclose -e program

of course program would be whatever application your trying to launch. If this works then add the --noclose -e to the properties of your existing shortcut.


leosgb 04-19-2005 05:58 PM

i add the "-noclose -e" option but all i get now is a blank terminal that i cant use... This is my question:

Could you please help me?

---- EDITED----
By the way, i launch it from the terminal as "program &" so it actually doesnt need the terminal, right? If i add a "&" as option the terminal closes and i get error 127. What does that mean?

All times are GMT -5. The time now is 06:46 PM.