LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-29-2016, 05:49 AM   #1
jastisreedevi
LQ Newbie
 
Registered: Apr 2015
Posts: 3

Rep: Reputation: Disabled
Appletviewer not working in RHEL 4


Hi

We are trying to execute applet programs by using appletviewer command.There is a message command not found coming on RHEL 4.we are using java 1.4.2 version and also installed gnome-applets-2.8.0-5.i386.rpm [/U][/B]package.I tried to open in a browser ,there pluggins needed message coming.

So far I have used commands update,later locate appletviewer to find any appletviewer files are there on my desktop.Here it is showing the message.

#locate appletviewer
o/p
/usr/lib/kde3/kjavaappletviewer.so
/usr/lib/kde3/kjavaappletviewer.la
/usr/share/services/kjavaappletviewer.desktop

I didn't understand what these files and what to do to make appletviewer work on my system...

#whereis java
java:/usr/bin/java /etc/java /usr/lib/java /usr/share/java

This is the o/p I got for java location.

can anybody help what to do for working applets on my system.
Thank you.
 
Old 06-29-2016, 07:15 AM   #2
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Have you utilized your support options?
You're paying for it, yes?

Don't use phonespeak.
If o/p is output, type output. Thank you.
 
Old 06-29-2016, 08:09 AM   #3
Upuetz
Member
 
Registered: May 2016
Location: Aachen
Distribution: Debian, CentOS, Ubuntu, Raspian, tinycore
Posts: 59

Rep: Reputation: Disabled
I wonder if you mix up "applets". There are applets for other programs - which are extensions. Gnome-applets is that.
And then there are java applets which are small java programs which run in your browser.

Which one do you want to use?
 
Old 06-29-2016, 09:04 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,477

Rep: Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246Reputation: 7246
Quote:
Originally Posted by jastisreedevi View Post
Hi
We are trying to execute applet programs by using appletviewer command.There is a message command not found coming on RHEL 4.we are using java 1.4.2 version and also installed gnome-applets-2.8.0-5.i386.rpm [/U][/B]package.I tried to open in a browser ,there pluggins needed message coming.

So far I have used commands update,later locate appletviewer to find any appletviewer files are there on my desktop.Here it is showing the message.

#locate appletviewer
o/p
/usr/lib/kde3/kjavaappletviewer.so
/usr/lib/kde3/kjavaappletviewer.la
/usr/share/services/kjavaappletviewer.desktop

I didn't understand what these files and what to do to make appletviewer work on my system...

#whereis java
java:/usr/bin/java /etc/java /usr/lib/java /usr/share/java

This is the o/p I got for java location. can anybody help what to do for working applets on my system.
A few things:
  • Don't use RHEL *AT ALL* for a desktop system with a GUI. While it can work, it's designed FOR SERVERS...loading 'applets' may be problematic.
  • RHEL 4 is OLD and UNSUPPORTED....TOTALLY. Stop where you are, and load the latest version, 7.x.
  • ..unless you don't plan on PAYING FOR RHEL, then you don't need to use it AT ALL. Load CentOS instead, but only....
  • ..if you NEED a server-class distro. Chances are, YOU DO NOT.
What is the goal of this machine? What do you have it for? If it's for learning purposes, load Fedora 24 (latest), to remain within the RHEL ecosystem...Mint if not. BOTH will let you do pretty much everything that RHEL can do. There may be some differences for higher-end hardware support, but otherwise, you can load/configure the same services.
 
Old 06-29-2016, 03:06 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
as above
rhel4.9 is past it's END OF LIFE ( it's 10 year life span ENDED )

also java 1.4 is a antique , it is two generations out of data

contact redhat sales and BUY $$$ RHEL 7.2
or use the free CentOS 7.2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IPtables rules are not working in RHEL- 6.5 and it was working in RHEL5.9 sekarlinux Linux - Newbie 2 02-14-2015 01:45 PM
appletviewer: Help with java applet Fredstar Programming 1 06-17-2006 11:09 PM
appletviewer command is not found (URGENT) discuss Programming 2 05-21-2006 10:48 AM
Java AppletViewer DavidTempler Programming 6 04-08-2004 01:22 PM
Java Appletviewer... jetblackz Programming 3 01-24-2003 12:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration