LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   appache servername (https://www.linuxquestions.org/questions/linux-software-2/appache-servername-47170/)

illtbagu 02-25-2003 10:52 PM

appache servername
 
i tried to follow exactly what the help files said for apache as far as configuring my server name. its a little confusing. I'm using no-ip for my "dynamic dns partner".

here is what i interpret the server name to be according to the help
http://www.schrock.no-ip.info:80

here is the error I'm getting when i try to start the service

httpd failed. The error was: Starting httpd: Syntax error on line 323 of /etc/httpd/conf/httpd.conf:
The port number "http://www.schrock.no-ip.info:80" is outside the appropriate range (i.e., 1..65535).
[FAILED]

line no 323 says
ServerName http://www.schrock.no-ip.info:80


thanks for any advise,
AD

Crashed_Again 02-25-2003 11:28 PM

Try changing it to

ServerName www.schrock.no-ip.info

I don't think you have to specify port 80. Then do:

/etc/init.d/httpd restart

I think your problem was having the http:// before the server name.

illtbagu 02-25-2003 11:52 PM

thanks, im getting a error after using your suggestion. when i restart the service by /etc/init.d/httpd restart. i do have the mod_ssl cryptography support for the apache web server installed on my red hat machine. should i have this installed i took a guess when i installed the apache web server.

here is the error

[joe@dhcp-487-17 joe]$ /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 116 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file '/etc/httpd/conf/ssl.crt/server.crt' does not exist or is empty
[FAILED]

thanks again,
AD

Crashed_Again 02-25-2003 11:56 PM

Well that error is dealing with the ssl certificates. What you have to do is generate your digital certificates or comment out the lines dealing with ssl. If you just want to get the web server running comment out the lines. You won't have ssl but port 80 should work. Then find a nice little tutorial on creating digital certificates. I got mine out of a book.

illtbagu 02-25-2003 11:56 PM

ok never mind i uninstalled the ssl and there is a new error

[joe@dhcp-487-17 joe]$ /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
[FAILED]
[joe@dhcp-487-17 joe]$

illtbagu 02-25-2003 11:58 PM

huhhh never mind su

illtbagu 02-26-2003 12:18 AM

OK I'm still getting errors but with no details to them when i restart apache. in the file:/var/log/httpd/error_log this is what it says

[Tue Feb 25 22:09:22 2003] [alert] (22002)Name or service not known: mod_unique_id: unable to find IPv4 address of "dhcp-487-17"
Configuration Failed

anyone have any ideas I'm hittin the sack ill give it some more sweat tomorrow:)

:)thanks:),
AD

illtbagu 02-26-2003 09:43 AM

http://www.linuxquestions.org/questi...d+IPv4+address

http://www.linuxquestions.org/questi...d+IPv4+address

http://www.linuxquestions.org/questi...d+IPv4+address

well ill give these a try when i get home hopefully one of them will work ;)

illtbagu 02-26-2003 10:28 PM

this worked except my sendmail is delayed teribly long when booting up.

http://www.linuxquestions.org/questi...d+IPv4+address


All times are GMT -5. The time now is 09:34 AM.