LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-23-2004, 02:24 PM   #1
paulr1984
Member
 
Registered: Dec 2003
Posts: 75

Rep: Reputation: 15
apollon installation


Hi! I was trying to install apollon(http://apollon.sourceforge.net/files.html) in my mandrake 10. I downloaded the all-in-one installer which installed other plugins like fasttrack, gnutella, etc. About 80% of the installation, I got an error. This was during the installation of apollon itself. here's the error:

* giftconnection.cpp: In member function `void giFTConnection::makeAttachRequest()':
* giftconnection.cpp:177: error: `PACKAGE' undeclared (first use this function)
* giftconnection.cpp:177: error: (Each undeclared identifier is reported only once for each function it appears in.)
* giftconnection.cpp:179: error: `VERSION' undeclared (first use this function)
* make[3]: *** [giftconnection.o] Error 1
make[3]: Leaving directory `/home/paulr1984/tmp/selfgz26520/apollon-0.9.4/apollon'
* make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/paulr1984/tmp/selfgz26520/apollon-0.9.4/apollon'
* make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/paulr1984/tmp/selfgz26520/apollon-0.9.4'
* make: *** [all] Error 2
***** Return value 2

any ideas? thanks!
 
Old 05-26-2004, 04:22 AM   #2
Butterbur
LQ Newbie
 
Registered: Oct 2003
Location: Shires
Distribution: Mandy 9.2
Posts: 7

Rep: Reputation: 0
If it's of any consolation your not alone. I'm getting the same problem. If you find an answer please post here and I will do like-wise.
Regards
BB
 
Old 05-26-2004, 08:00 AM   #3
paulr1984
Member
 
Registered: Dec 2003
Posts: 75

Original Poster
Rep: Reputation: 15
I finally got it after several days of emailing the apollon mailing list. So here is what i did:

get the 0.9.4-1 version (although, I think 0.9.4 will do)
define PACKAGE and VERSION by adding these lines in your apollon-0.9.4/config.h if they are missing:

/* Name of package */
#define PACKAGE "apollon"

/* Version number of package */
#define VERSION "0.9.4"

-->at this point, I compiled and installed and I was able to run apollon then!!

alternatively you can add those lines at the top of giftconnection.cpp
as another workaround.
 
Old 05-26-2004, 03:49 PM   #4
Butterbur
LQ Newbie
 
Registered: Oct 2003
Location: Shires
Distribution: Mandy 9.2
Posts: 7

Rep: Reputation: 0
Thanks paulr1984.
May there be a bed for you in heaven
Regards
BB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apollon installation problem in Mandrake 10.1 - can't find ltdl BovineStargazer Linux - Newbie 7 11-12-2005 04:45 PM
apollon installation: kircfunctors error librano Linux - Software 0 09-13-2004 09:33 PM
installed apollon...nothing happens!... breezewax Linux - Software 3 09-11-2004 10:44 PM
Apollon carlolin Linux - Software 16 06-08-2004 10:50 AM
Apollon.... MrH0TT Linux - Software 1 03-17-2004 12:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration