LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   APM + upgrade to GRUB2 = fails to poweroff (https://www.linuxquestions.org/questions/linux-software-2/apm-upgrade-to-grub2-%3D-fails-to-poweroff-812363/)

kevinbenko 06-05-2010 03:21 PM

APM + upgrade to GRUB2 = fails to poweroff
 
I've got an OLD computer I'm using as a server, the thing does not support ACPI, so we're in APM-land.

The thing works fine w/ Debian Lenny. I have apmd installed and my /etc/modules file has an apm entry in it. It does a powerdown and everything is happy. I don't even need to add an apm entry on the kernel line in my menu.lst file.

Then I decide to upgrade the box to the testing (squeeze) branch, making the appropriate additions to my sources.list file. And everything goes to hell with apm.

I don't know if it's GRUB2 (grub-pc) or not, all I know is that I can't get a powerdown on the machine.

I've done a reinstall, via a netinstall CD, twice to verify this behavior.

I can't find squat via Google on this other than someone else mentioning that the upgrade to GRUB2 killed apm.

Does anyone have any suggestions?

While I can just reach over and hold the power button for a few seconds to get a powerdown, I assume that every problem is solved by a simple entry in a config file.

Mr-Bisquit 06-06-2010 11:45 AM

You could install LiLo.

JZL240I-U 06-08-2010 07:39 AM

With ACPI I use acpi=force on the kernel line in my menu.lst file to counter exactly the same problem. Dunno whether that is supported by apm, though.

kevinbenko 06-08-2010 10:53 AM

JZL240I-U:

It's an old computer, and the bios doesn't support ACPI.
I just can't see any justification in getting rid of something that still works, even if it is a boat anchor or a doorstop. (It must be my Scottish heritage on my mother's side)
Anyway, it still does a shutdown until I upgrade to GRUB-pc.
Until I get this worked out, I'm thinking about apt-pinning this to GRUB-legacy until sometime after GRUB-pc becomes part of the newstable branch.

JZL240I-U 06-09-2010 01:14 AM

I understand that, my own box is more than 10 years old and still working very well :). What I meant is to give it just a try and use "apm=force" on the kernel line in my menu.lst file. Can't do any harm, could it?


All times are GMT -5. The time now is 02:30 PM.