-   Linux - Software (
-   -   apc powerchute (

craddy 10-20-2003 04:59 AM

apc powerchute

Im having problems installing APC's Powerchute. When i try to execute it (.bin file) it says
"Exception in main class "JExpressLoader""

leaving me stumped!

all i want is for the UPS to work (had problems with apcupsd too, so i thought i wold try this).

Thanks for any help.


sethen 11-05-2003 09:00 PM

I'm having the same issue. As far as i can tell, i think you need to be running XWindows. At least thats all i can get out of their website....

craddy 11-06-2003 12:23 PM

it seems crazy that it is so hard! ups's being designed for the server market-where linux has roots/is used often.

i made more progress...but the rpm found on the APC cd requires some libraries that arenít installed. I found the libraries it needs but cant install them. im not at work at the moment so im not sure what lib's it needs. anyway-any info you get would be much appreciated!


sethen 11-06-2003 12:28 PM

My CD only has a BIN file on it, no RPM. I've tried finding the RPM, but to no luck.

craddy 11-06-2003 06:39 PM

:scratch: well, im not certain it was a rpm...pretty sure though. i will be able to check on monday, if it is i could email it to you.

kc8duw 11-17-2003 11:13 AM

I am wondering if this was ever resolved? i am getting this error and am wondering if X is required.


Jeff Kelley
Network Administrator
Lectronix, Inc.

craddy 11-18-2003 03:57 PM

hey- not resolved as of yet. i work mondays doing admin for an local office. im quite forgetfull, so i will find out all i can next monday (reminder set on my phone :))

Helmet 06-04-2004 11:05 AM

Has anyone resolved this issue? I'm having exaclty the same problem as you all. How did you manage? Please help....


craddy 06-04-2004 04:28 PM


I'm sorry to say i haven't, although i haven't been trying! Way to much college work at the moment so all this techie stuff has to wait. Sorry mate!


Helmet 06-07-2004 08:47 AM

Well.... happy to say problem solved.

Downloaded the latest version and ran the rpm file, not the bin, with its "--prefix" option. Although I don't know what the problem really was, installation with the new version was seamless.

Thanks and regards

lysander 10-12-2004 09:23 AM

I am having the same problem as you were. I have tried to install the 'bin' file with no success. All I get is a 'javaExpressLoader' error.

Could you please post the URL to where I can downlaod the latest version with the 'rmp' file.

Hopefully this will solve it.


Helmet 10-18-2004 04:29 PM

Here's the URL:
they have a newer version now: 7.0.2 for Linux.

Hope it works for you

mykhal 02-06-2005 11:33 AM


pbe_agent_linux_jvm.bin is executable zip sfx archive, so you are able to extract it using "unzip" command.
Then look into jinstall.log which has been generated during the failed attempt to install for the exact command.. i have there:

"/bin/java/jre/1.4//bin/java" -Djava.util.prefs.userRoot\=/bin/jav>a/jre/1.4 -Djava.util.prefs.systemRoot\=/bin/java/jre/1.4 -DProduct.Nodes\=5 -DProduct.Type\='FREE' -DProduct.NodeLeve>l\=5 -DProduct.FeatureLevel\=BASIC -cp .:./install.jar:./m11.jar:./comm.jar:./ds.jar:./pcbe_ds.jar:./RXTXComm.jar\:./M>odifyShutdownLinux.jar load

so i pasted into shell, and it works. Unfortunately, during the installation, is turned out, that the software does not support APC Cyberfort, because it uses USB port, instead of required serial port.

scs14aug 02-20-2006 08:46 AM

I was having the same trouble on a Sun Netra (Solaris 9) when I was using a remote X session from another Sun box. When I used VNC to connect to the Netra (which must have simulated a X console) the whole show installed just fine.

All times are GMT -5. The time now is 04:21 AM.