LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-09-2006, 09:27 AM   #1
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Rep: Reputation: 15
apache2 / PHP4 install problem


Hello,

I have a debian sarge 2.4, and I have install apache2 via:
Code:
apt-get install apache2
And this work well on http://localhost/

Now, I want to put PHP4, with:

Code:
apt-get install libapache2-mod-php4 php4
a2enmod php4
But when I create test.php with:
PHP Code:
<? 
echo "testons :)";
?>
I have a white page ..

I retry the a2enmod php4 and /etc/init.d/apache2 reload, but debian say: "This module is already enabled!"

Anybody have an idea to make work php4 ? :\



PS:
Code:
libapache2-mod-php4 est déjà la plus récente version disponible.
php4 est déjà la plus récente version disponible.
apache2 est déjà la plus récente version disponible.

Last edited by Mycado; 07-09-2006 at 09:33 AM.
 
Old 07-09-2006, 12:21 PM   #2
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Original Poster
Rep: Reputation: 15
No idea
 
Old 07-11-2006, 01:06 AM   #3
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Original Poster
Rep: Reputation: 15
ok, no help
 
Old 07-19-2006, 06:50 AM   #4
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Original Poster
Rep: Reputation: 15
It's not the good forum for this question ?
 
Old 07-19-2006, 05:04 PM   #5
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Original Poster
Rep: Reputation: 15
Isn't a english forum ?
Somebody see my post ?
 
Old 07-19-2006, 06:56 PM   #6
Mirag3
Member
 
Registered: Jun 2005
Location: Ellicott City, Maryland
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
What browser are you using? Also, can you try using some other test page, like the PHP information control panel?
Now, in case all this doesn't work, heres my advice.

Code:
su
password:
apt-get remove php4 libapache2-mod-php4
apt-get install php4
apt-get install libapache2-mod-php4
a2enmod libapache2-mod-php4
/etc/init.d/apache2 force-reload
 
Old 07-20-2006, 12:36 AM   #7
Mycado
Member
 
Registered: Jun 2006
Location: Paris, France
Distribution: RHEL
Posts: 73

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Mirag3
What browser are you using? Also, can you try using some other test page, like the PHP information control panel?
Now, in case all this doesn't work, heres my advice.

Code:
su
password:
apt-get remove php4 libapache2-mod-php4
apt-get install php4
apt-get install libapache2-mod-php4
a2enmod libapache2-mod-php4
/etc/init.d/apache2 force-reload
I use the last version of firefox, an I have test with internet explorer with the same result.



"a2enmod libapache2-mod-php4"

Impossible .. libapache2-mod-php4 isn't a mod ..


But thanks
 
Old 07-23-2006, 02:47 PM   #8
Mirag3
Member
 
Registered: Jun 2005
Location: Ellicott City, Maryland
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
It is, you don't have the right repo, search around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2.0.52, t1lib-5.0.2, php-apache2-5.0.2 wizard7423 Slackware 2 04-04-2011 08:09 PM
Please help : how to install/troubleshoot php on apache2 manishsingh4u Ubuntu 5 06-12-2006 02:58 PM
Suse 9.3/apache2/php4 - Firefox tries to download index.php, other *php pages work stefanlasiewski SUSE / openSUSE 1 01-18-2006 06:12 PM
php5 apache2 mysql4 don't work, php does not seem to read php.ini atom Linux - Software 5 03-24-2005 11:05 AM
Apache2 and PhP wolfwolf Linux - Networking 0 03-12-2003 11:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration