LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-06-2003, 08:01 PM   #1
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Rep: Reputation: 31
apache wont start on boot


I cant get apache to start on boot. I believe somehow it's conflicting with libphp.so, it doesnt like the linked libraries to the custom ODBC. So what Ive done is switched it to not boot in the Control Center for KDE.
I've edited my /etc/rc.d/rc.local to call
/etc/init.d/httpd start
at the end of the rc.local file, but apache will still not start. When Mandrake 9, is fully loaded if I go to a console and type service httpd start then it will start up.

My question is why wont apache start when I call it from rc.local since that should be the last thing to run while booting?

Also which user is running the rc.local script? is it root?
 
Old 09-06-2003, 11:40 PM   #2
mlp68
Member
 
Registered: Jun 2002
Location: NY
Distribution: Gentoo,RH
Posts: 333

Rep: Reputation: 40
I don't think it's the right way to add the "start" command to the rc.local. All these starts are controlled by symlinks that get managed by other utilities, you probably have a choice here but I prefer chkconfig (which you may or may not have).

If you do, remove it from rc.local and do a
chkconfig httpd on
chkconfig --list httpd

Otherwise google for another tool (you can also do it by hand). I don't use Mandrake so I don't know.

Hope it helps
mlp
 
Old 09-07-2003, 06:58 PM   #3
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
i ran those 2 commands
chkconfig httpd on
chkconfig --list httpd

after linux booted from a console and they didnt start apache

I'm not sure what I'm supposed to do with that chkconfig command?
It is included on the mandrake system.

when i type the chkconfig httpd on it just goes to the next line and when I type chkconfig --list httpd
it prints:
httpd 0: off 1: off 2: off 3: on 4: on 5: on 6: off

So my problem is still not solved.
Any thoughts?
 
Old 09-07-2003, 08:38 PM   #4
mlp68
Member
 
Registered: Jun 2002
Location: NY
Distribution: Gentoo,RH
Posts: 333

Rep: Reputation: 40
Yes, but that's what you wanted to accomplish - on the next boot, everything that's "on" for the run level in question will be started. This commands just controls which services get started on boot. It does not start the service just affects the behavior on the next boot.

If you do chkconfig --list
it will show all services and their settings.

HTH, mlp
 
Old 09-07-2003, 10:12 PM   #5
a_morgan
LQ Newbie
 
Registered: Nov 2002
Location: BC, Canada
Distribution: Red Hat 9
Posts: 12

Rep: Reputation: 0
I have always used rc.local to start my apache but I use a script that came with the apache installation:

/usr/local/apache2/bin/apachectl start

This script also responds to stop and restart.
 
Old 09-08-2003, 12:35 AM   #6
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by mlp68
Yes, but that's what you wanted to accomplish - on the next boot, everything that's "on" for the run level in question will be started. This commands just controls which services get started on boot. It does not start the service just affects the behavior on the next boot.

If you do chkconfig --list
it will show all services and their settings.

HTH, mlp
Ok. This has not solved my problem. yes it set it to start on boot but apache fails to start on boot up.
 
Old 09-08-2003, 05:44 AM   #7
mlp68
Member
 
Registered: Jun 2002
Location: NY
Distribution: Gentoo,RH
Posts: 333

Rep: Reputation: 40
Hm. What does the log file say why it didn't start? Do you see those boot messages
"starting httpd.... [ok]"

messages ?

mlp
 
Old 09-08-2003, 10:56 AM   #8
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
I dont see the message when linux boots i think because it's near the end of the messages so it doesnt show.

Which log am I supposed to check
/var/log/httpd/error_log ??
 
Old 09-08-2003, 07:37 PM   #9
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by mlp68
Hm. What does the log file say why it didn't start? Do you see those boot messages
"starting httpd.... [ok]"

messages ?

mlp
I don't see the boot message.
 
Old 09-09-2003, 09:04 PM   #10
mlp68
Member
 
Registered: Jun 2002
Location: NY
Distribution: Gentoo,RH
Posts: 333

Rep: Reputation: 40
That /var/log/httpd/error_log will have the error messages that the server produces, but you don't get to that point. It's probably in /var/log/messages.

mlp
 
Old 09-09-2003, 11:40 PM   #11
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
Ok. I found the errors.
PHP (libphp4.so) is linking to dbodbc8.so.1 which was compiled in so I could use Sybase 8 database. It says no such file or directory, maybe there is a way for me to add the path to that file to the regular set of paths in linux?
Any ideas?
 
Old 09-10-2003, 11:26 AM   #12
Pete Dogg
Member
 
Registered: May 2003
Location: Ontario, Canada
Distribution: Mandrake 9.0, RedHat 7.3, Mandrake 9.2
Posts: 178

Original Poster
Rep: Reputation: 31
I solved this problem.

I added a line in the rc.local to run httpd
/etc/init.d/httpd start

before that line I put in a few lines to add to the PATH and LD_LIBRARY_PATH variables to add the path of the sybase lib directory.

thanks for the help
 
Old 10-30-2003, 12:26 PM   #13
igih
LQ Newbie
 
Registered: Oct 2003
Distribution: RedHat, Mandrake and OpenBSD
Posts: 1

Rep: Reputation: 0
Make sure your /etc/init.d/httpd is executable

chmod +x /etc/init.d/httpd

cd /etc/init.d

ls -ltra

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache wont start stlyz3 Linux - Software 14 05-30-2005 01:25 PM
apache wont start mrgeoff Linux - Software 8 10-27-2004 02:46 PM
Apache wont start. Never seen this error before mpriddy Linux - Software 1 10-12-2004 03:44 PM
apache 1.3 wont start on redhat 7.3 buddamonk Linux - Software 3 03-03-2004 10:31 PM
apache wont start... any ideas... Gear_freak2000 Linux - Software 6 06-02-2003 01:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration