-   Linux - Software (
-   -   Apache virtualhost problems, apache install problems (

nyroc 11-21-2002 07:09 PM

Apache virtualhost problems, apache install problems

I am running RH8.0. I began trying to run Apache 2.0.40, whcih worked with a single website, but when I configured virtual hosts, apache would not start. It gave me a funny error message "[error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results" I tried a large number of things to change in the httpd.conf, but it did not help. I am not using 443. I tried specifying 80, but it did not help.

Apache suggests the latest distribution 2.0.43, which installs but won't run without a later version of modperl "httpd: module "mod_perl.c" is not compatible with this version of Apache (found 20020628, need 20020903).

so I downloaded the latest mod perl, and it won't install: "/usr/bin/ld: cannot find -lapr" (upon attempting make).

I'm getting frustrated.

Was I supposed to uninstall apache 2.0.40 first.
Do I need to configure something to point to apr? APR exists, and it is up to date (somes with apache).


asnagy 01-08-2003 11:24 PM

Fix for virtual host problem
Here's the fix:

Basically, the problem is ssl, which happens to not like virtual hosts. If you specify exactly what config files to load for example:
Include conf.d/perl.conf
Include conf.d/python.conf
Include conf.d/php.conf

Instead of
Include conf.d/*.conf

You will not load ssl.conf and this will solve the problem.

Hope this helps!

BTW -- has anyone else noticed that there are a lot more things that cause problems in apache 2.* than in 1.* ???

Happy Coding

grychwski 06-09-2003 11:16 PM

Another fix for virtual host problem
Explicitly state the port that you want the virtual host to use (this will keep it from conflicting with port 443 SSL):

NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot /var/www/site

This way you don't have to mess with the Include statement which might become a problem later if you forget to include a needed module or want to use SSL.

All times are GMT -5. The time now is 04:31 AM.