-   Linux - Software (
-   -   apache SSI error with Invalid command 'AddOutputFilter' (

Moebius 10-15-2004 03:35 AM

apache SSI error with Invalid command 'AddOutputFilter'
I'm trying to use SSI to add a header and a footer to each of my pages. And I'm getting a 500 internal server error whenever I try to go to that site. The error log says:

[Fri Oct 15 01:01:16 2004] [alert] [client] /var/users/ffs/www/.htaccess: Invalid command 'AddOutputFilter', perhaps mis-spelled or defined by a module not included in the server configuration

I know the mod_include is installed because "apache-modconf apache query mod_include" returns "mod_include". Also, it's in the apache modules list in webmin.


DirectoryIndex Home.php
Options Indexes FollowSymLinks +Includes
AddType application/x-httpd-cgi .cgi
#AddType text/x-server-parsed-html .php
#AddType text/x-server-parsed-html .htm
AddType text/html .htm
AddType text/html .html
AddType text/html .php
AddOutputFilter INCLUDES .html
AddOutputFilter INCLUDES .php
AddOutputFilter INCLUDES .shtml
XBitHack on


The reletive part of httpd.conf

<VirtualHost *:80>
  DocumentRoot /var/users/ffs/www
  <Directory "/var/users/ffs/www">
    AllowOverride All
    allow from all
    Options +Includes
  ErrorLog /var/users/ffs/logs/error.log
  LogLevel debug

And the file I'm trying to load, Home.php:

<Title>Fight for Sight</Title>

<!-- -->

<Meta Http-Equiv="Content-Type" Content="text/html; charset=iso-8859-1" />

<!--#include file="Top.htm" -->

Fight for Sight^�s mission is to encourage and finance research in ophthalmology, vision and related sciences $
<!--#include file="Bottom.htm" -->

I appriciate any help.

bathory 10-15-2004 05:05 AM

I'll try to help even though I have never used SSIs. According to this tutorial you have:
1st, add:

AddHandler server-parsed .html .htm
2nd, make your header and footer pages executable

chmod +x Top.htm Botton.htm
Try also to add: AddOutputFilter INCLUDES .htm and remove the: AddOutputFilter INCLUDES .shtml

Good luck

Moebius 10-15-2004 12:18 PM

OK I tried making those changes, but I still get the same error.

"Invalid command" makes me think the module it needs isn't working or something. Is there anything else I should check for besides mod_include? Or is there anything else I have to do to activate it?


All times are GMT -5. The time now is 08:19 PM.