LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2009, 07:06 PM   #1
qspares
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Rep: Reputation: 0
Apache Server conflict with SSL?


My Firefox have had this weird issue for months, it connects regular website just fine, but everytime when it opens a page with SSL(https://), I got an error message says it cannot connect to port 443.

Today I finally found it was because my local Apache server is listening to port 443. When I shut the apache down, Firefox finally started working.

But I am not sure I fully understand the issue here. Did the remote https server try to connect to my local 443 port? Why does it do that? Furthermore, why does my Apache listen to 443? Shouldn't it just listen to port 80?
 
Old 08-29-2009, 11:53 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
Hey qspares,

Thats a little strange, unless you are running a local proxy I cant see any reason why apache should have any effect on firefox... the connections would look like:

yourhost:random_high_port -> remotewebsite:443

yourhost:443 shouldn't make any difference to the connection unless firefox is configured to use localhost:443 as a proxy

wierd...

kbp
 
Old 08-30-2009, 12:07 AM   #3
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Ubuntu 12.04, Antix19.3
Posts: 3,794

Rep: Reputation: 282Reputation: 282Reputation: 282
I can not answer the main question (the why?), but your apache seems to be configured to serve http as well as https requests.

Without knowing your distro, it will be difficult to advise how to reconfigure your apache.

This however will be a workaround and does not solve the root cause. Without knowing your setup (network wise; one or more PCs, router, ...) I think it will be difficult for anybody to advise. Can you post the exact firefox error that you get?
 
Old 08-30-2009, 11:18 AM   #4
qspares
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Hi! Thanks all who replied.

I am using Fedora 9. Not sure about the apache version, but it is the one comes with the original package. Firefox version is Fedora/3.0.4-1.fc9 Firefox/3.0.4

Here is the error message I got. I was trying to access chase oneline. The 2nd line is really confusing, I am very sure chase does not use Apache server. It must be referring to my local Apache:
================================
The requested URL /Secure/OSL.aspx was not found on this server.
Apache/2.2.9 (Fedora) Server at chaseonline.chase.com Port 443
================================


And here you can see my local Apache is listening to port 443:
================================
rt@sun#/>netstat -tulnap | grep 443
tcp 0 0 :::443 :::* LISTEN 2239/httpd
rt@sun#/>ps -eaf | grep 2239
root 2239 1 0 04:01 ? 00:00:01 /usr/sbin/httpd
apache 5547 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5548 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5549 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5550 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5551 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5552 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5553 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
apache 5554 2239 0 05:02 ? 00:00:00 /usr/sbin/httpd
root 26484 26425 0 11:03 pts/0 00:00:00 grep 2239
================================

I think I have two questions here:
1 How do I stop Apache from listening on port 443? I don't really use SSL on my local server.
2 How does https really work? Why does the remote server need to connect to my local 443?
I think there maybe a config error in my firefox?
 
Old 08-30-2009, 11:28 AM   #5
qspares
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
This is so weird. I found how to disable SSL on apache:
SSLEngine off

But even after I added that line and bounce the server(I confirmed nobody's listenning to my local 443 anymore),
https is still failing with the same error.

But, as soon as I shut off apache, https immediately start working. I don't understand.
 
Old 08-30-2009, 11:31 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Ubuntu 12.04, Antix19.3
Posts: 3,794

Rep: Reputation: 282Reputation: 282Reputation: 282
1)
I can't help as I don't use Fedora, so don't know how the files are organised. Check the config files for one that contains 443. Next check if that file is included from the main httpd.conf; if so, put a hash in the beginning of the line that includes the ssl stuff.

2)
This is not a https issue. This is indeed a network or firefox issue. I did ask about your network setup and kbp mentioned the proxy. Have a look at that.
 
Old 08-30-2009, 11:36 AM   #7
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Ubuntu 12.04, Antix19.3
Posts: 3,794

Rep: Reputation: 282Reputation: 282Reputation: 282
SSLEngine off is not the way; requests will still go to your local apache on port 443.

I'm not 100% sure but https request will still be handled by your apache if you switch the engine off but are (probably) no longer encrypted causing different errors to occur once apache has decided that it has the requested page.
 
Old 08-30-2009, 11:07 PM   #8
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora/Pop!_OS
Posts: 2,897

Rep: Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547
sounds like you are running httpd local as well as running your local dns. this will cause you to point to your local httpd FIRST as it is local.

without httpd running local your browser will go outside of your local LAN and hit the www.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install ssl for apache server deepu.sarma Linux - Security 1 05-06-2009 11:04 AM
Apache SSL Server Murdock1979 Slackware 2 10-23-2008 03:57 PM
Apache HTTP Server 2.2.3 with SSL gjagadish Linux - Software 1 01-22-2007 01:15 AM
Unable to get the Response from Apache-SSL Server Lenux78 Linux - General 7 07-06-2006 04:03 PM
2 certificate ssl in 1 server apache simquest Linux - Software 2 07-24-2002 11:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration