LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-15-2005, 12:52 PM   #1
legolin
Member
 
Registered: Dec 2003
Location: munich
Distribution: Fedora Core 4
Posts: 141

Rep: Reputation: 15
Question apache config problem with otto, FollowSymLinks


hi people,

i have a very strange problem with my apache server (fedora 3).
i tryied to install otto there, but i had a problem.

i followed all the instrucctions in the readmy file (they are simple!), i made a softlink from /var/www/html/otto to /usr/local/otto/www
then i made:
chown -R apache.apache /usr/local/otto/www
chmod a+rx -R /usr/local/otto/www

i edited httpd.conf and added the following lines:
<Location /otto>
Options +ExecCGI +FollowSymLinks
AddHandler cgi-script cgi
DirectoryIndex index.html index.cgi otto.cgi
</Location>

with "Options +FollowSymLinks" i'm not very shure....

then restarted apache and everything goes fine.
when i co to mypage.org/otto i become this message:


Quote:
Forbidden

You don't have permission to access /otto/ on this server.
if i go to mypage.org/otto/otto.cgi the error looks like this:
Quote:
Forbidden

You don't have permission to access /otto/otto.cgi on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
the error log shows me this:
Quote:
[Fri Apr 15 18:28:17 2005] [error] [client 10.149.34.147] (13)Permission denied: access to /otto/otto.cgi denied

What i'm idoing wrong, what ca i do to make apache follows this symbolic link? how can i configure apachhe to execute the cgi scripts outside the root dierectory of the apache-server?



thankx

have a while,


leg
 
Old 05-16-2005, 07:21 PM   #2
cormander
Member
 
Registered: Dec 2004
Location: Hawaii
Distribution: Fedora & CentOS
Posts: 72

Rep: Reputation: 15
Try using the Directory tag instead of the Location and provide the full path to the directory, like this:

Code:
<Directory /home/vhosts/myhost/otto>
Options +ExecCGI +FollowSymLinks
AddHandler cgi-script cgi
DirectoryIndex index.html index.cgi otto.cgi
</Directory>
Let me know if this works for you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Drupal Apache Config problem - incorrect URLS TippExed Linux - Software 0 06-02-2005 06:38 PM
Apache config problem code_junkie Linux - Newbie 2 11-30-2003 10:50 PM
Apache / PHP / Mysql config problem - debian bandit Linux - Software 14 09-03-2003 09:04 AM
possible samba config problem or network config issue? rruffin Linux - Networking 3 06-03-2003 04:04 PM
php or apache config problem mattkat Linux - Software 2 04-30-2003 06:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration