LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2004, 09:18 PM   #1
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Rep: Reputation: 15
Question Apache


I have Apache installed and would like to make a webpage.
When I try going to http://localhost I only get a message saying that I either do not have permission to look at the website or that theres something wrong with the directory or something like that.
I do not have a virtual host yet which I would like to have. I tried it but it doesn't work.

Thank you
 
Old 10-21-2004, 10:16 PM   #2
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Did you start apache?
 
Old 10-21-2004, 10:24 PM   #3
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
yes
 
Old 10-21-2004, 10:29 PM   #4
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
ok, well then try this.

$/sbin/ifconfig

Get your IP from the output and try to suref to it...like:

bignate@delia bignate$ /sbin/ifconfig
eth1 Link encap:Ethernet HWaddr 00:02:2D:A9:EB:51
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0

Open up your browser and go to "http://192.168.0.2"
 
Old 10-22-2004, 04:29 PM   #5
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
I tried that and I got the same response as with http://localhost :

Code:
Access forbidden!


 You don't have permission to access the requested directory. There is either no index document or the directory is read-protected. 


If you think this is a server error, please contact the webmaster. 


Error 403

192.168.1.102
 Fri Oct 22 14:18:20 2004
 Apache/2.0.49 (Linux/SuSE)
here is my httpd.conf file incase it might help:

Code:
NameVirtualHost *

<VirtualHost *>
     DocumentRoot /srv/www/htdocs/
     ServerName www.laundryswebsite.com
</VirtualHost>
thank you a lot
 
Old 10-22-2004, 04:44 PM   #6
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
did u change the permissions of the folder /srv/www/htdocs/ and the files in them ????
 
Old 10-22-2004, 04:51 PM   #7
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
yeah i think so

thanx
 
Old 10-22-2004, 06:41 PM   #8
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Well. IT would seem that the permissions are the problem. Post what this does

bignate@delia bignate$ ls -l /var/www/localhost/

or alternately depending on your set up...just the dir /var/www/. Whatever dir the htdocs is under
 
Old 10-22-2004, 07:08 PM   #9
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
here is the outcome:

Code:
dre@XAR:~> ls -l /srv/www/htdocs
total 4
-rw-r--r--  1 dre users 393 2004-10-20 16:58 laundryswebsite.html
dre@XAR:~>
thanks a lot
 
Old 10-22-2004, 07:15 PM   #10
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
well there is your problem...the file has perm problems...try chmoding the file to 755...like this

$chmod 755 laundryswebsite.html
 
Old 10-22-2004, 07:40 PM   #11
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
the same error comes up when going to localhost

thank you
 
Old 10-22-2004, 07:44 PM   #12
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
Did u stop and restart the server???? if not then do it.. then the changes [permissions] will be reflected

How come u said earlier that u had changed permissions ??
Ur folder's content doesnt reflect that... anyway

Best of luck !!!

Tell us how it went....

Last edited by UsualTuxpect; 10-22-2004 at 07:46 PM.
 
Old 10-22-2004, 07:55 PM   #13
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
yeah...what he said
 
Old 10-22-2004, 08:12 PM   #14
drethenerd
Member
 
Registered: Aug 2004
Distribution: Slackware 12.0
Posts: 81

Original Poster
Rep: Reputation: 15
nope didnt work

can it be something with the index document?

thank you for your time
 
Old 10-22-2004, 08:27 PM   #15
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
My directory permissions are like this --->
drwxr-xr-x WWW [where i have my files]

my index file's permissions
-rw-r--r-- index.php [my index.php file]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 12:41 AM
Apache 1.3.33 (debian built) and Apache SSL does not respond to the proper ports lqorg_user Linux - Networking 0 11-06-2005 04:11 PM
Strange apache trailing / problem - Slack-current, apache 1.3.33 vamp Linux - Networking 1 01-30-2005 07:28 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 05:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 10:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration