LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
 
Search this Thread
Old 03-08-2006, 03:54 PM   #1
martian
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, Ubuntu
Posts: 14

Rep: Reputation: 0
Apache's Ant


I just tried installing ant, and when I run it I get this error message.

Code:
Exception in thread "main" java.lang.NoClassDefFoundError: org.apache.tools.ant.launch.Launcher
   at gnu.gcj.runtime.FirstThread.run() (/usr/lib/libgcj.so.5.0.0)
   at _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_RunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/libgcj.so.5.0.0)
   at __gcj_personality_v0 (/usr/lib/jvm/java.version=1.4.2)
   at __libc_start_main (/lib/tls/libc-2.3.4.so)
   at _Jv_RegisterClasses (/usr/lib/jvm/java.version=1.4.2)
I've set up my environment as specified in the manual (http://ant.apache.org/manual/install.html#installing).

Thanks.
Chris
 
Old 03-08-2006, 04:49 PM   #2
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Maybe you need to set CLASSPATH to the location of a jar with the missing class? Just a guess...

Peace...
 
Old 03-09-2006, 02:26 PM   #3
martian
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, Ubuntu
Posts: 14

Original Poster
Rep: Reputation: 0
How do I do that?
 
Old 03-09-2006, 03:16 PM   #4
martian
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, Ubuntu
Posts: 14

Original Poster
Rep: Reputation: 0
I upgraded Java to version 1.5, and installed the jaxp_parser_impl RPM, and that has reduced my error message to this:
Code:
# ant
/usr/bin/build-classpath: error: could not find xml-commons-apis Java extension for this JVM
/usr/bin/build-classpath: error: All specified jars were not found
Unknown argument: -cp
When I search for the xml-commons-apis, I find RPMs for Mandriva and Connectiva (on rpmfind.net). I'm guessing I shouldn't use these on a RedHat distribution. Any suggestions on what I should do?
 
Old 08-14-2007, 07:52 PM   #5
gezmo
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Smile newbie

I recently needed to work with ant for work and installed FC7, Java SDK 5 with Update 12.

I did a wget from the jpackage.repos, and did a yum install ant, had encountered similar problems where the ant would complain:

/usr/bin/build-classpath: error: Could not find xml-commons-apis Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found


I then did a yum install xml-commons-apis

Hopefully this will help your problem martian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache's global default page marsguy Linux - Software 2 05-31-2005 06:31 AM
Apache's CGI directory don_wombat Linux - Software 7 03-01-2005 12:14 PM
Apache's Index XxAndyxX Linux - Software 2 03-16-2003 12:34 PM
changing apache's signature hardigunawan Linux - Software 1 05-31-2002 01:00 PM
apache's OK, php's not matt Linux - Software 9 11-25-2001 09:24 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration