LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-02-2012, 10:31 PM   #1
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Rep: Reputation: 21
Question Any NagiosXI users here? Need help


Hi Guys,

Im trialling nagiosXI and it isnt going very well. Everything was running alright until I tried to add a new hostgroup through the interface, this happened;

Code:
Checking services...
Error: Service check command 'check_xi_service_snmp' specified in service 'Battery Status' for host 'APC Smart-UPS 5000' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Output Load' for host 'APC Smart-UPS 5000' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Power State' for host 'APC Smart-UPS 5000' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Remaining Battery Charge' for host 'APC Smart-UPS 5000 AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Replace Battery Flag' for host 'APC Smart-UPS 5000' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Battery Status' for host 'APC Smart-UPS 5000 ' not defined anywhere!
Warning: Service 'Battery Status' on host 'APC Smart-UPS 5000 ' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp' specified in service 'Output Load' for host 'APC Smart-UPS 5000 ' not defined anywhere!
Warning: Service 'Output Load' on host 'APC Smart-UPS 5000 ' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp' specified in service 'Power State' for host 'APC Smart-UPS 5000 ' not defined anywhere!
Warning: Service 'Power State' on host 'APC Smart-UPS 5000 ' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp' specified in service 'Remaining Battery Charge' for host 'APC Smart-UPS 5000 ' not defined anywhere!
Warning: Service 'Remaining Battery Charge' on host 'APC Smart-UPS 5000 ' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp' specified in service 'Replace Battery Flag' for host 'APC Smart-UPS 5000 ' not defined anywhere!
Warning: Service 'Replace Battery Flag' on host 'APC Smart-UPS 5000 ' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp' specified in service 'Battery Status' for host 'APC Smart-UPS RT 5000 RM XL AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Output Load' for host 'APC Smart-UPS RT 5000 RM XL AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Power State' for host 'APC Smart-UPS RT 5000 RM XL AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Remaining Battery Charge' for host 'APC Smart-UPS RT 5000 RM XL AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp' specified in service 'Replace Battery Flag' for host 'APC Smart-UPS RT 5000 RM XL AKL' not defined anywhere!
Error: Service check command 'check_xi_service_snmp_win_load' specified in service 'CPU Usage' for host 'O-DR1' not defined anywhere!
Warning: Service 'CPU Usage' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Drive C: Disk Usage' for host 'O-DR1' not defined anywhere!
Warning: Service 'Drive C: Disk Usage' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Drive D: Disk Usage' for host 'O-DR1' not defined anywhere!
Warning: Service 'Drive D: Disk Usage' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Drive Z: Disk Usage' for host 'O-DR1' not defined anywhere!
Warning: Service 'Drive Z: Disk Usage' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_process' specified in service ' Movement v1.0b' for host 'O-DR1' not defined anywhere!
Warning: Service ' Movement v1.0b' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_process' specified in service 'SQL Server' for host 'O-DR1' not defined anywhere!
Warning: Service 'SQL Server' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Virtual Memory Usage' for host 'O-DR1' not defined anywhere!
Warning: Service 'Virtual Memory Usage' on host 'O-DR1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_load' specified in service 'CPU Usage' for host 'O-SAFE1' not defined anywhere!
Warning: Service 'CPU Usage' on host 'O-SAFE1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Drive C: Disk Usage' for host 'O-SAFE1' not defined anywhere!
Warning: Service 'Drive C: Disk Usage' on host 'O-SAFE1' has no default contacts or contactgroups defined!
Error: Service check command 'check_xi_service_snmp_win_storage' specified in service 'Drive D: Disk Usage' for host 'O-SAFE1' not defined anywhere!
There are about a 100 of these errors. I have no idea what caused them, I just went to add a host group and clicked "Apply".

Anyone?
 
Old 04-03-2012, 01:16 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Lets start here
Code:
Error: Service check command 'check_xi_service_snmp' specified in service ' ... not defined anywhere!
This says you don't have the relevant check cmd installed (or the path doesn't see it).
In my std nagios install, check_... progs are in /usr/local/nagios/libexec, you should have a similar dir somewhere.

Code:
has no default contacts or contactgroups defined!
On my system /usr/local/nagios/etc/objects/contacts.cfg

On a more general level, you need to check nagios.cfg (/usr/local/nagios/etc on my system)

HTH
 
Old 04-03-2012, 01:21 AM   #3
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Original Poster
Rep: Reputation: 21
Hi Chris,

Thanks for the reply. The problem is within nagiosXI, it claims the commands don't exist however they do;

And when I run a

Code:
$ /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg


Code:
Total Warnings: 57
Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check
it returns some warnings but definitely no errors. But when I try to 'commit' the changes from within the NagiosXI web interface it doesn't want any of it!

This leads me to beleive the error is within the NagiosXI web interface... not sure where to start looking!
 
Old 04-03-2012, 01:29 AM   #4
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Original Poster
Rep: Reputation: 21
Issue resolved -- I was logged in as my personal user account, but I logged in as 'nagiosadmin' which is the administrative account created as install and commited the changes and it went right through. Odd.
 
Old 04-03-2012, 05:46 AM   #5
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 535

Rep: Reputation: 79
Quote:
Originally Posted by brokenpromises View Post
Issue resolved
If so, please mark your thread as solved (Thread Tool > Mark this thread as solved)

And thank you for your feedback on how you solve the issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu One taking care of Windows users ... not so much users of other Linux distributions LXer Syndicated Linux News 0 08-26-2010 10:30 PM
tbl Users.guide | troff tmac.n - > Users.fmtd causes fatal error. stf92 Linux - Newbie 0 07-05-2010 08:03 PM
LXer: Linux Users Still Left Out, Why Source Code Matters to End Users LXer Syndicated Linux News 0 10-15-2009 11:51 PM
Script to add a secondary group to all users except system default users Tekken Linux - Server 5 06-29-2009 05:02 PM
Struggling to setup a Debian/etch desktop: LDAP users and LOCAL users jferrando Linux - Networking 1 05-05-2006 04:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration