LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-25-2009, 09:41 PM   #31
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1

Quote:
So I changed boot device order to
CD-Rom - first
HD0 - second
HD0 - third

booted, and got XP.

???
Why is this surprising? You already said so in your very first post:


Quote:
If I set BIOS = boot=hd0, I get XP boot.
 
Old 03-25-2009, 10:29 PM   #32
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by meierfra View Post
Why is this surprising? You already said so in your very first post:
It's surprising cause I forgot. You're followin' better than I am.


http://www.linuxquestions.org/questi...hooter-278748/
But a clue shows itself... I am now stuck at M11 - when I press 'tab', I do not get a list of possible partitions. What I get is a comma, then I press tab again, and I get 0 and close parenthesis:
grub> root (hd,0)
Press tab again, and I get
Filesystem type unknown, partition type 0x7

Quote:
Originally Posted by aus9 View Post
INTRODUCTION
See my link to know I will give you credit when credit is due
http://www.linuxquestions.org/questi...hreadid=237511

If grub is not in mbr.....no grub appears on screen on bios boot to mbr....so you need to read how to use your install cds to get into rescue mode.
Otherwise, you can use a Knoppix cd.

Briefly that is
load knoppix b4 hard drive by changing bios boot order
click on a terminal (konsole opens)
$ su
$ grub
$ root (hdX,Y) # where x and y will define your /boot partition
$ setup (hdX) # where X is the drive you want bios to see first.

ALL USERS
Note 1 Pressing the TAB key for autocompletion only works if you are defining root or have defined root.
Note 2 Spelling of grub commands can be checked by just pressing TAB at the prompt with nothing else like this.
Note 3 GREEN text is the screen shots.....you either press enter at the end of the line showing grub> ....or press the TAB key to autocomplete.

grub> PRESS TAB
Possible commands are:
altconfigfile blocklist boot cat chainloader clear cmp color configfile debug device displayapm displaymem dump embed find fstest geometry halt help hide impsprobe initrd install ioprobe kernel lock makeactive map
md5crypt module modulenounzip pager partnew parttype password pause quit read reboot root rootnoverify savedefault serial setkey setup terminal terminfo testload
testvbe unhide uppermem vbeprobe


A MS TROUBLE-SHOOTING.
Without a flowchart I am using steps M (No) to lead down the dark alley of success.

M1 at the menu screen PRESS C (for commands to try stuff direct)[
or if prompt is showing start typing.

M2 test what grub finds is a MS format

grub> root (hd0, PRESS TAB
Possible partitions are:
Partition num: 0, Filesystem type is fat, partition type 0xc
Partition num: 1, Filesystem type is reiserfs, partition type 0x83
Partition num: 2, Filesystem type is reiserfs, partition type 0x83
Partition num: 4, Filesystem type is reiserfs, partition type 0x83
Partition num: 5, Filesystem type is reiserfs, partition type 0x83
Partition num: 6, Filesystem type is reiserfs, partition type 0x83
Partition num: 7, Filesystem type unknown, partition type 0x82


I only have a w98 but all MS users should be able to recognise that (hd0,0) will be a fat file system. Lets confirm.

For those who have MS on a non-first drive first partition system you need to jump to M8 for the map commands.

M3 confirm MS file partition to load
grub> root (hd0,0)
Filesystem type is fat, partition type 0xc


M4 MS likes bootable partitions it can see so switch on the flag
No harm if its already on. Persons who had to jump to M8 rejoin here, only after completing M8 stuff.

grub> makeactive
# grub gives no feedback

M5 Tell grub to use the MS bootloader
grub> chainloader +1
MS now boots otherwise step M6

M6 force the boot to MS as step M5 fails
grub> boot

M7 if you have booted, when you get back into linux amend your /boot/grub/menu.lst file to reflect the new changes.
################end of M series for normal users

M8 MS ON NON-FIRST PARTITION FIRST DRIVES START HERE
You are here only if MS is not on first drive first partition.

To boot first drive but NOT first partition jump to M11
Otherwise you are booting a second or third drive please continue
To recap you attempted to find partition info and did this
grub> root (hd PRESS TAB to get responses eg
hd0
hd1


M9 Check non-first drive for C drive
root (hd1, PRESS TAB
Partition num: 0, Filesystem type is fat, partition type 0xc
Partition num: 1, Filesystem type is reiserfs, partition type 0x83

So C drive is (hd1,0) continue.

M10 issue root and map commands
grub> root (hd1,0) change this to suit where C drive sits
grub> map (hd1) (hd0)
grub> map (hd0) (hd1)


Note we must use two maps (or swaps) swap a to b and swap b to a.
Does not matter which we swap first.

The main howto explains that MS is now tricked. Now goto M4
############end of other drive steps

M11 Check C drive on first drive but not first partition
Recap you may have this setup
grub> root (hd0, PRESS TAB
Possible partitions are:
Partition num: 0, Filesystem type is reiserfs, partition type 0x83
Partition num: 1, Filesystem type is reiserfs, partition type 0x83
Partition num: 2, Filesystem type is fat, partition type 0xc


so instead of a map drive command we use it to map partitions, still the same logic to trick MS that hd0,2 is hd0,0

M12 Issue root and map commands
grub> root (hd0,2) change this to suit where C drive sits.
grub> map (hd0,2) (hd0,0)
grub> map (hd0,0) (hd0,2)


The main howto explains that MS is now tricked. Now go to M4
###########end of MS stuff########################################

B LINUX TROUBLESHOOTING

L1 OUR GOAL IS TO BOOT SOMETHING LIKE THIS

The sequence to test is
root (hdX,Y)
kernel {/boot}/vmlinux (or bzImage or kernel ) WITH KERNEL PARAMETERS
initrd {/boot}/initrd.img OR NO INITRD LINE

L2 TESTING THE ROOT COMMAND
root (hdX,Y) defines a search path for grub to find the next command files.
IT MUST define either the /boot partition or the / partition as /boot is a sub-folder to /

BUT on the kernel line we may need the structure /boot/ etc or WITHOUT /boot
so to kill 2 birds with one stone we try this
grub> find /boot/bzImage
Error 15: File not found
grub> find /boot/kernel
Error 15: File not found
grub> find /boot/vmlinuz
Error 15: File not found
grub> find /bzImage
Error 15: File not found
grub> find /kernel
Error 15: File not found
grub> find /vmlinuz
(hd0,1)


I know what my structure is but by doing all permutations you get the idea.
We all know now that the kernel is called vmlinuz and its on (hd0,1) AND no /boot to be used as a part of the kernel command.

To be blunt you either have /boot as a separate partition, IMHO the best way OR
its on the main / as is therefore a subfolder to /.

If you already know that....then if you have /boot partition you drop the /boot from your command.....otherwise you leave them in.

L3 TEST KERNEL LINE root=/dev
our sequence so far is root (hd0,1) and the first part of kernel we already know is
kernel /vmlinuz and not /boot/vmlinuz.

How do we find the root=/dev/sdX or hdX parameter? 2 ways
WAY 1
The /etc/fstab file sits on / partition so find it

grub> find /etc/fstab
# typed long hand
(hd0,2)


WAY 2
If you have more than one linux it may get multiple responses. In which case you may need to print to screen each response like this
For each response change the root command ....for searching and then issue the cat command
grub> root (hd0,2)
Filesystem type is reiserfs, partition type 0x83

grub> cat /etc/f
AND PRESS THE TAB KEY to autocomplete so that you get the full line
grub> cat /etc/fstab
Possible files are: fstab fstab~


grub> cat /etc/fstab
/dev/sda3 / reiserfs notail,noatime 1 1
/dev/sda6 /a reiserfs notail,noatime 1 2
/dev/sda2 /boot reiserfs notail,noatime 1 2
none /dev/pts devpts mode=0620 0 0
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro
,exec,users 0 0
/dev/fd0 /mnt/floppy auto umask=0,user,codepage=850,iocharset=iso8859-15,noauto,s
ync 0 0
/dev/sda1 /mnt/windows vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/sda5 /usr reiserfs notail,noatime 1 2
/dev/sda7 /z reiserfs notail,noatime 1 2
/dev/sda8 swap swap defaults 0 0


/dev/sda3 is the bit we need for the "root=/dev/sda3" part of the kernel command line
so our sequence so far
root (hd0,1)
kernel /vmlinz root=/dev/sda3

L4 CHECKING THE OTHER KERNEL PARAMETERS
Info is in your kernel docs at
/usr/src/(kernel name) /Documentation/kernel-parameters.txt
online here
http://lwn.net/Articles/14632/

This section is under severe edit as I think of some to add.....I am not a kernel guru

Some kernel appends can be checked as working or not there in /VAR/LOG/DMESG

ro means read only the partition of /boot while kernel is loading...the rw status or otherwise is then determined by your /etc/ files

noraid means don't load any software raid

root=/dev/hda means tell kernel where your / partition is AND ITS COMPULSORY paramter.
Note hda is an example change it to to suit the /etc/fstab file

acpi=ht means enable hyperthreading for your processor

hdX=ide-scsi some old kernels (distros) need this to get cd burners to work

nofb means no frame buffer......a graphics driver

apci=off means don't use the power management

vga=ask some people like bigger fonts so see what your kernel messages can handle



L5 CHECK IF INITRD IS NEEDED AND NAME
grub> root (hd0,1)
Filesystem type is reiserfs, partition type 0x83

grub> find /
Possible files are: grub message-graphic System.map System.map-2.6.8.1-10mdk System.map-2.6.9 us-latin1.klt config-2.6.8.1-10mdk config-2.6.9 configkernel.h-2.6.8.1-10mdk initrd.img
reiserfs_priv initrd-2.6.8.1-10mdk.img initrd-2.6.9.img vmlinuz kernel.h vmlinuz-2.6.8.1-10mdk vmlinuz-2.6.9

NOTE grub is a FOLDER

grub can use LINK files so vmlinuz and initrd can be used

Response shows that for kernel-2.6.8.1-10 it has an initrd
but kernel-2.6.9 there is no initrd.

so our sequence to boot the 2.6.8 series so far is
root (hd0,1)
kernel /vmlinuz root=/dev/sda3 WITH KERNEL PARAMETERS
initrd /initrd.img

But for 2.6.9 series its
root (hd0,1)
kernel /vmlinuz-2.6.9 root=/dev/sda3 WITH KERNEL PARAMETERS



WHAT NEXT
At some point you must issue commands to either get into MS or Linux.
If they work write them down. Then boot into linux and with root access powers edit the /boot/grub/menu.lst file to exactly those commands but add a title line so you can choose it later. Read the rest of the howto on other stuff if you like.

SPLASHIMAGE FAILS
Check that the command is available to use if at mbr menu
press TAB to see all commands

b) if system has booted try su then grub then tab

then check the pathway in your menu file is correct
then check with a graphics program.....the image is viewable and correct graphic size as per myhowto.

Note, I prefer you have no fancy stuff......use the bootloader to get to your fancy stuff and keep the bootloader as simple as possible.

Last edited by buccaneere; 03-25-2009 at 10:30 PM.
 
Old 03-25-2009, 11:07 PM   #33
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
More interesting stuff:
Quote:
linux-q06p:~ # fdisk -l /dev/sdb1

Disk /dev/sdb1: 30.7 GB, 30729613824 bytes
255 heads, 63 sectors/track, 3735 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x69205244

This doesn't look like a partition table
Probably you selected the wrong device.

Device Boot Start End Blocks Id System
/dev/sdb1p1 ? 13578 119522 850995205 72 Unknown
Partition 1 does not end on cylinder boundary.
/dev/sdb1p2 ? 45382 79243 271987362 74 Unknown
Partition 2 does not end on cylinder boundary.
/dev/sdb1p3 ? 10499 10499 0 65 Novell Netware 386
Partition 3 does not end on cylinder boundary.
/dev/sdb1p4 167628 167631 25817+ 0 Empty
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order
linux-q06p:~ #
 
Old 03-25-2009, 11:25 PM   #34
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1
All the output you got are exactly as expected

root (hd1,

has only one possible completion, namely

root (hd1,0)

So instead of giving you a list possible completions, grub completes it for you.

The output of the command "root (hd1,0)" is also as expected,
(namely the same information you already got from "geometry (hd1,0)"

Quote:
fdisk -l /dev/sdb1
fdisk cannot be applied to a partitions, since partitions do not have a partition table.

Last edited by meierfra; 03-25-2009 at 11:35 PM.
 
Old 03-26-2009, 12:04 AM   #35
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
And NOW, I load a Live CD, to see what happens.

The menu pops up 'Start or install, ..., and last, "Boot from first hard disk".

I choose boot from first hard disk.

XP boots up. ??? BIOS right now is CD-Rom, HD0 (RAIDbus card), HD0 again. But XP boots up.

I give up.
 
Old 03-26-2009, 04:57 PM   #36
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1
You might consider a bios upgrade, but I'm not sure whether that will solve your problem and adding all the OSs to the XP boot menu is a much safer option.
 
Old 03-26-2009, 07:26 PM   #37
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by meierfra View Post
You might consider a bios upgrade, but I'm not sure whether that will solve your problem and adding all the OSs to the XP boot menu is a much safer option.
I think there is no BIOS upgrade for this board socket A M7NCD...

Solved by work-around. And REALLY aROUND!

I reinstalled GRUBloader on the RAIDbus card HD, for openSuSE. It already had a GRUBloader for the entire disk (SuSE, F10, and PCLOS).

And of course, it called itself HD2.

Then I set BIOS to boot from that device - SCSI (the same as HD0) - and it didn't find the SuSE GRUB at HD2,1. It defaulted to the SuSE GRUB menu.

Select SuSE, no boot. Had to edit again for HD0,1. SuSE booted.

Re-booted, selected XP from SuSE GRUB, no boot, no edit attempted (later).

Re-booted, selected Ubuntu from SuSE GRUB; Not found at HD1,0. Edited (HD2,0), and it defaulted to Ubuntu GRUB menu, when NOT finding Ubuntu bootconfig file (possible corruption). THIS IS THE ORIGINAL GRUB. Selected Ubuntu, it tried to load it from HD0,0. No-go. Edited to HD2,0, and got Ubuntu.

Re-booted, repeated each edit to Ubuntu GRUB menu, selected XP, no edits, and it booted!!! THIS IS THE ORIGINAL MENU ENTRY WHICH DID NOT WORK BEFORE, BUT NOW WORKS. I GIVE UP. AGAIN.

Hercules couldn't find his way through this maze with a ball of string.

Now, time to make the edits permanent. Cross your fingers...

And thanks for the input!

I'll post back if I get can all to boot from SuSE GRUB.
 
Old 03-26-2009, 08:50 PM   #38
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1
All the results you got are exactly as I would have expected, except that XP booted. But I have a couple of questions:

Quote:
reinstalled GRUBloader on the RAIDbus card HD, for openSuSE.
Why did you have to reinstall grub? It seemed that Grub was already installed corrrectly in the MBR of the Raid card to boot to the opensuse grub menu.
Did you try booting from the Raid Card, without before you reinstalled grub?


Quote:
Re-booted, selected Ubuntu from SuSE GRUB;
Did you add an Ubuntu item to the Suse menu.lst? (The suse menu.lst on RESULTS.txt did not have an Ubuntu item)
What item did you use? "configfile (hd2,0)\boot\grub\menu.lst" should work.


Quote:
BUT NOW WORKS
That's the big surprise, Just to make sure:

You boot from the Raid Card to the Suse Grub menu from /dev/sda2.
You use the "configfile (hd2,0)\boot\grub\menu.lst" entry on the Suse Grub menu.
The Ubuntu Grub menu from /dev/sdc1 appears.
You choose the

title XPPro
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

entry on the Ubuntu Grub menu and you boot into XP.
But if you choose the same entree at the Suse Grub menu, booting fails.

Well, I'll add this to my list of weird Grub works arounds.

I just remembered another strange work around I have heard of, but I never actually seen in action. So I'm really curious whether it might work in your case:

Press "c" at the Suse Grub menu after booting from the Raid Card)
(or at the Ubuntu Grub menu after booting from the Ubuntu drive)

map {hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
rootnoverify (hd1,0)
chainloader +1
boot

Last edited by meierfra; 03-26-2009 at 08:51 PM.
 
Old 03-26-2009, 09:08 PM   #39
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
I don't know where PCLOS went...

This is SuSE GRUB, edited.

Quote:
[chucknbfc8@localhost ~]$ su -
Password:
[root@localhost ~]# cat /media/disk/boot/boot/grub/menu.lst
# Modified by YaST2. Last modification on Thu Mar 26 18:31:08 EDT 2009
default 0
timeout 8
gfxmenu (hd0,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part2 resume=/dev/disk/by-id/ata-ST3802110A_5LRADN27-part5 splash=silent showopts vga=0x317
initrd /boot/initrd-2.6.27.7-9-default

This entry is for the original [Ubuntu] GRUB, now partially modded and shown below:
###Don't change this comment - YaST2 identifier: Original name: Ubuntu 8.04.2, kernel 2.6.24-23-generic (/dev/sdb1)###
title Ubuntu 8.04.2, kernel 2.6.24-23-generic (/dev/sdb1)
root (hd2,0)
configfile /boot/grub/menu.lst


###Don't change this comment - YaST2 identifier: Original name: openSUSE 11.1 (/dev/sdb3)###
title openSUSE 11.1 (/dev/sdb3)
rootnoverify (hd1,2)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: Fedora (2.6.27.5-117.fc10.i686) (/dev/sdc4)###
title Fedora (2.6.27.5-117.fc10.i686) (/dev/sdc4)
root (hd0,3)
configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
initrd /boot/initrd-2.6.27.7-9-default

title XPPro2
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1
[root@localhost ~]#
Changes in red:
Quote:

## ## End Default Options ##

title Ubuntu 8.04.2, kernel 2.6.24-23-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=c750b94d-415d-4015-8d90-54500d601b5d ro quiet splash
initrd /boot/initrd.img-2.6.24-23-generic
quiet

title Ubuntu 8.04.2, kernel 2.6.24-23-generic (recovery mode)
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=c750b94d-415d-4015-8d90-54500d601b5d ro single
initrd /boot/initrd.img-2.6.24-23-generic

title Ubuntu 8.04.2, kernel 2.6.22-14-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=c750b94d-415d-4015-8d90-54500d601b5d ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

title Ubuntu 8.04.2, kernel 2.6.22-14-generic (recovery mode)
root (hd2,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=c750b94d-415d-4015-8d90-54500d601b5d ro single
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 8.04.2, memtest86+
root (hd2,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hdb1
UNCHANGED: NOW WORKS!
title XPPro
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda1.


BOOTS BACK TO RAIDBUS DISK. PCLOS MIA, SUSE re-loaded, so they are not entered into this house of cards!!!
title Fedora10
root (hd0,3)
kernel /boot/vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=cc9cedeb-1f14-4cf7-8b4e-ce05acd8c4e7 rhgb quiet
initrd /boot/initrd-2.6.27.5-117.fc10.i686.img
 
Old 03-26-2009, 09:18 PM   #40
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by meierfra View Post
All the results you got are exactly as I would have expected, except that XP booted. But I have a couple of questions:



Why did you have to reinstall grub?
To see if it would 'FIND' XP. As it was, it only loaded SuSE, F10, and PCLOS.


Quote:
It seemed that Grub was already installed corrrectly in the MBR of the Raid card to boot to the opensuse grub menu.
Yes, except for XP and Ubuntu. They were never in the RAIDbus card GRUB - only SuSE, F10, and PCLOS.
Quote:
Did you try booting from the Raid Card, without before you reinstalled grub?
Yes, but I do not remember how it worked out.




Quote:
Did you add an Ubuntu item to the Suse menu.lst? (The suse menu.lst on RESULTS.txt did not have an Ubuntu item)
I have now, but previously Ubuntu and XP were NOT on SuSE GRUB.
Quote:
What item did you use? "configfile (hd2,0)\boot\grub\menu.lst" should work.
See previous post...
 
Old 03-26-2009, 09:41 PM   #41
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by meierfra View Post
Quote:
BUT NOW WORKS (the old XP menu entry)

That's the big surprise, Just to make sure:

You boot from the Raid Card to the Suse Grub menu from /dev/sda2.
You use the "configfile (hd2,0)\boot\grub\menu.lst" entry on the Suse Grub menu.
The Ubuntu Grub menu from /dev/sdc1 appears.
Not sure howw to answer you here. I get the Ubuntu [old] GRUB
You choose the

title XPPro
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

entry on the Ubuntu Grub menu and you boot into XP. [/QUOTE] CORRECT - You got it exactly.
Quote:
But if you choose the same entree at the Suse Grub menu, booting fails.
umm... XP was not on SuSE GRUB before.

After re-installing SuSE GRUB, XP was added, but enumeration was incorrect. It is now corrected.

Quote:
Well, I'll add this to my list of weird Grub works arounds.
Since you follow it, it's worth remembering. I surely have it marked.

Quote:
I just remembered another strange work around I have heard of, but I never actually seen in action. So I'm really curious whether it might work in your case:

Press "c" at the Suse Grub menu after booting from the Raid Card)
(or at the Ubuntu Grub menu after booting from the Ubuntu drive)

map {hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
rootnoverify (hd1,0)
chainloader +1
boot
The entry in the above post now works. I copied it into SuSE menu. Think on that for a moment - 'copied from another disk, and NOW works'.

It comes down to enumeration discrepancy between BIOS and GRUB, when the RAIDbus card is added. Some boards perhaps have a better RAID configuration utility than this Rosetta mobo.
 
Old 03-26-2009, 10:02 PM   #42
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1
Quote:
have now, but previously Ubuntu and XP were NOT on SuSE GRUB.
O.k. I misunderstood want you meant with "reinstalling Grub"

Quote:
BOOTS BACK TO RAIDBUS DISK. PCLOS MIA, SUSE re-loaded, so they are not entered into this house of cards!!!
As far as I can see the Fedora entry seems to be correct.
Did you try the Fedora entry on the Suse Grub Menu?
You might also copy the Fedora entry from Ubuntu menu.lst to Suse menu.lst.


Quote:
It comes down to enumeration discrepancy between BIOS and GRUB, when the RAIDbus card is added.
???????? I don't think so.

Quote:
The entry in the above post now works. I copied it into SuSE menu. Think on that for a moment - 'copied from another disk, and NOW works'.
Really? That's great. Then you won't have go through two grub menus to boot XP.

Last edited by meierfra; 03-26-2009 at 10:04 PM.
 
Old 03-26-2009, 10:47 PM   #43
meierfra
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 1
Just to make sure:

title XPPro
map {hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
rootnoverify (hd1,0)
chainloader +1

on the Suse Grub menu works,

but

title XPPro
map {hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

does not work.

Or do they both work?


Mostly, I'm trying to figure out why you are able to boot XP now. Maybe it is a bug in the Ubuntu Grub, which prevented you from booting XP.
So Suse Grub is able to boot XP, but Ubuntu's Grub is not.
(Note that, if you use "configfile /boot/grub/menu.lst" , then its is Suse Grub which reads Ubuntu's menu.lst.)

Last edited by meierfra; 03-26-2009 at 10:48 PM.
 
Old 03-26-2009, 11:29 PM   #44
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by meierfra View Post
Just to make sure:

title XPPro
map {hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
rootnoverify (hd1,0)
chainloader +1

on the Suse Grub menu works,

but

title XPPro
map {hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

does not work.

Or do they both work?


Mostly, I'm trying to figure out why you are able to boot XP now. Maybe it is a bug in the Ubuntu Grub, which prevented you from booting XP.
But remember; I COULD boot XP if I pulled the card, and did NOTHING else. That's why I think it's a numeration gig.
Quote:
So Suse Grub is able to boot XP, but Ubuntu's Grub is not.
(Note that, if you use "configfile /boot/grub/menu.lst" , then its is Suse Grub which reads Ubuntu's menu.lst.)
I'll try the 2 XP entries tomorrow froom GRUB cli - got bugs in F10 on the table

I DO think there is enumeration differences. If there's not, I'm not understanding how I could have the situation that I had before - insert the RAIDbus card, no XP boot. Pull the card, it boots. It was a third disk, that did not get numbered by BIOS as 3rd disk (hd2); rather it got numbered first (hd0). I don't believe it's a bug either, but I don't know for sure...
 
Old 03-29-2009, 03:14 PM   #45
buccaneere
Member
 
Registered: Nov 2007
Posts: 213

Original Poster
Rep: Reputation: 16
It might not be an enumeration difference. It is a fault in code.

I just updated SuSE GRUB last night, fresh install 1st update for 11.1.

Today when I booted it up, it would not boot. The update did a disk enumeration check, which included GRUB, and it changed the menu entry from hd(correct),x, to hd(incorrect),x.

I changed it back, and no problem. It also added an entry for failsafe 11.1, and gave it the wrong hd#.

All 3 Linux'es on this PCI Raidbus disk, when installed, read disk configuration incorrectly. There is no code for checking enumeration when a PCI Raidbus card is installed.

To really throw in convolution, my Raidbus card has only one disk. The card can handle 4 disks - primary master and slave, and secondary master and slave.

BIOS WILL boot from my ODD's first, since they are first boot device. They are both on ONBOARD IDE primary master and slave. BUT, set BIOS second boot device as hd0, and what boots? NOT the ONBOARD IDE secondary master, but the the RAIDbus card!!!

Why does BIOS boot device 'read' jump from ONBOARD, to PCI RAIDbus card?

AND, what if there are MULTIPLE disks on the RAIDbus card, in the RAIDbus' card primary/secondary master/slave configuration?????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why /boot/grub/grub.conf is symlinked to /boot/grub/menu.lst raj_hcl1986@rediffma Linux - Newbie 2 10-19-2008 02:19 AM
Any grub experts out there ? budword Linux - Software 5 02-08-2008 12:24 PM
Grub question, wrong menu.lst on boot Armane Debian 7 03-27-2007 06:36 AM
GRUB can't boot my new configure kernal. What's wrong? sabaka Linux - Newbie 1 11-23-2003 03:37 AM
Grub wrong can't boot *anything* Bruce Hill Linux - Newbie 3 07-23-2003 09:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration