LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-05-2008, 05:14 PM   #1
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Rep: Reputation: 31
annoying fsck


Every time I boot my laptop, it goes through fsck of my filesystems. this takes quite a while, which is rather annoying. they are formatted as ext3, which should only check once in a great while. what will I need to change to fix this?


kubuntu 8.04
 
Old 06-05-2008, 05:32 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,096

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Please see man tune2fs
 
Old 06-05-2008, 05:52 PM   #3
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Original Poster
Rep: Reputation: 31
I tried tune2fs -j /dev/sda5 and the only output I get is the "usage" instructions. no difference whether the fs was mounted or not
 
Old 06-05-2008, 06:01 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,096

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Why did you choose the -j option?
Quote from man tune2fs:
Code:
−j Add an ext3 journal to the filesystem. If the −J option is not specified, the default journal parame-
   ters will be used to create an appropriately sized journal (given the size of the filesystem) stored
   within the filesystem. Note that you must be using a kernel which has ext3 support in order to
   actually make use of the journal.
You are already using ext3
Please read the man pages, and pay attention to the -c|C|i options.
 
Old 06-05-2008, 06:18 PM   #5
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Original Poster
Rep: Reputation: 31
I set 60 mount limit. actually I had managed to think tune2fs while writing e2fsck. I'll see if this fixed the problem at the next reboot.
 
Old 06-05-2008, 08:26 PM   #6
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Original Poster
Rep: Reputation: 31
setting -c 60 changed nothing, the computer still checks the file systems for several minutes at every bootup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
very annoying ad CollieJim LQ Suggestions & Feedback 6 02-14-2007 09:10 AM
how annoying php Linux - Distributions 9 01-05-2007 10:42 PM
automatic fsck on boot. fsck errors. nixel Slackware 1 05-17-2004 08:51 AM
This is so annoying please help... Z28kid Linux - Newbie 8 03-10-2003 04:54 PM
Really annoying Bigun Linux - General 6 09-15-2002 06:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration