-   Linux - Software (
-   -   annoying fsck (

edgjerp 06-05-2008 05:14 PM

annoying fsck
Every time I boot my laptop, it goes through fsck of my filesystems. this takes quite a while, which is rather annoying. they are formatted as ext3, which should only check once in a great while. what will I need to change to fix this?

kubuntu 8.04

tredegar 06-05-2008 05:32 PM

Please see man tune2fs

edgjerp 06-05-2008 05:52 PM

I tried tune2fs -j /dev/sda5 and the only output I get is the "usage" instructions. no difference whether the fs was mounted or not

tredegar 06-05-2008 06:01 PM

Why did you choose the -j option?
Quote from man tune2fs:

−j Add an ext3 journal to the filesystem. If the −J option is not specified, the default journal parame-
  ters will be used to create an appropriately sized journal (given the size of the filesystem) stored
  within the filesystem. Note that you must be using a kernel which has ext3 support in order to
  actually make use of the journal.

You are already using ext3
Please read the man pages, and pay attention to the -c|C|i options.

edgjerp 06-05-2008 06:18 PM

I set 60 mount limit. actually I had managed to think tune2fs while writing e2fsck. I'll see if this fixed the problem at the next reboot.

edgjerp 06-05-2008 08:26 PM

setting -c 60 changed nothing, the computer still checks the file systems for several minutes at every bootup.

All times are GMT -5. The time now is 01:52 PM.