-   Linux - Software (
-   -   Annoying CD-rom driver error messages (

dinges 02-26-2005 06:52 AM

Annoying CD-rom driver error messages
When I put a DVD disc in my dvd drive the system log is filled up with the following repeating message (it gets in the log every second):

Feb 20 08:44:26 zeno kernel: ATAPI device hdd:
Feb 20 08:44:26 zeno kernel:  Error: Illegal request -- (Sense key=0x05)
Feb 20 08:44:26 zeno kernel:  Cannot read medium - incompatible format -- (asc=0x30, ascq=0x02)
Feb 20 08:44:26 zeno kernel:  The failed "Read Subchannel" packet command was:
Feb 20 08:44:26 zeno kernel:  "42 02 40 01 00 00 00 00 10 00 00 00 00 00 00 00 "
Feb 20 08:44:26 zeno kernel: hdd: packet command error: status=0x51 { DriveReady SeekComplete Error }
Feb 20 08:44:26 zeno kernel: hdd: packet command error: error=0x54
Feb 20 08:44:26 zeno kernel: ide: failed opcode was 100

So the log is filled up rapidly. It's also shown every second on terminal #1, so I can't use that.

I found a discussion between Walsh and Alain Cox in Cox blamed a 'stupid app' that I don't have, but I have of course several media players. Perhaps one of them is to blame: bmp, xine, mplayer, xmms, Helix, Realplayer, and the normal players that are installed by Fedora 3.

Has anyone else had this problem? (My system data are in the signature next to this message). Any ideas on solving this would be welcome.

Sepero 02-26-2005 07:00 AM

Bad title for your thread. :(

rylan76 02-26-2005 08:14 AM


I used to get those types of messages when my old DVD player (an Aopen, don't remember the model) was on the way out. So it might be that you have a hardware fault on the drive. Replace the drive?

I did and this made my "sense key" problems go away.

dinges 02-27-2005 04:44 AM


Rylan 76: it might be that you have a hardware fault on the drive
It can't be the drive. It's brand new.

Sepero: Bad title for your thread.
Alan Cox didn't complain when this subject was issued in 2001.

JohnBell 02-28-2005 05:31 AM

I have a similar problem on Suse 9.2

I haven't isolated the problem entirely, but in my case, when I drop out of X (init 3) the problem disappears. So, I suspect that a media player or something similar is mounting the CD as an audio CD (and not dismounting it if not audio) before any other program can get a look in.


rylan76 02-28-2005 02:24 PM

[QUOTE]Originally posted by dinges
[B]It can't be the drive. It's brand new.

So was my Aopen!


dinges 05-23-2005 11:24 AM

Well it's been a while, and two months after my report I noticed that the problem was gone. It took me that long to notice because I took care not to place any dvd's in the drive. I didn't uninstall any cd player software, but I did of course get the updates via yum. I have no idea which update caused the problem to go away. But it was definitely NOT the cd player hardware as rylan76 suggested.

However I now have a method to locate the program that does it, should it ever happen again. First I locate the cdrom device via /etc/fstab. My system indicates it is /dev/hdd. Next I issue the command

fuser -a /dev/hdd
which gives me a process id. After

ps aux | grep <process-id>
I know which program is working with the device. I can see that Kscd is auto-started with kde. Perhaps that program was the culprit. I'll never know. But I do not like programs that start without my consent. I have yet to find out how to disable this autostart.

wulfilas 05-30-2005 04:43 PM

It was kscd !
I had the same problem:
New installation (SuSE 9.3) on a new QUIET PC ...
and always the noise prrrt, prrrt, prrrrt for every one of those error messages
written to disk.
After I killed kscd it immediately became quiet again :D

evans0409 09-24-2005 12:30 PM

My probing around for what was using /dev/hdb (with fuser -a /dev/hdb and various ps) gave no PID's

On a long shot, I tried killing the hald (haldeamon) and .... no more error! I have, of course, lost some hotplug features, but I do not care and running a command after hooking my camera up, for example, seems preferable to an ever spinning disk (hence fan!).

I am still interested in another work around. Perhaps a bug report to the hald folks is in order?

I hope someone else finds this useful

dinges 09-25-2005 05:53 AM

evans0409 said

On a long shot, I tried killing the hald (haldeamon) and .... no more error!
Well, I'm still using FC3 and never had problems with hald, nor with kscd after the updates. Kscd still uses the drive, but there ar no repeating errors in the log any more. So I'm happy.

evans0409 10-12-2005 04:06 AM

OK, I have FC4 work around until they fix Bug 167542: Toshiba DVD RW Issues

I edited the file


as follows. I removed the lines


    <match key="storage.media_check_enabled" bool="true">
      <append key="info.addons" type="strlist">hald-addon-storage</append>

which were at the end of my file. I'm not sure what the info.addons key does, but some experimentation with hal options indicated that that the storage.media_check_enabled variable set to true is not the culprit. There could be unknown (to e) consequences as well! All I know is that the horrible erro message is now written three times at boot, and never more! Maybe this will help someone else out too.

evans0409 02-05-2006 04:54 PM

I updated my kernel today to 2.6.15-1.1830_FC4smp i686

the problem is gone as verified by commenting out the above code and restarting haldaemon.

All times are GMT -5. The time now is 10:21 AM.