LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2004, 12:45 AM   #1
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
amule, lmule, and xmule problem


I can't seem to get lmule or amule to make and the xmule binary package won't run.

lmule error message when running make 1> /dev/null
Quote:
xh_frame.cpp: In constructor `wxFrameXmlHandler::wxFrameXmlHandler()':
xh_frame.cpp:32: error: `wxDEFAULT_DIALOG_STYLE' undeclared (first use this
function)
xh_frame.cpp:32: error: (Each undeclared identifier is reported only once for
each function it appears in.)
make[4]: *** [xh_frame.o] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
xmule error message when running ./xmule:
Quote:
./xmule: error while loading shared libraries: libwx_gtk-2.4.so: cannot open shared object file: No such file or directory
(...The library is in the same directory as xmule though)

some of the amule errors when running make 1> /dev/null
Quote:
wxcas-onlinesig.o(.text+0x13d): In function `OnLineSig::OnLineSig[not-in-charge]()':
/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:57: undefined reference to `wxGetTranslation(wchar_t const*)'
wxcas-onlinesig.o(.text+0x201):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:65: undefined reference to `wxGetTranslation(wchar_t const*)'
wxcas-onlinesig.o(.text+0x5df): In function `OnLineSig::OnLineSig[in-charge]()':/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:57: undefined reference to `wxGetTranslation(wchar_t const*)'
wxcas-onlinesig.o(.text+0x6a3):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:65: undefined reference to `wxGetTranslation(wchar_t const*)'
wxcas-onlinesig.o(.text+0x1571): In function `OnLineSig::Refresh()':
/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:103: undefined reference to `wxString::wxString[in-charge](wchar_t const*)'
wxcas-onlinesig.o(.text+0x1585):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:103: undefined reference to `wxTextInputStream::wxTextInputStream[in-charge](wxInputStream&, wxString const&, wxMBConv&)'
wxcas-onlinesig.o(.text+0x15c7):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:104: undefined reference to `wxString::wxString[in-charge](wchar_t const*)'
wxcas-onlinesig.o(.text+0x1b3a): In function `OnLineSig::GetConnexionIDType() const':
/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:248: undefined reference to `operator==(wxString const&, wchar_t const*)'
wxcas-onlinesig.o(.text+0x1b51):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:250: undefined reference to `wxGetTranslation(wchar_t const*)'
wxcas-onlinesig.o(.text+0x1b5d):/tmp/aMule-2.0.0rc5/src/utils/wxCas/src/onlinesig.cpp:250: undefined reference to `wxString::wxString[in-charge](wchar_t const*)'
...
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_toolbar_set_space_size'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `g_main_set_poll_func'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_root_window'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_im_end'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_cursor_destroy'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_gc_destroy'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_type_is_a'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_radio_menu_item_group'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_unref'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_regions_intersect'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_set_attr'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_image_destroy'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_radio_button_group'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_get_events'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_notebook_set_page'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_widget_pop_visual'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_signal_disconnect'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_regions_union'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_new'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_accel_group_detach'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_get_visual'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_copy_area'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_im_ready'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_destroy'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_get_style'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_get_size'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_pixmap_unref'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_signal_connect_after'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_container_children'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_type_check_object_cast'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_attr_destroy'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_bitmap_unref'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_root_parent'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_accel_group_attach'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_ic_attr_new'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_regions_subtract'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_signal_disconnect_by_func'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_get_colormap'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_toolbar_set_button_relief'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_regions_xor'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_im_decide_style'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_draw_pixmap'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_container_focus'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_menu_ensure_uline_accel_group'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_widget_push_visual'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_menu_insert'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_menu_append'/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_im_begin'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_widget_set_default_visual'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gdk_window_ref'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_marshal_NONE__POINTER_POINTER'
/usr/local/lib/libwx_gtk2u_core-2.5.so: undefined reference to `gtk_signal_connect'
collect2: ld returned 1 exit status
make[6]: *** [wxcas] Error 1
make[5]: *** [all-recursive] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
My best guess is it has something to do with wxWindows and GTK but I installed wxWidgets with GTK today.
 
Old 09-29-2004, 10:59 PM   #2
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Original Poster
Rep: Reputation: 15
I'm reviving this thread because I am still lost on what I should do for any of the three programs.
 
Old 06-10-2005, 08:04 PM   #3
francesconuma
LQ Newbie
 
Registered: Aug 2003
Distribution: mandriva le2005
Posts: 3

Rep: Reputation: 0
Same problem

Anyone can help us?
make[4]: Entering directory `/home/francesco/lmule-1.2.1/src/wx/xrc'
g++ -I../.. -c `/usr/local/bin/wx-config --cxxflags` xh_frame.cpp
xh_frame.cpp: In constructor `wxFrameXmlHandler::wxFrameXmlHandler()':
xh_frame.cpp:32: error: `wxDEFAULT_DIALOG_STYLE' undeclared (first use this function)
xh_frame.cpp:32: error: (Each undeclared identifier is reported only once for each function it appears in.)
make[4]: *** [xh_frame.o] Error 1
make[4]: Leaving directory `/home/francesco/lmule-1.2.1/src/wx/xrc'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/francesco/lmule-1.2.1/src/wx'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/francesco/lmule-1.2.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/francesco/lmule-1.2.1'
make: *** [all] Error 2
 
Old 06-11-2005, 12:56 PM   #4
Grajagan
LQ Newbie
 
Registered: May 2005
Location: Brazil
Posts: 27

Rep: Reputation: 15
I have wxBase-2.6.0 and wxGTK-2.6.0 and i sucessfuly compiled amule 2.0.1
 
Old 06-12-2005, 03:19 PM   #5
francesconuma
LQ Newbie
 
Registered: Aug 2003
Distribution: mandriva le2005
Posts: 3

Rep: Reputation: 0
I tryed again
Downloaded amule-2.0.2.2....rpm
When i click on the rpm file there's a prompt about missing o not found libwx_baseu_xml-2.6.so.0.
So I downloaded wxgtk and wxbase but when i ./configure the first one I get:

checking for gtk-config... no
checking for GTK - version >= 1.2.7... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for gtk-config... (cached) no
checking for GTK - version >= 1.2.3... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

So I tried to install gtk+ and all relative files but installing glib it asks me gettext-0.14.tar.gz so i downloaded it too but it ask c# compiler..... infinite loop of downloads?!
 
Old 07-15-2005, 07:56 PM   #6
LordSurvivoR
Member
 
Registered: Jul 2005
Location: Serbia
Distribution: Gentoo
Posts: 46

Rep: Reputation: 15
I have the same problem with LMule

Quote:
xh_frame.cpp: In constructor `wxFrameXmlHandler::wxFrameXmlHandler()':
xh_frame.cpp:32: error: `wxDEFAULT_DIALOG_STYLE' undeclared (first use this
function)
xh_frame.cpp:32: error: (Each undeclared identifier is reported only once for
each function it appears in.)
make[4]: *** [xh_frame.o] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Can anyone help us?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
AMule/XMule and Windows eMule compatability Artik Linux - Software 1 05-05-2005 12:55 PM
[HELP] Xmule,aMule,lmule Client For Connect Behind Proxy LukeLuke1979 Linux - Networking 3 12-01-2004 07:52 AM
Xmule,aMule,lmule Client For Connect Behind Proxy LukeLuke1979 Linux - Software 0 10-13-2004 10:37 AM
How do I get xmule or amule to work??? Necronomicom Linux - Software 4 06-22-2004 06:11 PM
aMule / xMule / lMule invalid static cast error Komakino Linux - Software 5 04-22-2004 07:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration