Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-05-2005, 02:02 PM   #1
Senior Member
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
aMule and writing to FAT32

Due to a lack of space on my (home partition, I set aMule's 'incoming' directory to FAT32 partition through a symlink. Everytme I finish downloading a file I get the following error message:
Impossible to set permissions for the file /home/linmix/Musica/filename
(error 1: Operation not permitted)
Additionally, completed ownloads do not disappear from the 'Transfers' window. I have found I can solve this by cancelling the download and accepting a warning message:
Are you sure you want to cancel and delete this file?
The file disaapears from the 'Transfers' window, stays in the 'Shared Files' and is not deleted from the FAT32 partition. However, if I don't do this immediately, after every startup I'll get the same error message and aMule will write a new copy of the downloaded file to the incoming folder.

Is there any way to change this behaviour so that aMule works like it would when writing to a linux native partition?

For your information, file permissions are set in fsatb with "umask=000"

Last edited by linmix; 03-05-2005 at 02:04 PM.
Old 03-06-2005, 07:27 AM   #2
Mega Man X
LQ Guru
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
That was a very old problem known with xMule, but it should be gone by now with new versions of xMule and aMule for that matter. Do you have "exec" permissions to your fat32?. Here is my fstab line:

/dev/hda1 /mnt/win_d vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0
I hope it helps...
Old 03-06-2005, 01:09 PM   #3
Senior Member
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
No, my fstab reads:
/dev/hda7   /mnt/windows/f   vfat	defaults,umask=000,iocharset=iso8859-1,codepage=850	0 0
I tried to get some sharacters like and to work but it didn't do much. I'll try modifying it to what you have and see what happens.

I'm surprised at the "rw" as I can read and write (well, except for aMule that is) to the partition without any problem.
Does the uid=500 and gid=500 give exclusive access to one specific user?

Anyway, man mount tells me:
                     Use  default options: rw, suid, dev, exec, auto, nouser,
                     and async.
so exec is set.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Writing to FAT32 endfx Linux - General 5 08-14-2005 11:02 AM
writing to windows 2000 fat32 partitions from Fedora 2 michaelweaver Linux - Newbie 5 05-24-2005 10:40 PM
not writing to FAT32 Great_Mizuti Linux - Newbie 6 04-03-2005 06:46 PM
Writing to FAT32 Partition Xios Linux - Hardware 8 02-12-2005 01:21 PM
Writing to FAT32 and reading from NTFS in FC2 dysfunction Linux - Hardware 5 11-04-2004 04:26 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration