-   Linux - Software (
-   -   amixer attach default error - no such file or directory (

kite10linux 07-22-2005 12:24 PM

amixer attach default error - no such file or directory
Red Hat 9.0 - new user
just installed ALSA utilities

I tried to run amixer and received the following error:

mixer attach default error, no such file or directory.

What is amixer looking for that it does not find? Do I need to make a file, or give access to a directory? Please help.

BTW - I installed all sound components for RH9, but it did not have the ALSA sound driver installed nor did it have the ALSA sound utilities. What does RH use for sound, and who knows how to use sound in RH9? Why does sound configuration and use seem so complicated in Linux?

darkleaf 07-22-2005 12:29 PM

Does alsamixer work instead of amixer?

kite10linux 07-22-2005 12:35 PM

alsamixer: function snd_ctl_open failed for default - no such file or directory.

It looks like the same type of error. Are there permissions that I need to set for a file or a directory?

darkleaf 07-22-2005 12:44 PM

You're missing the files. There's a script that creates the sound devices. Do you have a script called "snddevices" on your pc? You can find it with "updatedb && locate snddevices". Can you run it and try the command again.

kite10linux 07-22-2005 12:52 PM

I have performed the requested commands. I also ran the snddevices script. Then I tried the amixer and the alsamixer command again, with the same results.

nikolaibelkin 11-24-2009 10:16 PM

Check permissions
This may be caused by permission - or in my case, i used su to switch to another account which could not access visual elements. Try running alsamixer or amixer with sudo permission, if it works as it is supposed to check the permissions, by typing in which amixer, then checking those permissions. If it is not the permissions, make sure that you run it from an account which support visuals, i.e. don't su to a diff user and then try and run it like I did - use either root, or your default user account.

All times are GMT -5. The time now is 02:28 PM.