-   Linux - Software (
-   -   Amarok plugins suddenly stopped working (

gymnart 07-18-2008 02:40 PM

Amarok plugins suddenly stopped working
I used to be able to enjoy Amarok 1.4.7 for listening to internet radio. Now lately, Amarok cannot connect to any stations at all. All I get is an error message, "No suitable input plugin" for every station I try. I'm sure that have them or else it never would have worked in the first place! I have not done a thing to my computer (SuSE 10.0) in a very long time. The only thing that I have done is to surf the internet and use email.

Amarok 1.4.7 uses the Xine Engine on my machine. With the older Amarok, it did give you a choice as to what engine you could use. Now it seems there is only one. I don't see a way to check on my plugins either.

I have tried deleting the .xine file and restarting Amarok but that did not make any difference.

XMMS has no trouble connecting to any stations, so I'm very puzzled about this.

{BBI}Nexus{BBI} 07-18-2008 10:58 PM

Try renaming your /home/username/.kde/share/apps/amarok folder to something like amarokold, then delete your /home/username/.kde/share/apps/amarok folder and fireup amarok to see if the problem is solved. If you don't need your original amarok folder you can just delete it instead of renaming it.

gymnart 07-19-2008 12:46 PM

I did as you said, and that did not make any difference.

I tried connecting to my favorite Shoutcast stations from my Windows XP computer and they just timed out. I'm beginning to think that it's more of a firewall issue. I found that XMMS can connect to some Icecast (xiph) stations and I just tried it in Amarok and that worked. So I'm now limited to just those 3 streams that work.

P.S. Thanks for your reply. :D

Abdrahim 02-10-2009 07:50 PM

I had the same problem. All worked well when I turned off the firewall, in my case Firestarter. Thanks for the hint.

All times are GMT -5. The time now is 08:56 AM.