-   Linux - Software (
-   -   ALT+CTRL+F1-F6 quit working (

vsnyder 04-18-2010 12:10 AM

ALT+CTRL+F1-F6 quit working
I just installed some updates, one of which might have been

Before I installed the updates, switching to a VT console using ALT+CTRL+Fn (n=1..6) worked, but after installing the updates it quit working within a KDE session. It does still work from the login screen (so it's not an X problem, or a /etc/inittab problem).

After logging into a KDE session, I can get to a VT console if I first use ALT+CTRL+F12.

Here's the keyboard section from xorg.conf:

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

There is no option DontVTSwitch line.

I have the same problem on another computer. That one is more of a problem because its keyboard doesn't have an F12 key.

What to do?

business_kid 04-19-2010 11:27 AM

Check the file /etc/inittab for lines like these
# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

ps -e |grep agetty should show you a process for every terminal that's not logged in
ps -e |grep bash should show you a process for every one that is.

Tell us if those are correct.

vsnyder 04-19-2010 03:20 PM

ALT+CTRL+F1-F6 quit working
As should have been clear from the original question, ALT+CTRL+F1 switches to a text console, but only before logging in to a KDE session. Once a KDE session is open, ALT+CTRL+F12 followed by ALT+CTRL+F1 works. This is therefore not a problem with /etc/inittab (which has a date of 7 Sep 2007, much older than the onset of the problem), or X (xorg.conf has a date of 14 Dec 2008, also much older than the onset of the problem). The problem is almost surely a KDE problem. I can't find anything in the KDE Control Panel that re-maps ALT_CTRL_Fn (n=1..6).

vsnyder 04-19-2010 03:23 PM

ALT+CTRL+F1-F6 quit working (additional info)
By "before logging into a KDE session" I mean in level 5, from the X login screen, not before xdm is launched.

vsnyder 04-19-2010 03:32 PM

More follow-up: GNOME has the same problem. From the X login screen, ALT+CTRL+F1-F6 switches to a text console. After logging in to either GNOME or KDE, ALT+CTRL+F12 switches to a blank non-X screen (no login prompt), from which ALT+CTRL+Fn (n=1..6) switches to a text console. From a text console, ALT+CTRL+F7 switches back to X as expected. So it's probably not a KDE or GNOME problem. What is it? Definitely not /etc/inittab.

business_kid 04-20-2010 04:52 AM

Have you tried downgrading the kernel?

All times are GMT -5. The time now is 11:46 PM.