LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   alsaconf needs to be run after every reboot (https://www.linuxquestions.org/questions/linux-software-2/alsaconf-needs-to-be-run-after-every-reboot-405170/)

dick-richardson 01-18-2006 09:33 PM

alsaconf needs to be run after every reboot
 
I'm running debian sarge with a custom 2.6.15 kernel and had sound working "out of the box." Then I installed alsa and am beating my head against the wall trying to figure this problem out. On boot, there's a FATAL message when loading something, but it scrolls by too fast to see, nor does it show up in dmesg (or in /etc/var/messages). 2 lines of note in the dmesg output are:

cannot find the slot for index 0 (range 0-0)
Sound Fusion CS46xx: probe of 0000:00:0c.0 failed with error -12

I get an artsmessage when kde loads that it's using the null device for sound and running /etc/rc5.d/S12alsa start yields:

Setting up ALSA.../etc/init.d/alsa: Warning: 'alsactl restore' failed with error message 'No state is present for card Camera'. done.

Once I run alscaconf, life is good. I'm using a Turtle Beach Santa Cruz card. Any suggestions?

dick-richardson 01-19-2006 01:41 AM

I ran lsmod before and after running alsaconf and compared the difference. After running alsaconf, the following modules were NOT loaded:

Module Size Used by
snd_usb_audio 72256 1
snd_page_alloc 10440 2 snd_cs46xx,snd_pcm
snd_usb_lib 15168 1 snd_usb_audio
snd_hwdep 9376 1 snd_usb_audio

dick-richardson 01-20-2006 12:44 AM

Not sure if it'd be considered "fixed," but it's working after doing a kernel recompile and removing all sound cards but the one in my system.

fang0654 07-13-2006 02:54 PM

Found the cause
 
I had the same problem, and figured out what was causing the problem. I have a QuickCam Pro 4000, which has an internal microphone, which loads the usb_sound module, which in turn conflicts with the intel0x8 driver, and crashes. When I unplugged the webcam and rebooted it, it worked fine.


All times are GMT -5. The time now is 07:58 AM.