-   Linux - Software (
-   -   Alsa Sound problems under KDE 3.2 (SuSe 8.2) (

Juan_lutz 02-12-2004 08:08 AM

Alsa Sound problems under KDE 3.2 (SuSe 8.2)
After an update to KDE 3.2 many little problems appeared, but all of them were solved, with the exception of the sound behavior for some application.

1) xmms: version 1.2.7
Even by free Sound Resources, it freeze when the output plugin aRtds 0.4 is being used.
If the output plugin is OSS 1.2.7. and the aRtds is being used by other applications than come the warning the sound device is busy. otherwise if the Sound source are free, it works fine and OK

2) Some existing Games, are running mute. and sometimes follwing warning appeared:
"Error initializing Sound Driver
device: default can't be opened for playback (device or resource
Sound server will continue using the null output device"

It seems to be a problem with the ALSA driver. But I am not sure. I have googled and the issue is well known and the possible solution seems to be a new ALSA driver installation (issue that is not easy for a newbie), but I am not sure, considering that KDE 3.2 now take a controll of the sound system. I suspect it is a configuration issue.

AMD XP 2200+
512 MB Ram
SUSE 8.2
KDE 3.2

Can some one offer me a solution?.

dander062 02-13-2004 12:36 AM

Look at YaST control center --> Hardware --> Sound.

Is there a sound system listed and running?
Is "Start sequencer" checked?
In Volume is PCM at 67 or higher?

Is this a motherboard sound system or add in card?

Juan_lutz 02-13-2004 08:51 AM

Hello thank you for your interest.
Yes it is a CMPI8338 (i think) a build in one.
I will check the parameters tonight.

My ugly problem is with WineX, the games running without sound there too.

Best regards,

dander062 02-13-2004 10:54 AM

A wine problem. I may not be too much help.
I have used CrossOver office, but not for games.
There is a game version of wine that may work your sound card. Is that the wineX you are having problems with?

vinay_s_s 02-13-2004 01:15 PM

I think its because of arts. Disable arts in the kde control center.

Juan_lutz 02-17-2004 02:26 AM

Hello verybody,
thank you for your feedback.

Ok now to information:

1.- Yes the wine is winex 3.2.1 from transgaming.

2.- I have disabled the arts from the Control Center but, no effect. I have the same behavior. Some games and wineX games are running without sound.

I don't understand why during the KDE 3.1.4 all sound tasks were OK. Now seems to be configuration issue in ALSA or aRts that I don't know.

Thank you for more replies.


number9 05-16-2004 08:35 PM

had the same problem, uninstall package, kdemultimedia3-mixer

All times are GMT -5. The time now is 02:50 AM.