LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-26-2007, 04:25 AM   #1
souhakubunn
LQ Newbie
 
Registered: Oct 2007
Location: China
Distribution: LFS
Posts: 8

Rep: Reputation: 0
ALSA said "could not find module snd"


I just installed alsa-lib-1.0.15,alsa-plugins-1.0.15,alsa-utils-1.0.15.
And I did choose:"Advanced Linux Sound Architecture,Sequencer support,Sequencer dummy client, OSS Mixer API, OSS PCM API,OSS Sequencer API, and Support old ALSA API" in Advanced Linux Sound Arthitecture in my kernel and recompiled it.

I followed the instructions from this page:
http://www.alsa-project.org/main/ind...l#modules.conf

But I got these:

Code:
root [ / ]# modinfo soundcore
modinfo: could not find module soundcore

Code:
root [ / ]# modinfo sound
modinfo: could not find module sound
Code:
root [ / ]# alsaconf
modinfo: could not find module snd
modinfo: could not find module snd
modinfo: could not find module snd
which: no dialog in (/usr/local/sbin:/usr/local/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin)
which: no whiptail in (/usr/local/sbin:/usr/local/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin)
Error, dialog or whiptail not found.
I am using LFS and the kernel version is 2.6.22.12, lspci displays:
Code:
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
What should I do?
Didn't I turn on the sound support soundcore module? And if not, how can I turn on it?

Thanks.
 
Old 11-26-2007, 08:49 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,630

Rep: Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808Reputation: 1808
Quote:
root [ / ]# modinfo soundcore
modinfo: could not find module soundcore
The above means that either you don't have sound support in your kernel, or that you have compiled ALSA as built-in and not as modules. Running
Code:
cat /usr/src/linux/.config|grep "CONFIG_SOUND="
cat /usr/src/linux/.config|grep "CONFIG_SND="
which one is the case.
Then you should recompile your kernel to support sound and ALSA as modules.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't find "/etc/module.conf" in Fedora Core 4 scweston Linux - Newbie 2 06-26-2005 01:51 PM
need to find "module" information for wireless card bsurfn99 Linux - Wireless Networking 1 01-23-2005 07:42 AM
"unable to find the dependent module" reji vl Linux - Software 0 01-22-2004 08:55 AM
ALSA module is used by "pid 3596" Olle Linux - Software 8 01-19-2004 11:25 AM
"modprobe snd-sscape" for ALSA a no go? r_jensen11 Linux - Software 1 05-21-2003 06:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration