LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ALSA mutes on startup (https://www.linuxquestions.org/questions/linux-software-2/alsa-mutes-on-startup-746495/)

lisa86 08-10-2009 01:26 PM

ALSA mutes on startup
 
I am using Debian sid.
I am having trouble with alsa. Everytime Kmix starts up Master goes back to 0%
I have done alsamixer and maxed out everything and then "alsactl store" Still didn't help. On reboot sound goes mute and I have to manually unmute it from Kmix. I am using KDE4.3
I thought this would be relevant:
Code:

$ ls -l /sys/module/snd/holders
total 0
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_hda_codec -> ../../snd_hda_codec
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_hda_codec_realtek -> ../../snd_hda_codec_realtek
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_hda_intel -> ../../snd_hda_intel
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_hwdep -> ../../snd_hwdep
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_mixer_oss -> ../../snd_mixer_oss
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_pcm -> ../../snd_pcm
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_pcm_oss -> ../../snd_pcm_oss
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_rawmidi -> ../../snd_rawmidi
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_seq -> ../../snd_seq
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_seq_device -> ../../snd_seq_device
lrwxrwxrwx 1 root root 0 2009-08-10 15:00 snd_timer -> ../../snd_timer



I have added
Code:

options snd-hda-intel index=0 in /etc/modprobe.d/alsa-base.conf
My card is:
Code:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)


Regardless this, sound works fine, i just want it to start normally.
Thanks i advance.

jdkaye 08-10-2009 01:32 PM

Have you checked the kde sound settings in the kde control centre? It sound like it might be a KDE issue rather than an Alsa issue. Just go into the Sound & Multimedia Section and have a look at what your KDE setting are in both the General and Hardware tabs.
cheers,
jdk

lisa86 08-11-2009 06:20 AM

I noted that it is actually kmix. Kmix mutes the Master channel whereas PCM and Front stay at 100%

jdkaye 08-11-2009 09:33 AM

Quote:

Originally Posted by lisa86 (Post 3638994)
I noted that it is actually kmix. Kmix mutes the Master channel whereas PCM and Front stay at 100%

Does this mean you've solved your problem?
jdk


All times are GMT -5. The time now is 06:34 AM.