LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-27-2003, 03:05 AM   #1
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Rep: Reputation: 0
ALSA installation problem


I am trying to install ALSA on my Redhat 9 system.

I found the installation instructions at the alsa website.

Followed them to the letter.

When I unzipped and installed the alsa-driver package in konsole, I got the following:

[root@localhost alsa-driver-0.9.7]# ./configure --with-cards=intel8x0 --with-sequencer=yes;make;make install

checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for executable suffix...
checking for object suffix... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for ranlib... ranlib
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for gcc option to accept ANSI C... none needed
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-0.9.7
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel sources (default is /usr/src/linux).
make all-deps
make[1]: Entering directory `/usr/src/alsa/alsa-driver-0.9.7'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-0.9.7'

Please, run the configure script as first...

rm -f /snd*.o /persist.o /isapnp.o
make[1]: Entering directory `/usr/src/alsa/alsa-driver-0.9.7/support'
Makefile:9: ../Makefile.conf: No such file or directory
Makefile:27: /Rules.make: No such file or directory
make[1]: *** No rule to make target `/Rules.make'. Stop.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-0.9.7/support'
make: *** [install-modules] Error 1

**********

I have no directory /usr/src/linux. The installation seems to get hung up at this point.

Looking for help deciphering what konsole told me and how I can get past whatever hurdle I am facing.

TIA . . . peace

 
Old 09-27-2003, 03:52 AM   #2
meldroc
Member
 
Registered: Aug 2003
Posts: 102

Rep: Reputation: 15
You need to install the kernel source code. That should be available in your Red Hat distro as an rpm package. The kernel source usually, but not always lives in /usr/src/linux.
 
Old 09-27-2003, 02:04 PM   #3
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
Smile Kernel source code installed - modprobe won't run

Thanks for your help . Installed the kernel source code and the compilation seemed to work, until . . .

until it tries to modprobe, or I try to modprobe, and I get:

"bash: modprobe: command not found"

I get the same when I try to lsmod

Both are in the /etc dir

I manually edited the modules.conf with the exact info from the alsa site.

Everything seemed to go well until I got the modprobe error.

I have tried googling and searching elsewhere to find out how to overcome the modprobe issue, but to no avail.

Any suggestions would be most helpful!

Peace . . .

 
Old 09-27-2003, 03:03 PM   #4
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
sounds like your not root >> ??

if you are root then try
man modprobe

Id think it strange if it were not installed

Last edited by mossy; 09-27-2003 at 03:06 PM.
 
Old 09-27-2003, 03:56 PM   #5
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
Running modprobe in root results in the same error message as before.

man modprobe works, however.

I tried modprobe with various commands listed in the man, nothing worked.

modprobe shows up in the /sbin directory in light blue color.

If I can't find a resolution to this, I am tempted to reinstall RH9 since I know how to do what I need to do up to this point. Maybe something got corrupted somewhere.

Thanks again!

Peace . . .

penguinsrcool

Last edited by penguinsrcool; 09-27-2003 at 03:59 PM.
 
Old 09-27-2003, 04:00 PM   #6
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
what is the full modprobe command you are trying to do - are you copying and pasting it form the alsa instructions to avoid errors ??

Last edited by mossy; 09-27-2003 at 04:14 PM.
 
Old 09-27-2003, 04:07 PM   #7
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
Ok, I can get modprobe to work if I type in the full path /sbin/modprobe (even if I am in the /sbin dir). I will try the alsa modprobe command again from the alsa website and see what happens.

Last edited by penguinsrcool; 09-27-2003 at 04:23 PM.
 
Old 09-27-2003, 04:28 PM   #8
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
I ran the modprobe command from the alsa website which resulted in the following:

[root@localhost sbin]# /sbin/modprobe snd-intel8x0;modprobe snd-psm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss
/lib/modules/2.4.20-20.9/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-20.9/kernel/sound/pci/snd-intel8x0.o: insmod /lib/modules/2.4.20-20.9/kernel/sound/pci/snd-intel8x0.o failed
/lib/modules/2.4.20-20.9/kernel/sound/pci/snd-intel8x0.o: insmod snd-intel8x0 failed
bash: modprobe: command not found
bash: modprobe: command not found
bash: modprobe: command not found

This doesn't mean much to me, but with your help I am learning. At least I got something to happen.

penguinsrcool
 
Old 09-27-2003, 04:33 PM   #9
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
help will prolly be modprobe --help

You are not using the rpms anymore right?
the exact command I had to type was:

modprobe snd-emu10k1;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss

what does yours look like?

1) reboot and try again [!]
2) make sure you are logged into console as root/su -
3) scream
4) I suppose it might be possible you dont have those commands installed - you can prolly install them from rpmfind.org or freshmeat.net
 
Old 09-27-2003, 04:43 PM   #10
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
type dmesg as suggested by the error - check it for any clues
it appears the command may not be in your uid's path [dont know too much about this in depth] - rebooting may put this straight again or you can research on how to add commands to your path

Last edited by mossy; 09-27-2003 at 04:47 PM.
 
Old 09-27-2003, 04:43 PM   #11
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
No, not using the rpms. I *thought* I had uninstalled them all. I am considering uninstalling everything alsa related and starting over.
 
Old 09-27-2003, 04:46 PM   #12
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
I did the dmesg and here is what seems to be sound related:

Intel 810 + AC97 Audio, version 0.24, 11:55:17 Aug 18 2003
PCI: Found IRQ 11 for device 00:1f.5
PCI: Sharing IRQ 11 with 00:1f.6
PCI: Sharing IRQ 11 with 02:0b.1
PCI: Setting latency timer of device 00:1f.5 to 64
i810: Intel ICH3 found at IO 0xcdc0 and 0xce00, MEM 0x0000 and 0x0000, IRQ 11
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
ac97_codec: AC97 Audio codec, id: YMH3 (Unknown)
i810_audio: only 48Khz playback available.
i810_audio: AC'97 codec 0 supports AMAP, total channels = 2

See anything odd?
 
Old 09-27-2003, 05:02 PM   #13
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
Ahh - I believe I remember you have to remove all sound related modules before adding the alsa modules - NB you will not have sound after removing those modules. Alsa modules will have "snd" in them. I do not see any here so it look like you still have your original modules in there. Did you remove the original sound modules yet?? if not I can research that for you and let you know for sure if you have to remove them but I am nearly certain. I am practically certain but would hate to take responsibility for you having no sound. I am pretty certain - yes I know I did remove my original sound modules before inserting the alsa modules. 's your call - modprobe -R i810_audio etc etc will remove it. go thru each audio module - then insert them again

I might be wary abut removing anything until you get the modprobe command working properly.
 
Old 09-27-2003, 05:05 PM   #14
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I think your modules for you sound device is already loaded. Type /sbin/lsmod to find out. If lsmod is not there type whereis lsmod.

Go to http://www.alsa-project.org/alsa-doc...odule=intel8x0

Carefully follow the directions.

I suggest you use && instead of ;. && means do this command if there is any errors don't do the next command. ; means do this command and who cares if errors comes up--go to the next command.

If you want to log everything that is displaying, you can use the pipe ' | ' command and tee. For example make | tee alsamake.log . What this does it runs make and directs the output to tee. tee then writes to a file named alsamak.log but it also displays the output of make at the same time. I suggest you find out more about tee using the man command.

You may want to have look at justlinux.com in the library section.
 
Old 09-27-2003, 06:14 PM   #15
penguinsrcool
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
lsmod results:

Module Size Used by Not tainted
snd-mixer-oss 16408 0 (autoclean) (unused)
snd 43108 0 (autoclean) [snd-mixer-oss]
i810_audio 27624 1 (autoclean)
ac97_codec 14568 0 (autoclean) [i810_audio]
soundcore 6404 2 (autoclean) [snd i810_audio]
lp 8996 0 (autoclean)
parport 37056 0 (autoclean) [lp]
autofs 13268 0 (autoclean) (unused)
orinoco_cs 5556 1
orinoco 39724 0 [orinoco_cs]
hermes 8068 0 [orinoco_cs orinoco]
ds 8680 2 [orinoco_cs]
yenta_socket 13504 2
pcmcia_core 57216 0 [orinoco_cs ds yenta_socket]
e100 54596 0 (unused)
ipt_REJECT 3992 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 15096 2 [ipt_REJECT iptable_filter]
sg 36524 0 (autoclean)
sr_mod 18136 0 (autoclean)
ide-scsi 12208 0
ide-cd 35712 0
cdrom 33728 0 [sr_mod ide-cd]
sd_mod 13516 2 (autoclean)
nls_iso8859-1 3516 3 (autoclean)
ntfs 59008 3 (autoclean)
printer 8928 0
usb-storage 74656 1
scsi_mod 107544 5 [sg sr_mod ide-scsi sd_mod usb-storage]
keybdev 2976 0 (unused)
mousedev 5556 1
hid 22244 0 (unused)
input 5856 0 [keybdev mousedev hid]
usb-uhci 26412 0 (unused)
usbcore 79040 1 [printer usb-storage hid usb-uhci]
ext3 70784 2
jbd 51924 2 [ext3]

Since I am getting sound, am I correct in reading the above that the soundcard is using the i810_audio driver? This is the way it was before I tried installing alsa, so I am not sure if anything has changed. snd and snd-mixer-oss are at 0.

Would it be wise to remove all sound modules, remove alsa and start over? What I am still concerned about is that in my initial alsa compile modprobe failed. I am afraid this would happen all over again.

I'll be sure to check out justlinux.com.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA installation problem waelaltaqi Linux - Software 3 10-03-2005 12:51 PM
Installation problem of ALSA on linux kernel 2.4.20-8 usher_raymond82 Linux - Software 3 06-12-2005 09:54 PM
another alsa installation problem tnielsen Linux - Software 1 08-17-2004 07:37 PM
Problem with ALSA installation White R4bbit Debian 9 12-19-2003 03:07 AM
Alsa sound installation problem matthead Linux - Newbie 2 11-13-2001 07:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration