-   Linux - Software (
-   -   ALSA drivers work well, sound channels mixed up (INTEL AD1981A ICH4) (

fritex 11-05-2002 07:00 PM

ALSA drivers work well, sound channels mixed up (INTEL AD1981A ICH4)
Hi there

There are 2 things I would like to clear out with the help of anyone:

1. I am very new to Linux, and I was having problems installing sound on it, just like a lot of other people that I've seen on other threads, who had the same on board sound card. I have a p4 1.7GHz, with an intel mobo (D845EBG2), i845E chipset, and AD1981A AC97' sound. I have read on another thread that the linux kernel only supports ICH4 starting version 2.5.11, which I know is still under development. But I went to and found that the latest stable version, 2.4.19 supports ICH4. Can anyone confirm or deny that? Would this kernel version solve my sound problem? (The soundcard autodetection in RH 8.0 KDE detects my soundcard as i810, but it doesn't work, please see 2)

2. Since I couldnt get sound using the modules that came with my distribution (RH 8, kernel 2.4.18-17.8.0) I installed ALSA drivers version 0.9.orc5, and they work fantastically, only problem is when I run alsamixer, the sound channels are somehow reversed. Sound coming from my speakers correspond to the "headset" sound channel on alsamixer, and "master volume" doesn't seem to do anything to the sound. For mpu files and general sounds the channel on alsamixer and on kmix or volume control in KDE is pcm, and again, master volume doesn't do anything. I still get sound fine, I was just wondering if anyone came across the same problem of mixed up sound channels.

Because of the sound channels problem I would have preferred to use native drivers.

Thanks in advance


fritex 11-21-2002 06:31 PM

I'm reviving this thread to see if anyone can help me with this issue. I looked up from help but couldnt find any.

I appreciate your time


pauet 12-05-2002 01:10 PM

I'm not having the same problem as you, but I also have the same Intel board. I'm currently using Debian woody (3.0r0). In fact, my problem is that I haven't been able to configure the card yet... :(

I'll try the latest alsa and tell you the outcome...


fritex 12-05-2002 04:38 PM


I'm using the orc5 version of the alsa drivers. I think the latest is orc6 or higher, so maybe (hopefully) they've fixed the problem.
I look forward to how it turns out for you, good luck! Maybe then I can get mine working too.

By the way, it seems that at least with the orc5 version, you can't have full duplex operation (no playing/recording at same time or having 2 requests at same time to sound device). For example, when I'm using xmms and I open a site with Flash animation and sound, my browser will freeze, since it cant get it's sound request through to the soundcard. Obviously I dont have this problem with windows, since they have full duplex drivers for our mother board's soundchip. I know that opensound drivers for linux work in full duplex mode, but you have to play US$56 for a license, and honestly I'd rather buy a SB live card with that money...

In any case, let's hope the alsa drivers will eventually work in full duplex.


fritex 12-05-2002 04:40 PM

OOps, quick follow up, the alsa driver version I have is 0.9.0rc5, and the latest ones are 0.9.0rc6
I made a mistake on the drivers version


slulovic 03-04-2003 12:28 AM

I'm having this problem aswell. For me, none of the 12 sound channels do anything, except PCM and PCM2. It seems both control the sound. The master "Volume" control doesn't do anything, and its annoying when I need to mute or unmute or even change the volume level at all.

Anyone figured out a fix for this?


allanmcmillin 05-30-2003 08:59 PM

Intel i810 sound works under Redhat 9
I have sound play back in Red Hat 9

and the Master volume and PCM and PCM2 work as well

Recording how ever seems to be problematic and I doubt it is full duplex

Oh well :rolleyes:

All times are GMT -5. The time now is 02:56 PM.