-   Linux - Software (
-   -   alsa-driver compilation problem (

Fisknils 06-10-2006 06:53 AM

alsa-driver compilation problem
I'm running kernel 2.6.8-2-386 with Debian, and when I try to compile alsa-driver I get the following error:


make[1]: Entering directory `/usr/src/kernel-source-2.6.8'
  CC [M]  /home/fisknils/alsa/alsa-driver-1.0.11/acore/memalloc.o
/bin/sh: line 1: scripts/genksyms/genksyms: No such file or directory
make[4]: *** [/home/fisknils/alsa/alsa-driver-1.0.11/acore/memalloc.o] Error 1
make[3]: *** [/home/fisknils/alsa/alsa-driver-1.0.11/acore] Error 2
make[2]: *** [_module_/home/fisknils/alsa/alsa-driver-1.0.11] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/kernel-source-2.6.8'
make: *** [compile] Error 2

I've also tried apt-get'ing alsa, but alsaconfig doesn't recognize my soundcard for some reason (which is integrated on the motherboard; Asus A8N5X - nForce4 chipset)
I've also tried installing the nForce drivers from, but with those, I get the following error:

  In file included from /usr/src/kernel-source-2.6.8/include/linux/list.h:7,
                    from /usr/src/kernel-source-2.6.8/include/linux/wait.h:14,
                    from /usr/src/kernel-source-2.6.8/include/asm/semaphore.h:4
                    from /usr/src/kernel-source-2.6.8/include/linux/sched.h:18,
                    from /usr/src/kernel-source-2.6.8/include/linux/module.h:10
                    from /tmp/selfgz7152/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
  /usr/src/kernel-source-2.6.8/include/linux/prefetch.h: In function `prefetch
  /usr/src/kernel-source-2.6.8/include/linux/prefetch.h:62: warning: pointer o
  f type `void *' used in arithmetic
  /bin/sh: line 1: scripts/basic/fixdep: No such file or directory
  make[4]: *** [/tmp/selfgz7152/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nv
  alinux.o] Error 1
  make[3]: *** [_module_/tmp/selfgz7152/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
  /main] Error 2
  make[2]: *** [modules] Error 2
-> Error.
ERROR: The NVIDIA kernel module was not created.
ERROR: Installation of the audio driver has failed.  Please see the file
      '/var/log/nvidia-nforce-installer.log' for details.  You may find
      suggestions on  fixing installation problems in the README available on
      the Linux driver download page at

I'd rather get alsa-drivers up and working than the nForce drivers to be honest. But either will do. Anyone?

bathory 06-10-2006 08:28 AM


/bin/sh: line 1: scripts/genksyms/genksyms: No such file or directory
I think there is something wrong with your kernel sources installation, because the correct path should be "scripts/genksyms". Note that genksyms is part of the package "module-init-tools", so check if you have the latest installed and then check your kernel-source installation instructions of your distro. Perhaps you've missed something.


Fisknils 06-10-2006 08:59 AM

When I recompiled the kernel, I just copied the .config file from /usr/src/linux/ and put it in my kernel-source dir.
It was the same version of the kernel, and the only reason I recompiled it was that I somehow managed to mess up the old source-dir and I needed it in order to compile the alsa-driver.

So basically, there should not be a problem with the kernel-source, since I didn't use the expert mode. (the linux26 installation is pretty safe, isn't it?)

Either way, I'm currently reading the documentation from the kernel-source dir to rebuild the kernel once more.

btw, "module-init-tools" was according to apt-get installed with the latest version.

Any other tips?

EDIT: I downloaded a newer version of alsa-driver from and got a brand new error :P

/bin/sh: line 1: scripts/basic/fixdep: No such file or directory

this file exists as well :P

bathory 06-10-2006 10:06 AM

How did you recompile your kernel? You should run:

make oldconfig
before running make, make modules_install etc.

Fisknils 06-10-2006 10:39 AM

Ahhh.. that's probably what I did wrong. I just copied the .config from /usr/src/linux to the kernel-source-dir.

I'll recompile it again. Thanks for the help, mate :)

Fisknils 06-10-2006 12:20 PM

okay. I used the same source-dir and did "make clean && make && make modules && make modules_install". Then I copied the kernel image from /usr/src/kernel-source/arch/i386/boot/bzImage to /boot/vmlinuz and rebooted. Everything seems to be in order, but I still get the same errormessage for the alsa-driver package. :(

Did I do anything wrong?

bathory 06-10-2006 05:47 PM

Well, it seems you need to do more things. Take a look at this thread and specially at the 2nd post.

Fisknils 06-11-2006 06:33 AM

Actually, I recompiled the kernel (again) with a new kernel-source-version nad included the driver in the kernel.
Now, alsamixer can find the soundcard and everything suggests that the soundcard is working except for the fact that there's still no sound.

I dont know where to start looking for info :S

EDIT: Just tried skype'ing with a friend. He can hear me after some alsamixer adjustments. But I can't hear anything

bathory 06-11-2006 10:08 AM

You should play with alsamixer and unmute most of the channels there (like master, pcm, etc) and also raise the volume to an auditible level. You can use "speaker-test" which produces a continuous sound through your speakers and adjust the alsmixer levels till you can hear that sound through your speakers.

Fisknils 06-11-2006 06:42 PM

I've done this. Unmuted all channels and muted them again one by one while running speaker-test. No success. I've also asked a friend that's pretty good with linux, and he couldn't figure out what was wrong either.

Everything suggests the soundcard should be operating, but it doesn't.

What can I do to debug?

Fisknils 06-12-2006 07:19 AM

just fixed it. -.-
Even though I've tried all sockets before, now for some reason, the "white" socket worked. >_<

Isn't that 5.1 sound btw? I've only got 2.1 :P

All times are GMT -5. The time now is 12:52 AM.