LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-14-2005, 09:38 PM   #1
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Rep: Reputation: 15
Alsa 1.08


I think i screwed up trying to upgrade from ALSA 1.06 to 1.08, as I dont get any sound at all.

lsmod reports:
Code:
[root@localhost mog]# lsmod
Module                  Size  Used by
isofs                  31352  1
cpufreq_powersave       1312  0
p4-clockmod             3720  0
speedstep-lib           3364  1 p4-clockmod
md5                     3584  1
ipv6                  230916  12
snd-pcm-oss            49320  0
snd-mixer-oss          17472  1 snd-pcm-oss
snd-intel8x0           29244  1
snd-ac97-codec         74936  1 snd-intel8x0
snd-pcm                80648  3 snd-pcm-oss,snd-intel8x0,snd-ac97-codec
snd-timer              20388  1 snd-pcm
snd                    47524  8 snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer
soundcore               7008  1 snd
snd-page-alloc          7432  2 snd-intel8x0,snd-pcm
af_packet              16072  2
ds                     17572  2
yenta_socket           18624  0
pcmcia_core            59972  2 ds,yenta_socket
thermal                 9928  0
tc1100-wmi              5028  0
processor              13736  1 thermal
fan                     2756  0
button                  4624  0
battery                 7044  0
ac                      3204  0
8139too                20928  0
mii                     4224  1 8139too
eth1394                17000  0
ide-cd                 37280  1
cdrom                  37724  1 ide-cd
ohci1394               30788  0
ieee1394              292056  2 eth1394,ohci1394
loop                   12520  0
intel-agp              19584  1
nvidia               3913852  14
agpgart                27752  2 intel-agp,nvidia
tsdev                   5824  0
joydev                  8032  0
evdev                   7648  1
usbmouse                4256  0
usbhid                 41088  0
ehci-hcd               26244  0
uhci-hcd               28752  0
usbcore               103172  6 usbmouse,usbhid,ehci-hcd,uhci-hcd
genrtc                  7444  0
ext3                  120680  2
jbd                    49080  1 ext3
I downloaded alsa-driver-1.0.8.tar.bz2 from their website and followed the instructions to the part at the end where it says "7) Edit your kernel module config (either /etc/modprobe.conf or
/etc/modules.conf, depending on the kernel version)." and im not exactly sure what im supposed to edit. Does anybody know how to fix this?
 
Old 03-14-2005, 10:10 PM   #2
bioagentice
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10
Posts: 25

Rep: Reputation: 15
reconfigure alsa:
alsaconf: then press enter a lot of times and you should be set.
if not let me know and i will help you further.
 
Old 03-14-2005, 10:43 PM   #3
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Original Poster
Rep: Reputation: 15
First off, thank you for your post. I ran alsaconf and it still doesnt work. No sound from anything. Im not sure what you would need to figure this out any easier. If it is easier for you to contact me via aim, my address is moogle915. Thanks
 
Old 03-15-2005, 12:08 AM   #4
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
For Mandrake 10 or higher and using the 2.6.x kernel version, you edit /etc/modprobe.conf. I think all you need to do is run alsamixer and set the volumes. Then run alsactl store as su or root.
 
Old 03-15-2005, 12:24 AM   #5
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Original Poster
Rep: Reputation: 15
I tried it and it still doesnt work. alsamixer returns
Code:
┌───────────────────[AlsaMixer v1.0.6 (Press Escape to quit)]──────────────────┐
│ Card: Intel ICH5                                                             │
│ Chip: Conexant id 30                                                         │
│ Item: Master                                                                 │
│                               ------   ------    ------            CAPTUR    │
│    ┌──┐     ┌──┐      ┌MM┐     ┌MM┐     ┌MM┐      ┌MM┐     ┌MM┐    L┌──┐R    │
│    │  │     │  │      │  │     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │  │      │  │     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │  │      │  │     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │▒▒│      │▒▒│     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │▒▒│      │▒▒│     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │▒▒│      │▒▒│     │  │     │  │      │  │     │  │     │  │     │
│    │▒▒│     │▒▒│      │▒▒│     │  │     │  │      │  │     │  │     │  │     │
│    └──┘     └──┘      └──┘     └──┘     └──┘      └──┘     └──┘     └──┘     │
│   74<>74   55<>55    55<>55    0<>0     0<>0        0                        │
│ < Master >Headphon    PCM      Line      CD       Mic    Mic Boos  Video     │
└──────────────────────────────────────────────────────────────────────────────┘

┌───────────────────[AlsaMixer v1.0.6 (Press Escape to quit)]──────────────────┐
│ Card: Intel ICH5                                                             │
│ Chip: Conexant id 30                                                         │
│ Item: Video                                                                  │
│   CAPTUR   ------                                ------   CAPTUR   ------    │
│   L┌──┐R    ┌──┐      ┌MM┐     ┌──┐     ┌MM┐      ┌──┐    L┌──┐R    ┌──┐     │
│    │  │     │  │      │  │     │▒▒│     │  │      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │  │      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │▒▒│      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │▒▒│      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │▒▒│      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │▒▒│      │  │     │  │     │  │     │
│    │  │     │  │      │  │     │▒▒│     │▒▒│      │  │     │  │     │  │     │
│    └──┘     └──┘      └──┘     └──┘     └──┘      └──┘     └──┘     └──┘     │
│                                 100      67                0<>0              │
│ < Video  > Phone     IEC958  IEC958 P PC Speak    Aux    Capture    Mix      │
└──────────────────────────────────────────────────────────────────────────────┘

then i ran alsactl store as root and it returned nothing. Any more suggestions, or did i forget to do something?
 
Old 03-15-2005, 12:29 AM   #6
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Common sense should tell you to unmute PCM. Though you did not compile and install everything because you are still using alsa 1.06.
 
Old 03-15-2005, 12:41 AM   #7
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Original Poster
Rep: Reputation: 15
Well then, how exactly do i compile everything for 1.08? I am still quite new to linux and am trying to learn as I go.
 
Old 03-15-2005, 02:11 AM   #8
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Read the documentation for your sound card (intel8x0 assuming your sound device is intel) at ALSA site. Their how to is a little wrong. When you specify "./configure ; make ; make install", it will not stop on errors if there is any. I recommend "./configure && make && make install" because it stops on errors if there is one.

TIP: Only use ; when using bash code at the bash prompt. Never use ; during compiling or never use it when you need the previous command to succeed before going to the next command. Use && if you need the previous command to succeed before going on to the next command.
 
Old 03-16-2005, 03:58 PM   #9
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Original Poster
Rep: Reputation: 15
Hi again

I tried the howto from the alsa website for my intel8x0 card, and alsa 1.06 is still installed, not 1.08. I tried to upgrade to 1.08 because I get sound problems when I run any game with cedega. The sound from the game will go away, and I hear nothing but static. I am not sure if it was an alsa problem, but it was the only thing i could think of. Any suggestions on how to fix either of these problems?
 
Old 03-17-2005, 05:08 AM   #10
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
To install alsa, you have to first compile and install the drivers. Then compile and install the library. Next compile and install the utilities. After you have suceeded in these steps as su or root. Type modprobe -r snd-intel8x0. Then type modprobe snd-intel8x0. The easiest to reload the modules is to do service alsa restart. Typing cat /proc/asound/version will give you the version. However you will need to install the source or headers for your kernel because you need that to compile and install the drivers.

Probably its outputting digital information to your amplifier. You can try muting headphones and IEC 958 P. You must unmute PCM if you want to hear any sounds.
 
Old 03-17-2005, 06:42 PM   #11
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Original Poster
Rep: Reputation: 15
Well, alsa 1.08 is now installed. thanks for your help, however anything run with cedega outputs no sound at all. Any suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 05:32 AM
Alsa sound *jumpy*: alsa-space: xrun of at least 11.449 msecs. resetting stream qwijibow Linux - General 6 04-22-2006 08:35 PM
ALSA-oss compatability works, but not programs intended for alsa ? qwijibow Linux - Software 5 03-14-2004 08:28 AM
ALSA on Debian, Kernel Source is There Alsa dosent see it? pfizur Linux - Software 3 12-27-2003 09:46 AM
2.6.0 minus built-in ALSA drivers + ALSA 1.0.0rc2 Tino27 Slackware 3 12-19-2003 06:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration