-   Linux - Software (
-   -   Alpine with SMTP password (

273 05-11-2012 02:15 PM

Alpine with SMTP password
I have just installed alpine and set it up to retrieve messages from an IMAP server. What I cannot do, however, is send email.
I have set the SMTP server to:

But when sending an email instead of being prompted for a password I just see the message "Error sending".
I notice when I start alpine I get the message "Return address in mail you send may be incorrect" but I don't know if that is relevant and I can't find an entry for return address in .pinerc.
Does alpine allow for SMTP passwords and, if so, how do I configure this?

Andy Alt 05-15-2012 12:27 AM

You'll usually need to specify a different port when using SSL or TLS

273 05-15-2012 05:46 AM

Thanks, sadly that results in exactly the same error.

Andy Alt 05-15-2012 01:38 PM

I've tried using Alpine with my Yahoo mail -- I subscribe to the Yahoo Mail plus and can send and receive using POP3 clients. I tried to get it working with alpine once but was unsuccessful. According to this, the fault lies in the Yahoo SMTP server.

Perhaps it's the same issue you're experiencing. I've read that people have got it to work with gmail but not other providers.

One other thread about this issue:

273 05-15-2012 01:44 PM

From the way the problem manifests I think that must be the issue. I can tell something happens because there's a delay between hitting send and the error message when the correct details are entered.
I don't suppose you know of any other easy-to-set up straightforward text-mode mail clients do you? Though if it's my mail provider I suppose I might be stuck and have to resort to telnet if I want to send from the terminal.

Andy Alt 05-15-2012 03:51 PM

I used mutt for a while a few years back. I always liked pine(alpine) better, but it wasn't too bad once I got used to it. I don't know if you'd have the same problem though; I never tried it with my Yahoo mail plus.

Another one came up in a google search called gnus.

Also "mail" is available.

273 05-15-2012 04:20 PM

Thanks, I'll go away and play a bit. In the mean time I'll mark this solved since it seems there's not a fix.

All times are GMT -5. The time now is 12:14 AM.