LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-12-2004, 02:28 PM   #1
suit4
LQ Newbie
 
Registered: Feb 2004
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Allow apache2 to read from mounted device


this might be a newbie question, but i just don't get it.

i'm running my system with winxp and linux.
on both os's is an apache2 running.

i'd like to use the htdocs on both linux and windows.

so i moved the htdocs to a fat32-partiotion, which is accessible from within linux.
(let's say /mnt/workspace/htdocs)

changing the apache server root to /mnt/workspace/htdocs causes a 'forbidden'

changing the server root back to /var/www/localhost/htdocs and replacing the original htdocs with a symlink to /mnt/workspace/htdocs does not help either.
even if i change the apache.conf to 'FollowSymLinks', still no access to my data.
(errorlog: No symbolic links allowed for ....)

i think, it's some kind of ownership or rights-problem.
or maybe a change in my fstab (option for /mnt/workspace is set to users)?

any ideas ?

thanks so far ....
 
Old 02-13-2004, 05:26 PM   #2
cav
Member
 
Registered: Feb 2003
Location: Chicago
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
I had a lot of problems with apache permissions too. My solution was to symlink the folder, and do the old 'chmod a+rwx'. I think that has become my motto lately. When in doubt, chmod a+rwx. Security wise, not the best motto, so dont quote me on that.
 
Old 02-13-2004, 05:29 PM   #3
cav
Member
 
Registered: Feb 2003
Location: Chicago
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
That reminds me, I also had to change the permissions on my fat drives at mount time in order for apache to read them. Do this by adding 'umount=000' to the options field in your fstab file. Like this:

/dev/hde5 /fat-d vfat defaults,umask=000 1 0
/dev/hdf3 /fat-e vfat defaults,umask=000 1 0

That also gives everybody all permissions, so use at your own risk.
 
Old 02-16-2004, 10:06 AM   #4
suit4
LQ Newbie
 
Registered: Feb 2004
Distribution: Gentoo
Posts: 2

Original Poster
Rep: Reputation: 0
Smile thanks, thats it!

editing fstab fixed the problem.

apache now accepts access to my htdocs. cool.

next, i try to share my mysql database on both systems.....

thanks alot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 01:17 PM
apache2.conf read-only? lPrentice Linux - Newbie 4 05-26-2005 11:06 PM
NFS: a mounted to b, b mounted to c, c can't read a? Steve Cronje Linux - Networking 9 10-25-2004 10:51 AM
Can't read mounted drive mabarnes Linux - Newbie 4 12-19-2003 11:36 PM
Fs mounted in Read Only , Read Write Mode benjaminrtz Linux - General 2 07-31-2002 03:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration