-   Linux - Software (
-   -   After restart of router Sendmail (

theret79 06-19-2006 02:51 PM

After restart of router Sendmail
After I restart my router I am unable to connect to my server which is sendmail through the ports 25 and 110. They are open on the router. I tried restarting sendmail and no go. It is Sendmail version 8.11.6 on a Linux machine. Any help would be great.

Gethyn 06-20-2006 07:51 AM

Which version of Linux? How did you install it? Do you have any firewall software installed on the Linux computer? How does the computer get its IP from the router? If it's DHCP, the address may have changed when the router rebooted, in which case the firewall rules will no longer be any good.

Incidentally, why are using sendmail? It has a bad history when it comes to security. Using a different mail server program might be a better idea.

theret79 06-20-2006 09:03 AM

Linux 7.2 I actually didn't install it, I have been here a year and we have been using it the entire time and have never had any problems with it. I do not believe that it is DHCP, but I am not 100 percent sure. I think we are using sendmail because they wanted to save some money. We are going to be getting exchange at the end of the year. I can telnet into my server name 25 and 110 on my lan, but on my lan if I telnet 25 or 110 it says it cannot connect. Does this sound like a firewall blocking the domainname?

Gethyn 06-20-2006 11:45 AM

Okay, to clarify slightly: Linux is the name of the kernel. The latest version is 2.6.17, so I doubt you are using Linux 7.2. Sounds (at a guess) like you're using Red Hat 7.2.

There are free mail server programs other than sendmail available. I use qmail on my server, for example. No idea how you'd install that on an old version of Red Hat though.

It does sound like your firewall is blocking access. Try looking into the configuration of that. You may also be able to tell whether the computers on the network get addresses by DHCP or not by looking at the firewall configuration too.

One tool that might help you a little is nmap, if you've not tried it before. Try using it to scan the server from inside the network and outside the network (make sure you speak to the network admin first, if you're not him!). It should tell you which ports are open - sounds like this is pretty much the information you have from telnet, but nmap can give you more detailed information.

jeelliso 06-20-2006 02:09 PM


Does this sound like a firewall blocking the domainname?
Your firewall shouldn't be blocking domain names anyway, but it may block IP addresses. You should be using a static IP address (i.e., no DHCP) and some kind of DNS server. If you can't connect using the qualified domain name, but you can connect using the raw IP, then you have a DNS domain problem. Make sure your DNS server is setup correctly.


One tool that might help you a little is nmap, if you've not tried it before.

nmap -p1-65535
and it will tell you what ports are open.

If you are using Red Hat, then try looking in /etc/sysconfig/network-scripts/ifcfg-eth0 to find out whether you use DHCP or raw IP.

Try sending an email after restarting the Sendmail. Post the relevant lines from /var/log/maillog so we can see what is going on. Also please post the output from the nmap command.

Good Luck,

theret79 06-20-2006 02:28 PM

here is the nmap acan
Port State Service
22/tcp open ssh
23/tcp open telnet
25/tcp open smtp
109/tcp open pop-2
110/tcp open pop-3
111/tcp open sunrpc
143/tcp open imap2
513/tcp open login
515/tcp open printer
901/tcp open samba-swat
993/tcp open imaps
1024/tcp open kdm
1050/tcp open unknown
10000/tcp open unknown

Maillog post
Jun 20 14:58:14 mail ipop3d[1564]: pop3 service init from
Jun 20 14:58:14 mail ipop3d[1564]: login user=dcannon host=[] nmsgs=0/0
Jun 20 14:58:14 mail ipop3d[1564]: Logout user=dcannon host=[] nmsgs=0 ndele=0

could it be ipop3d that is causing this problem as it looks like the email is getting hung up somewhere between the router and the mail server. I am able to send out just not receive. our MX record is in good shape

in the ifcfg-eth0
I have
DEVICE = eth0
ONBOOT = yes
BOOTPROTO = static

All times are GMT -5. The time now is 02:48 AM.