LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   after KDE reinstall, printer stoped working (how to set it up?) (https://www.linuxquestions.org/questions/linux-software-2/after-kde-reinstall-printer-stoped-working-how-to-set-it-up-345967/)

Mistreated 07-23-2005 07:36 AM

after KDE reinstall, printer stoped working (how to set it up?)
 
Hi,
my distro is Gentoo, a few days ago i installed KDE 3.4, after that my HP DeskJet 3650 stopped printing. I have tried to install the printer via KDE print tool, as i did it before, but it still doesn't work! I've also tried to reinstall cups, foomatic, hpijs and even kdeprint packages, but it didn't helped. CUPS seems to be working fine.. It's really strange because in history all jobs is marked as aborted. And here is my /var/log/cups/error_log content (hope it helps to clear the situation):

I [23/Jul/2005:15:06:23 +0300] Loaded configuration file "/etc/cups/cupsd.
conf"
I [23/Jul/2005:15:06:23 +0300] Configured for up to 100 clients.
I [23/Jul/2005:15:06:23 +0300] Allowing up to 100 client connections per h
ost.
I [23/Jul/2005:15:06:23 +0300] Full reload is required.
I [23/Jul/2005:15:06:24 +0300] LoadPPDs: Read "/etc/cups/ppds.dat", 332 PP
Ds...
I [23/Jul/2005:15:06:24 +0300] LoadPPDs: No new or changed PPDs...
I [23/Jul/2005:15:06:24 +0300] Full reload complete.
I [23/Jul/2005:15:11:51 +0300] Adding start banner page "none" to job 7.
I [23/Jul/2005:15:11:51 +0300] Adding end banner page "none" to job 7.
I [23/Jul/2005:15:11:51 +0300] Job 7 queued on 'dj3650' by 'mistreated'.
I [23/Jul/2005:15:11:51 +0300] Started filter /usr/lib/cups/filter/pstops
(PID 7177) for job 7.
I [23/Jul/2005:15:11:51 +0300] Started filter /usr/lib/cups/filter/foomati
c-rip (PID 7178) for job 7.
I [23/Jul/2005:15:11:51 +0300] Started backend /usr/lib/cups/backend/usb (
PID 7179) for job 7.
E [23/Jul/2005:15:11:51 +0300] PID 7178 stopped with status 22!
I [23/Jul/2005:15:11:51 +0300] Hint: Try setting the LogLevel to "debug" t
o find out more.

Any suggestions to my problem?
Thank You!

comprookie2000 07-24-2005 03:58 AM

Post lsusb
and
tail /var/log/cups/error_log

Mistreated 07-24-2005 11:29 AM

With USB everything is fine, here's lsusb result:

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:7204 Hewlett-Packard DeskJet 36xx
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

And tail /var/log/cups/error_log i've already listed in previous post. But.. ok, here it is:
I [24/Jul/2005:18:28:37 +0300] LoadPPDs: No new or changed PPDs...
I [24/Jul/2005:18:28:37 +0300] Full reload complete.
I [24/Jul/2005:19:33:31 +0300] Adding start banner page "none" to job 10.
I [24/Jul/2005:19:33:31 +0300] Adding end banner page "none" to job 10.
I [24/Jul/2005:19:33:31 +0300] Job 10 queued on 'dj3650' by 'mistreated'.
I [24/Jul/2005:19:33:31 +0300] Started filter /usr/lib/cups/filter/pstops (PID 7 247) for job 10.
I [24/Jul/2005:19:33:31 +0300] Started filter /usr/lib/cups/filter/foomatic-rip (PID 7248) for job 10.
I [24/Jul/2005:19:33:31 +0300] Started backend /usr/lib/cups/backend/usb (PID 72 49) for job 10.
E [24/Jul/2005:19:33:31 +0300] PID 7248 stopped with status 22!
I [24/Jul/2005:19:33:31 +0300] Hint: Try setting the LogLevel to "debug" to find out more.

comprookie2000 07-24-2005 11:39 AM

You could install the newer drivers;
For printing support, you must have the ppds USE flag enabled.
emerge hplip
Then go back to http://localhost:631 and reconfigure

Mistreated 07-24-2005 12:22 PM

When i was emerging cups, hpijs and foomatic, i set USE variable to
USE="kde qt kdeenablefinal kdexdeltas cups foomaticdb ppds usb hpijs"

And what is hplip? Is it some kind of an alternative to hpijs, or just a new version of it with a different name?

comprookie2000 07-24-2005 12:25 PM

Here it is;
http://www.gentoo.org/doc/en/printing-howto.xml

Mistreated 07-24-2005 01:28 PM

Thanks for help, but hplip is masked..

!!! All ebuilds that could satisfy "hplip" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-print/hplip-0.9.3 (masked by: ~x86 keyword)

Should i merge it anyway?
I've also merged pnm2ppa, but no changes..

Why it's not working?! Everything was just fine!
Am i the only one who have got the HP printer???

comprookie2000 07-24-2005 02:29 PM

I have the same printer deskjet 3650, and it works fine.I have not used kde to set up a printer in a while, I do it with localhost.You will get it working, just need to find out why.I would go into the kde printer set-up and remove what ever is there so it is Blank.Add that driver to /etc/portage/package.keywords and emerge it.It may pull in something you need. to see what will happen do a emerge -pv <package name> I would emerge it all again, sometimes that is all it takes.Just follow the guide all the way through, may get lucky, it should work. good luck If you want I could give you the pid file from mine but it is on a server here at the house but I could e-mail it to you.
look at /etc/cups/cups.conf
and /etc/cups/ppd there should be the ppd there

Mistreated 07-25-2005 01:28 PM

I don't know, what to do! I've tried to install it in many different ways: by my own, according to Gentoo Handbook, via KDE Print, via http://localhost:631.. I was trying to configure it with hpijs and with hplip.. I've also used different USE variable values, and used it with the PPD file from the LinuxPrinting.org, but result is the same, as i described it before! Nothing changed! Maybe i messed up with configuration file update after emerge -Du world...
Could you please send me all possible printer configuration files, and tell what software and what versions are you currently using with your printer.
Thank you!

comprookie2000 07-25-2005 03:05 PM

See if these are the same as yours;
http://abbottdavid.no-ip.info/printer/

Mistreated 07-26-2005 05:14 PM

Thanks, for supplying me with config files! But it didn't work, neither with hpijs of hplip.
Then i've tried to unmerege hpijs, cups, foomatic, etc, delete all config files and install those packages again from scratch. The result was the same!
Maybe you know, how to set the LogLevel to "debug"? I would like to see what exactly is error 22 and maybe there will be some other information. Maybe it'll spread some light on me problem.

Mistreated 07-28-2005 04:16 PM

I have fixed the printer, now everything is ok, and it's working fine! I accidentally noticed, that file /usr/bin/foomatic-rip is absent! This file is part of package foomatic-filters, and i think it's most important of all filters. And there is a lot of symbolic links in the system directories to this file.
So if someone is having the same problem as i had, just reinstall foomatic-filters package!


Thanks for help, comprookie2000! Sorry for bugging you! :)

comprookie2000 07-28-2005 04:32 PM

Glad you got it fixed, your not bothering me. It took me a while to get a epson printer working one time then it started printing garbage and I couldn't turn it off.Even when I rebooted and went to print something it would do it all over again.Used up all the ink.I put the printer on the driveway and droped a block on it so I know your frustration.

Mistreated 07-28-2005 04:39 PM

:)
Thanks for understanding! :)


All times are GMT -5. The time now is 09:12 PM.