-   Linux - Software (
-   -   Adobe Flash player; can't complete install (

Texian 10-25-2008 11:08 AM

Adobe Flash player; can't complete install
As a newbie I'm having several issues, mostly with viewing video and PPT/PPS. I'm using Fedora 8 (2.6) I normally use YUM.

In this thread I will deal only with the video aspect. At YouTube I get this mssg;

"Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player."

Every where I have looked in my system it confirms that Java is turned on. I have tried to DL the latest flash player, following all the steps but I still get the same msg. Something is either preventing completion of install or ...??

All help is appreciated.

PTrenholme 10-25-2008 11:51 AM

Are you running a 64-bit version of F8? The Flash plug-in will not, normally, run in a browser compiled with 64-bit libraries. (See below.)

On the Adobe site there is an option to install the "YUM version," which is just the /etc/yum.repos.d/adobe-linux-i386.reop file so your Abobe stuff can be loaded using YUM. Here's a copy of what's in my /etc/yum.repos.d:

$ cat /etc/yum.repos.d/adobe-linux-i386.repo
name=Adobe Systems Incorporated

I don't know if it's available on F8, but the F9 repositories contain nspluginwrapper RPM that will let you us 32-bit plug-ins with Netscape-based (e.g., Firefox, Konqueror, Chrome [I think], etc.) browsers compiled with 64-bit libraries.

Texian 10-25-2008 12:14 PM

Thanks for the quick response.
This is what terminal said:

# cat /etc/yum.repos.d/adobe-linux-i386.repo
name=Adobe Systems Incorporated

Is there other info I could get for you that would help figure this out?

PTrenholme 10-25-2008 10:14 PM

Well, from that you're running as root in a terminal window, so be careful to make no mistakes typing,

But what you see is the description of the Adobe repository location, which looks correct. So all you need to do now is install the Flash player from the repository. Just enter yum install flash-player (as "root," of course) and you should be done.

Texian 10-26-2008 01:06 PM

Adobe Flash Player
I had tried that earlier but was hoping I had not used the dash. here is the response:

""Loading mirror speeds from cached hostfile
* livna:
* fedora:
* rpmforge:
* updates-newkey:
* updates:
livna | 2.1 kB 00:00
fedora | 2.1 kB 00:00
rpmforge | 1.1 kB 00:00
adobe-linux-i386 | 972 B 00:00
updates-newkey | 2.3 kB 00:00
k12ltsp | 1.1 kB 00:00
updates | 2.6 kB 00:00
freshrpms | 2.4 kB 00:00
macromedia | 1.9 kB 00:00
webmin | 951 B 00:00
Excluding Packages in global exclude list
Setting up Install Process
Parsing package install arguments
No package flash-player available.
Nothing to do
You have new mail in /var/spool/mail/root"

Would this msg come up if the program is already on my system but not operating? I know I get a msg about needing JAVA but when I chkd system it is there.

hulk321 10-26-2008 01:18 PM

hi buddy check this link out it is very very useful in general

Texian 10-26-2008 04:27 PM

Hulk; Thanks, I tried your suggestion here is the response:

Setting up Install Process
Parsing package install arguments
Package flash-plugin- already installed and latest version
Package libflashsupport-0.1.1-2098.fc6.i386 already installed and latest version
Nothing to do
You have new mail in /var/spool/mail/root
[root@ ~]#

My system keeps telling me these are installed, yet I can't watch video from web and almost every site I visit tells me I need to Dl the flash plugin.
Thanks for the input, keep on thinkin' cause i'm out of ideas!


PTrenholme 10-27-2008 10:37 AM

You never commented on my remark that the Adobe did not support 64-bit browsers.

What is the output of uname -a on your system, and what does the Help->About say in your browser?

The flash player plug-in is usually installed in /usr/lib/flash-plugin/ with soft links from your browser's plug-in libraries to that location.

What browser are you using?

Texian 10-27-2008 04:38 PM

Sorry about skipping that post. I wasn't sure how to get that info.

$ uname -a
Linux #1 SMP Sat Sep 20 09:32:58 EDT 2008 i686 athlon i386 GNU/Linux

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

I looked for the file "/usr/lib/flash-plugin/" here is what I found when drilling down from Computer, USR, Flash-Plugin; Basic tab;

TYPE: shared library
SIZE: 9.6 MB
LOCATION: /usr/lib/flash-plugin

MIME type: application/x-sharedlib

I looked under the tab "Open With", there are No applications selected.
Of course I wouldn't know if that is normal or not, ;-)

I really appreciate you folks helping me work thru this.

PTrenholme 10-27-2008 09:59 PM

Do you get this when you enter the command in a terminal window?

$ ls -l /usr/lib/mozilla/plugins/
lrwxrwxrwx 1 root root 39 2008-10-20 12:03 /usr/lib/mozilla/plugins/ -> /usr/lib/flash-plugin/

(Well, the date and time should be different.)

As far as I can see, if that symbolic link is there, it should be working.

I was just installing FF 3.0.3 from the tar.gz2 file on an old Fedora 8 system and discovered I needed to do a $ sudo ln -s /usr/lib/flash-plugin/ /usr/lib/firefox-3.0.3/plugins/ to get FF 3.0.3 to use the Flash Player plug-in. So the above "check" I suggested may have referenced the wrong (i.e., mozilla) directory.

Note that the unpacking of the tar file needs to be done thusly:

$ sudo tar -jxvf  firefox-3.0.3.tar.bz2 -C /usr/lib/
$ sudo mv /usr/lib/firefox /usr/lib/firefox-3.0.3
$ sudo rm /usr/bin/firefox
$ sudo ln -s /usr/lib/firefox-3.0.3/firefox /usr/bin/firefox

to get a clean, multi-user, install.

Texian 11-09-2008 10:49 AM

PTrenholme: Sorry, it has taken a while for me to understand what to do.. when I go to terminal I do not see anything like the statement you asked about.
[neil@neil ~]$ uname -a
Linux #1 SMP Sat Sep 20 09:32:58 EDT 2008 i686 athlon i386 GNU/Linux

I tried running the first command line and got no results.
# sudo In -s /usr/lib/
sudo: In: command not found

Then tried unpacking the tar?
# sudo tar -jxvf firerfox-3.0.3.tar.bz2 -C /usr/lib/
tar: firerfox-3.0.3.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

Sorry, I'm so dense. I went and bought a book on linux maybe that will at least get me up to speed on terminology & so I can better understand what needs to be done. I do appreciate your patience and all the effort on my behalf.

PTrenholme 11-09-2008 05:27 PM

Well, the uname output tells us that your system uses a AMD "Athlon" processor, and that you've installed a 32-bit operating system.

Since you're using a 32-bit OS, the "Flash" plug-in should work "out of the box," and the player plug-in (Flash 10) is, according to your post #7, above, is installed.

You still seem to be running as "root" in a terminal window, so did you open a terminal window in your account and enter the su command to change to "root?" The reason I ask is because the su command, without any arguments, will log you in as "root" but leave your current environment settings unchanged. If you add a dash after the su (i.e., su -), you will be logged in as "root" and get the default "root" environment settings.

Without "root's" environment settings many commands will not be available without your entering the full path to the command. So when you reported the ln was not available as a command, my first thought was that your environment (specifically, the PATH variable) was not set correctly. However, ln should be available to anyone since it's in /bin which is in everyone's path. (By the way, if you're running as "root," the sudo preceding the command is superfluous since you already have "root" privileges.)

Since you report that ln is not available as a command, I have serious doubts that your installation has been correctly completed. In fact, I'd suggest a complete re-install.

However, look at your PATH setting. You should see something like this:

$ echo $PATH]
$ su -
# echo $PATH

The differences should be that your PATH strings should start with /usr/lib/qt-3.3 instead of lib64 since you're using a 32 bit kernel, and, second, that the first PATH string should, obviously, reference your home directory rather than mine. :)

If those PATH values differ from the ones I have, again, I'd question that you have a good installation.

If they are substantially the same, then do a locate flash-plugin (you may need to do a updatedb first) which should show this:

# locate flash-plugin

and a locate -r flashplayer should show this:

locate -r flashplayer

(As I mentioned, above, the "mozilla" may need to be "firefox," but it seems to work this way on this installation.)

Anyhow, let us know what you see and we can, hopefully, get you straightened out.

Texian 11-10-2008 08:35 AM

I believe we are getting close to the problem. - - -
$ echo $PATH]

From first install I had problems with auto updates due to problem with package "lib 264" if I remember the # correctly. When getting root, I have always used "su -"

# locate -r flashplayer spit out a lot of entries and near bottom of list was:


There are some "/usr/lib/firefox-" numbers .10 thru .17 with NO #11. if that means anything?

I'm assuming a complete re-install will wipe out all data currently stored on hd, right? I don't have much; could probably dl to flash drive.

If I do a re-install would it be advisable to get a later version? (currently running #8) If so which would you suggest?

PTrenholme 11-10-2008 01:06 PM

What is in PATH when you do the echo $PATH after the su -? (I.e., when you're running as "root.") As I said, the fact that the link command (ln) was not found is quite worrisome.

Another thing: I notice from your locate -r flashplayer output that you've apparently installed the nspluginwrapper package. Since that's a package that supports using 32-bit plug-ins (like the Flash Player) when you're using a 64-bit browser, it's rather strange to find it when you are, apparently, using a 32-bit operating system so your browser would, perforce, need to also be a 32-bit version. I don't think that having it installed should cause any problem, but you could un-install it to see if it would help.

As to Fedora version, Fedora 8 is scheduled to have its support terminated fairly soon after Fedora 10 is released later this month. (I haven't checked the schedule lately, but Fedora 10 was slated for release this week when I last looked.)

If, instead of a re-install, you were to do an upgrade, then your data should be preserved. (But I'd recommend a back-up of anything you wish to preserve before even an upgrade. I've never had a problem upgrading, but that's no guarantee that the next time would go so well for either you or me.)

teckk 11-11-2008 12:27 PM

My 2 cents if it helps.


I tried running the first command line and got no results.
# sudo In -s /usr/lib/
sudo: In: command not found
That should be ln (el en) not In (eye en)

That may be why no ln (link) command found

Also space between ln -s /usr/lib/

Making a link in your browsers plugin directory to the library which is sitting in /usr/lib/

All times are GMT -5. The time now is 11:13 PM.