LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-19-2014, 10:26 PM   #1
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Iowa
Distribution: Debian distro family
Posts: 2,342

Rep: Reputation: Disabled
adjusting the clock in XFCE


How do I change the time on XFCE's panel clock? An option to adjust the clock doesn't appear to be in a very obvious place, such as the clock's right-click menu or in the control panel. Oddly enough, I'm not finding anything with an internet search either,

Last edited by newbiesforever; 12-19-2014 at 10:27 PM.
 
Old 12-19-2014, 10:48 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 18,773
Blog Entries: 28

Rep: Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970Reputation: 5970
The panel clock likely reflects the system clock, so this is about setting the system clock.

When I have to set the clock, I usually use the hwclock command as root to set the hardware clock time, then the hwclock -s command as root to bring the system clock in line with the hardware clock. I poked at this over a period of two weeks once when I was dual-booting Fedora and Slackware to get the two distros to both show the same time, but I finally got it figured out. There are, natch, many other ways to get to the same goal of coordinating the two clocks.

This link gives a pretty good intro to the process. However, I do not use the strings they show as their examples. I'm more likely to use something like this (from the hwclock man page):

Code:
hwclock --set --date="2011-08-14 16:45:05"
If I remember correctly (it's been a while since I've had to do this), this

Code:
hwclock --set --date="6:45:05"
will change the time without touching the date.

The timezone setting can also come into play, as Linux prefers to be set to UTC, then to use the timezone offset to display the time in local time.

This link may also help.

I generally keep ntp turned on, but make sure it's pointed to benign servers.

This is one of those areas that, because of the variables involved (particularly timezones), can be much more complicated than it looks. In Windows World, the assumption is that everything is always set to local time, so that that variable is removed.

Last edited by frankbell; 12-19-2014 at 10:57 PM.
 
2 members found this post helpful.
Old 12-19-2014, 11:36 PM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Try to use ntpd to set time. It keeps UTC date and time in 100s of milliseconds accurate.
 
1 members found this post helpful.
Old 12-20-2014, 11:11 AM   #4
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 6,046

Rep: Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271Reputation: 2271
Quote:
Originally Posted by newbiesforever View Post
How do I change the time on XFCE's panel clock? An option to adjust the clock doesn't appear to be in a very obvious place, such as the clock's right-click menu or in the control panel. Oddly enough, I'm not finding anything with an internet search either,
That depends on your distro, which you really ought to indicate when you post a question. Desktop tools are for adjusting the desktop, rather than the system. In Salix, for example, you'd run clocksetup as root, but in the Red Hat family it would be system-config-date.

Last edited by DavidMcCann; 12-20-2014 at 11:13 AM.
 
1 members found this post helpful.
Old 12-20-2014, 11:58 AM   #5
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Iowa
Distribution: Debian distro family
Posts: 2,342

Original Poster
Rep: Reputation: Disabled
Sorry, it's antiX.
 
Old 12-20-2014, 02:44 PM   #6
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: No more Linux. Done with it.
Posts: 1,238

Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
In Windows World, the assumption is that everything is always set to local time, so that that variable is removed.
In Windows there is an option to set time to UTC actually (through registry).

Quote:
Originally Posted by veerain
Try to use ntpd to set time. It keeps UTC date and time in 100s of milliseconds accurate.
Before that the OP has to deal with timezones and BIOS time because Linux takes time from BIOS while booting. Of course you can set ntp to correct current time in system everytime after booting the OS, it will still be wrong in “system clock” (BIOS). So after setting correct time in Linux OP has to do something like

Code:
hwclock --utc -w
or

Code:
hwclock --localtime -w
to save this time to BIOS.
 
Old 12-23-2014, 11:28 PM   #7
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
I tried timeconfig and setting the clock to local time doesn't help.(Slackware XFCE)
I even tried setting it to UTC and no dice.

I haven't tried this: (not on my Slack machine tonight)
Code:
As root (or sudo), do...

# date -s hh:mm:ss
http://forum.xfce.org/viewtopic.php?id=6799

I'm willing to work with all of you to find a solution.

Nothing I've tried fixes the clock; so far.

frankbell: DavidMcCann & Mr. Alex I'll try what you have advised and get back to you tomorrow.

@newbiesforever:
I know how you feel it's annoying that the clock isn't right.
If you happen to understand the page I linked kindly share the right formula (%H (hour) %M (minute)%S (second) Maybe?

This is the XFCE Clock page that my Slackware takes me to but it is a confusing mess IMO.
How can anyone get the right combinations of the percent signs with the correct characters set and in the right order?
http://docs.xfce.org/xfce/xfce4-panel/clock
 
Old 12-24-2014, 07:49 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
I tried:
Code:
hwclock --set --date="2011-08-14 16:45:05"
Only I used todays date (Dec 24, 2014)
Now my clock says 1:46 a.m It's really 8:45 p.m.

I tried :
Code:
hwclock --localtime -w
Clock is still saying 1:46 a.m.

Nothing works for me.

How is the clock working for you; newbiesforever?

Did you fix it?
 
1 members found this post helpful.
Old 12-25-2014, 11:18 AM   #9
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Iowa
Distribution: Debian distro family
Posts: 2,342

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ztcoracat View Post
I tried:
Code:
hwclock --set --date="2011-08-14 16:45:05"
Only I used todays date (Dec 24, 2014)
Now my clock says 1:46 a.m It's really 8:45 p.m.

I tried :
Code:
hwclock --localtime -w
Clock is still saying 1:46 a.m.

Nothing works for me.

How is the clock working for you; newbiesforever?

Did you fix it?
Nope...the command above simply didn't work. I have to get into the BIOS next time I reboot, assuming that's where the problem is.
 
Old 12-25-2014, 04:42 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by newbiesforever View Post
Nope...the command above simply didn't work. I have to get into the BIOS next time I reboot, assuming that's where the problem is.
Let me know if going into the BIOS settings (time) makes any difference?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Adjusting font size for Qt apps in Xfce kikinovak Slackware 3 02-15-2013 09:45 AM
LXer: Set the Xfce Clock the way you want it LXer Syndicated Linux News 0 11-28-2012 06:50 AM
Adjusting the digital clock appearance in kde Knightron Linux - Desktop 7 08-31-2012 08:54 PM
Xfce -- when watching video, LCD auto-adjusting to lowest brightness fastestOS Slackware 2 09-04-2009 11:17 AM
Adjusting fonts in XFCE jacatone Linux - Newbie 3 08-19-2008 04:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration