-   Linux - Software (
-   -   Adept Package Manager APT Database Error on Kubuntu 6.10 (

Alexbud10 07-12-2010 06:31 PM

Adept Package Manager APT Database Error on Kubuntu 6.10
I am running Kubuntu 6.10. I opened adept package manager to create a new repository. It opened and I created the new repository (/home/dell/repository/)it went through. I closed adept. Opened adept and a error message reading this popped up: "The APT database could not be opened! This may because by incorrect APT configuration or some similar problem. Try running apt-setup and apt-get in terminal and see if it helps resolve the problem." I ran it in terminal (I was online) for both and update and upgrade in both apt-get apt-setup, but it tells me "E: type "/home/dell/repository/" is not known on line 1 in source list /etc/apt/sources.list
E: The list of sources could not be read."
I tried opening Add/Remove Programs but it did the same thing as adept.
I am a linux newbie, and haven't toyed with APT database. When I added the new repository I just opened Manage Repositories and then entered "/home/dell/repository/", clicked add and it was put on the list as "Comment | /home/dell/repository/" in a grey text. I right clicked on it and clicked enable, it stayed grey. I left the program then. How can I fix the APT database?

Elv13 07-12-2010 09:27 PM

6.10 is 4 years old and was not a long term supported version. The real repository is down and it probably cause you a lot of problems. Even with local repository, if the computer is connected to the internet, you will get hacked one day or an other. If you want to use a Linux version for that long, be sure to take one with sufficient support length. Support for 6.10 ended in April 2008 and it is not recommended to use it in any connected scenarios.

That said, if you really don't want to change (not a wise decision, even if your hardware is old). Then your repository is probably not configured correctly. There is some tutorial on howtoforge and other sites that can help creating a working local Debian repository. It look like yours is broken or your entry in /etc/apt/source.list is invalid.

All times are GMT -5. The time now is 07:43 PM.