LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-11-2011, 06:29 PM   #16
LAPIII
Member
 
Registered: Mar 2009
Location: Virginia, US
Distribution: Ubuntu 10.10 & Debian 6.0.3,
Posts: 345

Original Poster
Rep: Reputation: 7

I just installed Opera 11.01 using:

Code:
deb http://deb.opera.com/opera/ stable non-free
and via bash:
Code:
sudo apt-get update
sudo apt-get install opera
I got this info from the OperaBrowser page of the Ubuntu documentation. Now I'd like help with
Making it more compatible with GNOME
. When entering at terminal:
Code:
mkdir ~/.opera
cat >> ~/.opera/filehandler.ini
I got:
Code:
lapiii@lapiii-desktop:~$ mkdir ~/.opera
mkdir: cannot create directory `/home/lapiii/.opera': File exists
lapiii@lapiii-desktop:~$ cat >> ~/.opera/filehandler.ini
 
Old 03-11-2011, 07:18 PM   #17
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
The output you posted says the directory and file are already there. If you want to modify it open it and follow the instructions on the Ubuntu page.
 
Old 03-11-2011, 07:49 PM   #18
LAPIII
Member
 
Registered: Mar 2009
Location: Virginia, US
Distribution: Ubuntu 10.10 & Debian 6.0.3,
Posts: 345

Original Poster
Rep: Reputation: 7
Quote:
Originally Posted by k3lt01 View Post
open it
Code:
gnome-open /home/lapiii/.opera
Quote:
Originally Posted by k3lt01 View Post
follow the instructions on the Ubuntu page.
If you meant
Quote:
Select the following text and paste it into your terminal by pressing Shift+Ins:

Opera Preferences version 2.0
; Do not edit this file while Opera is running
; This file is stored in UTF-8 encoding
[Settings]
Default File Handler=gnome-open ,1
Default Directory Handler=gnome-open ,1
Then I get this:
Code:
lapiii@lapiii-desktop:~$ Opera Preferences version 2.0
Opera: command not found
lapiii@lapiii-desktop:~$ ; Do not edit this file while Opera is running
bash: syntax error near unexpected token `;'
lapiii@lapiii-desktop:~$ ; This file is stored in UTF-8 encoding
bash: syntax error near unexpected token `;'
lapiii@lapiii-desktop:~$ [Settings]
[Settings]: command not found
lapiii@lapiii-desktop:~$ Default File Handler=gnome-open ,1
Default: command not found
lapiii@lapiii-desktop:~$ Default Directory Handler=gnome-open ,1
 
Old 03-11-2011, 08:04 PM   #19
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Code:
gksudo gedit ~/.opera/filehandler.ini
is what I would do to try and open it. I honestly don't know what the code is you posted. Once the file opens follow the instructions and paste in the text you have tried pasting into the terminal.
 
Old 03-11-2011, 08:57 PM   #20
LAPIII
Member
 
Registered: Mar 2009
Location: Virginia, US
Distribution: Ubuntu 10.10 & Debian 6.0.3,
Posts: 345

Original Poster
Rep: Reputation: 7
The contents of that file are:
Quote:
Opera Preferences version 2.0
; Do not edit this file while Opera is running
; This file is stored in UTF-8 encoding
[Settings]
Default File Handler=gnome-open ,1
The only difference between it and the text on the documentation for entering into a terminal is:
Quote:
Default Directory Handler=gnome-open ,1
Ctrl+D only closes the terminal!

Last edited by LAPIII; 03-11-2011 at 09:01 PM.
 
Old 03-11-2011, 11:53 PM   #21
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by Advice Pro View Post
The contents of that file are:
Yep

Quote:
Originally Posted by Advice Pro View Post
The only difference between it and the text on the documentation for entering into a terminal is:
So add it

Quote:
Originally Posted by Advice Pro View Post
Ctrl+D only closes the terminal!
Yep

I'm sorry but I fail to see what the problem is now. If you have successfully added that line to the file, successfully saved the file, and closed the terminal you are most of the way there. Is there anything else your having difficulty with?
 
Old 03-12-2011, 10:16 AM   #22
LAPIII
Member
 
Registered: Mar 2009
Location: Virginia, US
Distribution: Ubuntu 10.10 & Debian 6.0.3,
Posts: 345

Original Poster
Rep: Reputation: 7
I've added that line to the file and saved.
  1. How did you come up with adding that line to the file vs. the terminal as the document instructs?
  2. What did you mean by:
Quote:
Originally Posted by k3lt01 View Post
you are most of the way there.
 
Old 03-12-2011, 12:06 PM   #23
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by Advice Pro View Post
I've added that line to the file and saved.
Excellent
Quote:
Originally Posted by Advice Pro View Post
[*]How did you come up with adding that line to the file vs. the terminal as the document instructs?
If I can I use Gedit to edit files. I saw you failed at doing it with terminal so I used my brain, put 2 and 2 together and got Gedit I thought the nice thing to do would be to tell you how to do it that way and that would save you time, effort and frustration.
Quote:
Originally Posted by Advice Pro View Post
[*]What did you mean by:[/LIST]
It means you are nearly done.
 
Old 03-12-2011, 02:38 PM   #24
LAPIII
Member
 
Registered: Mar 2009
Location: Virginia, US
Distribution: Ubuntu 10.10 & Debian 6.0.3,
Posts: 345

Original Poster
Rep: Reputation: 7
Excuse my misunderstanding, but "nearly done" doing what? What comes next? I wasn't planning on making fonts in doing anything else on that doc.
 
Old 03-12-2011, 07:16 PM   #25
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by Advice Pro View Post
Excuse my misunderstanding, but "nearly done" doing what?
Setting Opera up to the way you like it.
Quote:
Originally Posted by Advice Pro View Post
What comes next?
Start Opera and use it!
Quote:
Originally Posted by Advice Pro View Post
I wasn't planning on making fonts in doing anything else on that doc.
I don't have any divine powers so I wonder how I was supposed to know this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Dynamic MMap ran out of room" error when adding new apt source list hasanito Debian 25 05-27-2013 04:56 AM
E:Type 'Reading' is not known on line 53 in source list /etc/apt/sources.list, E:The hunterclan0405 Linux - Newbie 2 01-16-2011 12:08 AM
'E:Malformed line 54 in source list /etc/apt/sources.list (dist parse), E:The list of vsssuccess@gmail.com Linux - Desktop 1 11-17-2010 09:17 AM
adding proc list and task list of active processes. pravin.embedded Linux - Newbie 1 09-02-2008 02:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration