-   Linux - Software (
-   -   Adding fonts to Ghostscript for printing (

MensaWater 03-28-2013 03:27 PM

Adding fonts to Ghostscript for printing
Iíll admit Iím not an expert in (or any level of user really) of Ghostscript myself.

We have a binary that is apparently looking for a font: n019003l.pfb

I found that font file does actually exist on my RHEL5 systems in two different locations:
-rw-r--r-- 1 root root 101436 Jul 12 2006 /usr/share/fonts/default/Type1/n019003l.pfb
-rw-r--r-- 1 root root 36026 Apr 24 2009 /usr/share/libwmf/fonts/n019003l.pfb

If I run gs Ėh as mentioned by man page it shows ďsearch pathĒ includes the first directory above but not the second one.

I see information in the man page about using GS_FONTPATH variable to set the directories but have read various sites online (this means I HAVE done a Google search so please donít suggest one) that make it appear this isnít always reliable. Setting the GS_FONTPATH does not change the output of gs Ėh and from what Iíve read I think what is output by gs Ėh is what it knew when Ghostscript was compiled.

Since I donít actually run the binary myself Iím just interested in finding some way to validate the font from second path is available to ghostscript if I add it somehow.

Iíve looked at the Init files but quite frankly donít understand them.

So my questions:
1) How can I be sure that Ghostscript is using the second path if Iíve added it to GS_FONTPATH?
2) Is there a better way to make the second path available to Ghostscript than GS_FONTPATH? (e.g. I see mention of ĖI flag and also discussion of adding fonts to Init files but what Iíve found mentions commands I donít have.)
3) Is it possible the font in the first directory has what is in the second directory given that it is so much larger? (The dates shown are on the files as installed from rpmís so donít reflect when they were actually installed on the system.)

I am of course asking the person doing the work on the application to discuss with the vendor that made it so please donít suggest we push back to the vendor. Iím simply trying to get alternate information as I suspect the issue may be they need the font in the second path rather than the one in the first path so wanted to see if there is any direction on how to tell ghostscript to use that and verify it is in fact using it.

My reason for thinking he needs the second path is that I ran a cksum on it and found it is exactly the same as the font of the same name that I found in gs Ėh output on an HP-UX server that previously ran the application. (Please donít mention md5sum Ė I know about it but it isnít available on the older HP-UX system and Iím not trying to validate security of the application but rather simply its cksum/size.)

bigrigdriver 03-29-2013 08:34 AM

Sounds like you are editing the wrong file to get ghostscript to use fonts. Look in /usr/share/ghostscript (the exact location in the directory tree will vary among distributions). Look for Fontmap.GS. That's the file to edit. The entries must follow a particular format which should be evident when you see the file.

Making Fonts Available To Ghostscript : Font HowTo

All times are GMT -5. The time now is 11:57 PM.